1. Android Central Question's Avatar
    My Galaxy Note 10 plus 5G camera doesn't start straight away.

    When I go to launch the app. Screen remains blank for 5 to 10 seconds before I can start taking photos or videos.

    This happens most times I go to use the camera.

    It happens from the quick launch on my lock screen and on home page where my camera app is located.

    Strangely when I Google the issue, the problem doesn't replicate.

    This is a default camera app that came with the phone.

    Model number is SM-976N
    12-10-2019 05:24 AM
  2. j_hansen's Avatar
    Have you tried clearing cache in the camera app itself?
    Maybe also try ang go into diagnostics to see if it shows any faults
    John614 likes this.
    12-10-2019 08:20 AM
  3. mustang7757's Avatar
    I agree try to clear data , cache and force stop the camera app.I'll leave a link to register so you can communicate here , as a guest account you can't.https://forums.androidcentral.com/sh...d.php?t=409154
    John614 likes this.
    12-10-2019 10:09 AM
  4. Rukbat's Avatar
    Try Google Camera. If that's also slow, it's the phone. If not, it's the app.

    If it's the phone, it's probably one of the camera modules, and that's a hardware problem, so it has to be replaced. (It's under warranty.)

    If it's the app, clearing the cache and data may help. (Force stop before clearing, so it doesn't load up junk between clearing and stopping.)

    (But you may find that you prefer the Google app to the stock app.)
    12-10-2019 05:36 PM
  5. John614's Avatar
    Hi guys,

    OP here. Thanks for the responses.

    I tried clear data, clear cache and force stop then reset phone.

    No difference.

    I will try to work out how to run diagnostics and create log.
    12-10-2019 06:07 PM
  6. John614's Avatar
    Not able to download google camera. App store says it's note compatible with my device.
    12-10-2019 06:26 PM
  7. John614's Avatar
    I also tried to install the Google camera from .APK file and it doesn't launch.
    12-10-2019 07:19 PM
  8. B. Diddy's Avatar
    Welcome to Android Central! Does this happen in Safe Mode as well? https://support.t-mobile.com/docs/DOC-40622
    12-10-2019 07:36 PM
  9. belodion's Avatar
    We can't help further if you don't respond.
    12-15-2019 11:55 AM
  10. zipro's Avatar
    Must be the phone - got zero issues with the camera app. Exynos version
    12-17-2019 04:23 PM

Similar Threads

  1. Moto G7 Play; Twitter refusing to open?
    By Android Central Question in forum Ask a Question
    Replies: 6
    Last Post: 12-15-2019, 09:53 PM
  2. Replies: 6
    Last Post: 12-10-2019, 05:44 PM
  3. Replies: 1
    Last Post: 12-10-2019, 12:19 AM
  4. How can I stop my S7 from dropping out of Android auto to phone when in a call?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-09-2019, 11:18 PM
  5. Note 10
    By 2kchevy in forum Samsung Galaxy Note 10 & Note 10+ (2019)
    Replies: 2
    Last Post: 12-09-2019, 10:58 PM
LINK TO POST COPIED TO CLIPBOARD