1. tonylinde's Avatar
    In my Galaxy Note 2 (from T-Mobile UK) I have a Sandisk 32Gb SDHC card. It worked fine for the first couple of months but just recently has begun saying that the card has been removed then asking if I want to reformat it etc . Just as others have noted here.

    However, when I got that message, I took a pic with the phone then used the 'My Files' app to look at /storage/sdcard0/DCIM/Camera and the pic was there! Just saw on another thread that sdcard0 is the internal memory. Doh!

    I saw that one recommendation was to copy stuff off the card then reformat to FAT32 and add the files/folders back. Unfortunately, I cannot get either my PC or Macbook to recognise the card. I tried using an Integral USB multi-card reader to load the card to the PC, also a microSD adapter directly into the PC's SD slot. Neither worked (though the multi-card reader brought up errors about a system reserved drive K!). Do I need a special driver to read the Samsung formatted card?

    Anyone got any ideas?

    Thanks,
    Tony.
    01-19-2013 07:28 AM
  2. MobileMadness002's Avatar
    If your computer fails to read it using an external card reader, you can be pretty safe presuming the card is garbage now. If you cannot format the drive directly in the computer, then replace it. Personally I use a a Kingston 32 GB SDHC and have yet to experience any issues in my BlackBerry nor in my S3.

    PS. No, no special drivers required to read your usb card in the computer.
    tonylinde likes this.
    01-19-2013 12:20 PM
  3. tonylinde's Avatar
    Thanks for that. Just ordered a Kingston 32Gb Class 4 from Amazon. Guess I should format it with FAT32 in the PC before loading into the phone.

    (BTW, Amazon offered to take the duff card back, even after 3 months, but I finally decided that if I couldn't wipe the card, I didn't really want it out in the wild.)

    t.
    01-19-2013 12:57 PM
  4. aquafusiondane's Avatar
    Mmmm that the same card that my friend is using for her Sprint Note 2. She complaining sometime it did just that too. I thought something must be wrong with the phone. But since you guys have the same sd card, apparently it the sd card. I am using AmazonBasics 16gb class 10 on my phone and never have any problem with it

    Sent from my T-Mobile Samsung Galaxy Note 2 on Tapatalk 2
    01-19-2013 06:21 PM

Similar Threads

  1. 2 Years worth of data on my SD card not being read on Thunderbolt. WTF?
    By Bassman125 in forum Verizon HTC Thunderbolt
    Replies: 5
    Last Post: 02-09-2013, 11:44 AM
  2. SD card not being read on new Optimus S
    By imapotato in forum LG Optimus S
    Replies: 3
    Last Post: 08-10-2011, 09:34 AM
  3. Updates to apps on SD card problem
    By cataylo6 in forum HTC EVO 4G
    Replies: 4
    Last Post: 02-18-2011, 08:18 PM
  4. SD card problem
    By JesseJames101 in forum Verizon Droid Incredible
    Replies: 4
    Last Post: 05-30-2010, 09:13 AM
  5. Droid sd card problems?
    By azezial in forum Motorola Droid
    Replies: 4
    Last Post: 11-30-2009, 03:23 PM
LINK TO POST COPIED TO CLIPBOARD