1. katrose08's Avatar
    I have an international Note 2, and I'm using a nano sim with an adapter. It has been working fine since November, however the other day it beeped and when I looked at it, it was telling me to insert a valid SIM card. I tried restarting, taking the sim out and putting it back in, etc, nothing is working.
    Anyone know of any fixes for this? Or somewhere that might fix it for me? I live ear Brampton, Ontario.
    01-20-2013 08:08 PM
  2. lynnneil's Avatar
    Is it a unlocked phone?
    01-21-2013 04:18 AM
  3. katrose08's Avatar
    It is, I actually found out that one of the little pins that holds and reads the sim card has broken off somehow, so I have to replace the whole sim tray. Lucky me!
    01-22-2013 01:27 PM
  4. Cravenhaven's Avatar
    Thanks so much for that post. I have been trying to figure out why my Ozzie phone stopped working while in the UK. I bought a local "3" sim and it worked for 3 days then just stopped. It was sitting on the bedside table and I must have heard it make a sound, when I looked it said that the sim had been removed ????. After that I couldnt get any UK sim to work, though my Ozzie sim seemed ok ie the phone seemed to recognise that it had a sim installed (but no OS roaming enabled).
    I tried re-installing the firmware, upgraded the firmware and was about to try a jailbreak when I came across your post.
    When I looked at the sim tray I could see one of the gold fingers bent outwards over the back of the sim tray. I levered it up slightly with a pocket knife and reinserted the sim and voila I have service.
    Guess I'll have to get the sim tray replaced now, but its great to have it working again.
    09-21-2013 09:55 AM

Similar Threads

  1. VZW S3 intermittently saying "No SIM"
    By rokstarr in forum Verizon Galaxy S III
    Replies: 175
    Last Post: 03-22-2014, 11:07 AM
  2. For those wondering, no, the Verizon Note II isn't SIM unlocked.
    By cj100570 in forum Verizon Galaxy Note 2
    Replies: 27
    Last Post: 04-26-2013, 04:06 PM
  3. S3 SAYS INSERT SIM,(sim inserted....)
    By prunz in forum Samsung Galaxy SIII I9300
    Replies: 3
    Last Post: 12-24-2012, 03:50 PM
  4. Anyone say "no" to iPhone 5 and "yes" to Note 2?
    By mountainman in forum Samsung Galaxy Note 2
    Replies: 55
    Last Post: 10-26-2012, 10:23 PM
  5. Mounting SD card, even when I say no
    By DevilInPgh in forum HTC EVO 4G
    Replies: 9
    Last Post: 08-10-2010, 03:32 PM