1. Sh3ngLong's Avatar
    Every time I start my car, my Note 2 automatically connects to my car's bluetooth system and the Music Player apps automatically starts playing music. Is there any way to prevent it from playing music automatically?

    I know I can always go into my phone's Bluetooth Settings and uncheck "Media audio", but I prefer to keep this checked because I still would like to stream audio from other apps, like TuneIn Radio, Pandora, SlingPlayer, or the Navigation app. I usually listen to ESPN Sports Center or the local news through SlingPlayer, but I always have to stop the Music Player app first.

    I do have Tasker, but I can't seem to find a way to prevent Music Player from automatically playing.

    Any ideas?
    04-06-2013 11:30 PM
  2. androidluvr2's Avatar
    Every time I start my car, my Note 2 automatically connects to my car's bluetooth system and the Music Player apps automatically starts playing music. Is there any way to prevent it from playing music automatically?
    Do you have Motospeak installed on your phone?
    04-06-2013 11:38 PM
  3. Sh3ngLong's Avatar
    Nope, no Moto Speak.


    ** Sent from my Galaxy Note II **
    04-07-2013 12:17 AM
  4. Windfrenzy's Avatar
    Try this : in Tasker set up a profile called "car connected" or something. Trigger it with State;net;bluetooth connected and put in the name of your car connection. Then make it run a task clicking media;music stop. That might work. I use my car connected profile to turn on Waze and Beyondpod when it connects.

    Sent from my Galaxy Nexus using Android Central Forums
    04-07-2013 12:33 AM
  5. Sh3ngLong's Avatar
    Yeah, that was first thing I tried and that didn't work. I also created a task to kill app, and that didn't work either.

    ** Sent from my Galaxy Note II **
    04-07-2013 01:21 AM
  6. 1812dave's Avatar
    I have the same annoying issue. If I connect my Note 2 to my Camry's USB connector (simply to charge it), the damn thing always starts up music, interrupting Pandora (playing thru Entune). Drives me nuts. Only solution I've found for the car is never use the USB connector to charge.
    04-07-2013 12:51 PM
  7. Sh3ngLong's Avatar
    Try this : in Tasker set up a profile called "car connected" or something. Trigger it with State;net;bluetooth connected and put in the name of your car connection. Then make it run a task clicking media;music stop. That might work. I use my car connected profile to turn on Waze and Beyondpod when it connects.
    I found a setup in Tasker that finally resolved this annoying autostart problem.

    I created a task called "Stop Music" which does these four actions when it detects a Bluetooth connection with my car:

    1) Action 1 mutes the media volume. (Audio > Media Volume > Level 0)
    2) Action 2 is an 8 second wait time before doing Action 3 (Task > Wait > 8 seconds)
    3) Action 3 stops/closes the Music Player app. (Media > Media Control > Stop)
    4) Action 4 increases the media volume to max (Audio > Media Volume > Level 15)

    Couple of Notes:
    * I had to put in a wait time because without it, it would try to stop the Music Player app before it even loaded. So it would misfire the stop action and the Music Player would start playing.
    * I had to mute the media volume at the beginning because if I didn't do that, sometimes I'll hear the first second of the music before it shuts down, which is pretty annoying.

    I'm sure there's a simpler way to do this, but so far this setup is working great for me. Now I no longer have to worry about my Tupac music blasting in the car when I go out to lunch with my boss or the CEO of the company.
    04-07-2013 09:03 PM
  8. jneusch's Avatar
    I believe Power Amp has a setting that prevents this also.

    Sent from my SCH-I605 using Android Central Forums
    04-08-2013 09:39 AM
  9. RobFreundlich's Avatar
    I believe Power Amp has a setting that prevents this also.
    I'm having the same problem as the OP, and used the PowerAmp setting to turn off the auto-play on BT connect. So the next time I connected, the stock music player started up. It has no equivalent setting.

    Both my wife and I thought there's a system-wide setting to turn off this behavior, but we can't find it. Anyone else know where it is?
    05-22-2013 07:53 PM
  10. Newbie2415's Avatar
    Does using the Tasker process work for an S4?
    09-13-2013 12:33 PM
  11. bunnybash's Avatar
    This is really strange I have never had this issue with my note 2 and I use it with bluetooth media streaming every day!

    Sent from my GT-N7100 using Tapatalk 4
    09-13-2013 01:35 PM
  12. justinsu's Avatar
    Try Media Button Router on Google Play.
    This is best solution I have seen so far.
    09-29-2013 01:11 AM
  13. IKMNewman's Avatar
    That sorted it.... Any idea how to stop it saying "Play with what?" .

    Thanks, Ian.
    11-18-2013 12:05 PM
  14. techitrucker's Avatar
    In the settings for Media Button Router check disable text to speech. I also unchecked all the programs and set timeout to "to fast". Works like a charm. Only problem is when a program with media gets updated by Google Play it automatically checks its box again so you will need to manually uncheck it after and update.

    Posted via Android Central App
    11-19-2013 03:26 AM
  15. KillerWee's Avatar
    Did you guys check inside your music program to see if any tracks were set in queue?
    I've been having the same issues with my HTC One, and since I have more than one song on there, I found it odd that it was always the same song it was playing.
    So I checked it, and sure enough.. It was on queue, but not anymore.. Problem Solved..
    12-12-2013 11:20 PM
  16. Rotgut Redbeard's Avatar
    I registered just to thank you for the awesome, app-less fix. I opened my music player and deleted the music that was queued. Now there's nothing to play once it connects!

    Cheers!

    Posted via Android Central App
    03-14-2014 07:56 PM
  17. stueycaster's Avatar
    Thanks @Sh3ngLong. This took care of the problem. Then I added a second profile named Heatset Menu:

    Action 1 is a 10 second wait time so that the first profile can complete. Action 1 (Task>Wait>10 seconds)
    Action 2 is a menu with choices. Action 2 (Alert>Menu>Layout=IconGridMenu>Timeout (Seconds)=30>Items>+Action=App>Launch App>Select App 1>+Action=App>Launch App>Select App 2)

    Puts a nice little menu up so you can choose your app. You can add as many apps as you want to this menu.
    07-27-2014 06:41 AM
  18. prepaidguy9081's Avatar
    Every time I start my car, my Note 2 automatically connects to my car's bluetooth system and the Music Player apps automatically starts playing music. Is there any way to prevent it from playing music automatically?

    I know I can always go into my phone's Bluetooth Settings and uncheck "Media audio", but I prefer to keep this checked because I still would like to stream audio from other apps, like TuneIn Radio, Pandora, SlingPlayer, or the Navigation app. I usually listen to ESPN Sports Center or the local news through SlingPlayer, but I always have to stop the Music Player app first.

    I do have Tasker, but I can't seem to find a way to prevent Music Player from automatically playing.

    Any ideas?
    Use xposed modules receivers modual and turn off the bluetooth state receiver on your music app.

    Apps have these things called receivers. For example facebook has one that tells it to boot at startup and also to boot on sd card media scan. So to make it not boot at startup you must disable these receivers.

    Rom toolbox may also be able to do this but I prefer to use the xposed modules.

    By the way, this is a rooted solution.

    Sent from my SAMSUNG-SGH-I317 using Tapatalk 4
    07-30-2014 04:48 AM
  19. benandholly's Avatar
    Maybe I have a different version or something but how does one remove songs from the queue?
    08-04-2014 05:59 AM
  20. benandholly's Avatar
    In response to KillerWee's suggestion how does one remove songs from the queue?
    08-04-2014 06:00 AM
  21. Gerald Zennie's Avatar
    I purchased Tasker then found out I didn't need it. My music is on an SD-card in my phone. Before connecting to vehicle Bluetooth, go to Settings on phone, then Storage, then Unmount SD-card. When you want to listen to your music, just mount SD-card.
    10-14-2014 10:42 PM
  22. Gohae's Avatar
    Do you have Motospeak installed on your phone?
    I'm having the same issue with mine and I do have Motospeak installed. I turned off "Enable Automatic Launch" under Bluetooth for Devices in the Advanced settings in my Pandora app, but it still auto-launches when it connects to my car.
    11-07-2015 08:22 AM

Similar Threads

  1. Any Way To Prevent Music Player Autostarting With Bluetooth?
    By DirkBelig in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 41
    Last Post: 01-06-2017, 06:47 PM
  2. Is there any way to transfer music from Nexus 7 to ipod shuffle?
    By newkitten123 in forum Google Nexus 7 Tablet (2012)
    Replies: 11
    Last Post: 04-09-2013, 08:14 AM
  3. Is there a 4G icon on the status bar when connected?
    By ce2dope in forum Sprint Galaxy S III
    Replies: 10
    Last Post: 08-22-2012, 03:02 PM
  4. Is there a way to prevent it from locking?
    By hyperphantom in forum HTC EVO 3D
    Replies: 6
    Last Post: 07-06-2011, 08:32 PM
  5. Is there a way to get the music apk from the galaxy?
    By StayFly in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 07-26-2010, 07:22 PM
LINK TO POST COPIED TO CLIPBOARD