1. furrburger's Avatar
    I received a galaxy note 2 from my brother Which he dropped on the ground causing damage to the charge port. The phone would not recognize USB charging after the drop. I ordered a new charge port flex from eBay and installed it. After installation the phone would charge but once plugged into the computer it would not sense it as a USB device. Is this a defective part or is there another section of the phone that holds USB connectivity Other than the charge port? I am also using the original note 2 Data cable and software is installed on the computer. I also tried uninstalling and reinstalling the software as well. Thanks for the help guys anything is appreciated. I spent countless hours and days on this trying to figure it out with no success and I hope someone has had this problem and can solve it for me.
    06-01-2013 11:23 AM
  2. friedtators's Avatar
    its gotta be the part. something is different about the new working part
    furrburger likes this.
    06-01-2013 11:37 AM
  3. soulstlr's Avatar
    hello furrburger...
    do you happen to have the usb drivers installed on pc? (available on samsung site)
    also read of similar problems peeps are having since latest update...
    perhaps uninstall pc drivers (if installed) and check for newer versions, also don't forget to reboot...
    furrburger likes this.
    06-01-2013 12:40 PM
  4. jdub1981's Avatar
    Deleted
    06-01-2013 04:54 PM
  5. furrburger's Avatar
    Thanks soulstlr but I have tried everything you've mentioned with no success. I'll probably try to order a new flex cable and see if that was infact the problem. I just wanted to make sure that the USB flex was not souly for the mic and charging but not for USB data transferring.
    06-01-2013 07:02 PM
  6. jdub1981's Avatar
    here is a helpful video from youtube on this exact problem.
    furrburger likes this.
    06-01-2013 08:41 PM

Similar Threads

  1. Droid Charge USB not recognized
    By twitch93 in forum Verizon Droid Charge
    Replies: 8
    Last Post: 08-20-2012, 09:32 PM
  2. <HELP>: Bluetooth Headset Not Recognized after Flashing ROM
    By HKQT in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 14
    Last Post: 12-09-2011, 08:27 AM
  3. Usb not recognized
    By AAG607 in forum Verizon Droid Incredible 2
    Replies: 6
    Last Post: 09-23-2011, 06:12 PM
  4. USB not recognizing on vista?
    By durangojim#AC in forum Verizon Fascinate
    Replies: 9
    Last Post: 05-22-2011, 11:01 AM
  5. USB not mounting after switching kernel.
    By pyg1991 in forum Verizon Droid Incredible
    Replies: 1
    Last Post: 02-14-2011, 06:51 AM
LINK TO POST COPIED TO CLIPBOARD