1. naeemomar20's Avatar
    Hi guys
    New to the forum
    Any help with this appreciated..

    When trying to download any apps from either store the ffg error comes up :

    "your device is not compatible with this version "

    running version 4.1.2
    09-21-2013 11:32 AM
  2. Hamidd's Avatar
    What is your country? Maybe Google has restricted accessing apps for your country!
    09-22-2013 03:28 AM

Similar Threads

  1. My Samsung Galaxy S3 Mini won't turn the screen of while resting
    By litteraturfrik in forum Samsung Galaxy S3 Mini
    Replies: 19
    Last Post: 11-04-2015, 03:00 AM
  2. S4 Mini: Camera Zoom Problem
    By ebeskimo in forum Samsung Galaxy S4 Mini
    Replies: 11
    Last Post: 12-28-2014, 06:24 PM
  3. Welcome (and welcome back) to the wonderful world of BBM
    By Kevin Michaluk in forum BBM for Android
    Replies: 68
    Last Post: 05-15-2014, 12:57 PM
  4. Group Message Problem
    By jaydow11 in forum HTC One M7
    Replies: 3
    Last Post: 10-22-2013, 02:52 AM
  5. S3 screen problem
    By RealEliasJaber in forum Samsung Galaxy SIII I9300
    Replies: 3
    Last Post: 09-28-2013, 06:59 PM
LINK TO POST COPIED TO CLIPBOARD