1. asdfkjhg's Avatar
    My SD card seems to have some kind of unknown error. When I use my camera, it usually saves into the DCIM\Camera folder in my SD card. But suddenly, the Camera folder has been renamed to "AMERA". Inside the AMERA folder, all of the photo files have become completely unreadable, and there are also some strange folders and files in there that were never there before. To top it off, the SD card and the files inside cannot be altered in any way. Files cannot be moved, renamed, or deleted. New folders cannot be made. And new files cannot be saved into the SD card.

    Besides the AMERA folder and its contents, all other files, music, pictures, videos, etc, can be opened on the phone just fine, though they cannot be moved, deleted or renamed on the phone.

    When I insert my SD card into the computer, the files inside the AMERA folder cannot be copied into the computer, and the photos are still unreadable. But otherwise, the folder and the files inside can be renamed, and all other files and folders can be deleted, renamed or moved just fine. But if I try to rename the AMERA folder, then when I put the SD card back into my phone, it just creates another AMERA folder.

    What can I do to fix this, so that I can alter files in my SD card when it's in my phone? And is there any way to recover my photos so that they can be read again? I'm thinking of backing up my SD card files and then formatting the card, but if I can't even copy the unreadable photos into my computer, then are they truly lost forever? Has this problem occurred in the past?

    Please help.
    10-08-2013 01:01 PM
  2. Haalcyon's Avatar
    This is indeed strange. I know you don't want to at this point but I wonder if the phone would be able to reformat the SD card. It may be worth getting an OTG cable and pluggling the card into a reader and seeing if you could copy the photos to another internal storage or another SD card.
    10-08-2013 01:31 PM
  3. Gras's Avatar
    I have the exact same problem right now with a card from my S4. Anyone heard of this before??
    10-14-2013 05:59 AM
  4. _X_'s Avatar
    I had the same error with my SD card. Same issues, but the issues worsened, the whole file system became read only.

    What I did was remove the SD card backup everything to my computer reformat (from my phone) the card then everything was good again.
    10-14-2013 03:04 PM
  5. asdfkjhg's Avatar
    I found a solution that (more or less) solved my problem. I happened to have kept my old Android phone, and I experimented by switching their SD cards. Here are the results. Both cards worked perfectly in the opposite devices. The SD card from my Galaxy Note 2, the one with the error I'm talking about, worked perfectly on my Galaxy S(1) phone. It wasn't read-only, and files and folders can once again be changed and new ones can be saved. The SD card from my old Galaxy S also worked perfectly on my Galaxy Note. I switched them back, and now it's working perfectly again.

    HOWEVER, the only drawback I have is that the AMERA folder is gone, along with all the possibly(?) recoverable photo files inside. So all of my photos have been lost.
    10-20-2013 03:36 PM

Similar Threads

  1. HTC One - No sim card error?
    By Topgonzo in forum HTC One M7
    Replies: 55
    Last Post: 01-29-2017, 02:30 AM
  2. HELP! Stuck in Secure Booting Error!
    By 3rdEyeBlue in forum LG Optimus G
    Replies: 5
    Last Post: 03-01-2014, 07:19 PM
  3. Error installing android 4.3 on HTC One
    By breadmaker98 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 3
    Last Post: 10-19-2013, 08:02 PM
  4. Samsung Galaxy mini 2 S6500D Wifi error
    By Luka Zupanovic in forum General Help and How To
    Replies: 1
    Last Post: 10-08-2013, 02:30 PM
  5. Replies: 4
    Last Post: 10-08-2013, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD