09-26-2014 04:44 PM
152 12345 ...
tools
  1. Paul Ackers's Avatar
    Hi Kelly
    Thank you for your suggestion. I have installed wake lock and will conduct test. However it doesn't address why this awful drain is happening POST 4.3 update. I was perfectly happy getting 2 days out of a full charge on 4.1.2 I have actually uninstalled various apps since 4.3 to help reduce load etc so in fact I am running less on my phone (other than any new processes brought in by update and no I am not running Knox) than before. Wake lock may help identify what is causing the issue brought about solely by a supposed update.
    I also remain troubled by the inability to restore app saved data. Cheers.

    Posted via Android Central App
    anon(8408674) likes this.
    12-20-2013 08:52 AM
  2. jsmat's Avatar
    Here are the wakelock images. Today aswell battery drained in about 15 hours. it seems that it doesn't even matter how much i use my phone, battery drains out in about 15-16 hrs. today my usage was calls and a bit of gaming. What can you make of the wakelock stats? Help me solve this.
    Note 2: Battery Drain after 4.3 update-2013-12-20-20-58-51.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-20-59-07.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-20-59-43.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-21-00-08.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-21-00-19.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-21-00-30.png
    Note 2: Battery Drain after 4.3 update-2013-12-20-21-00-37.png
    12-20-2013 10:44 AM
  3. Rishi Ashar's Avatar
    Here are the wakelock images. Today aswell battery drained in about 15 hours. it seems that it doesn't even matter how much i use my phone, battery drains out in about 15-16 hrs. today my usage was calls and a bit of gaming. What can you make of the wakelock stats? Help me solve this.
    Click image for larger version. 

Name:	2013-12-20-20-58-51.png 
Views:	105 
Size:	182.4 KB 
ID:	97645
    Click image for larger version. 

Name:	2013-12-20-20-59-07.png 
Views:	349 
Size:	117.7 KB 
ID:	97646
    Click image for larger version. 

Name:	2013-12-20-20-59-43.png 
Views:	350 
Size:	136.6 KB 
ID:	97647
    Click image for larger version. 

Name:	2013-12-20-21-00-08.png 
Views:	347 
Size:	81.6 KB 
ID:	97648
    Click image for larger version. 

Name:	2013-12-20-21-00-19.png 
Views:	343 
Size:	76.0 KB 
ID:	97649
    Click image for larger version. 

Name:	2013-12-20-21-00-30.png 
Views:	344 
Size:	67.2 KB 
ID:	97650
    Click image for larger version. 

Name:	2013-12-20-21-00-37.png 
Views:	341 
Size:	59.0 KB 
ID:	97651
    The I had atleast 85% wakelock which started heppening some days back and the culprit was Google Play Service.. Nothing helped.

    There has been an update released :N7100XXUEMKD 3-4 days back.

    I just did factory reset -> installed the upgrade, then again factory reset.

    The wakelocks are gone.and my battery life is like 27 hrs approx with:
    Moderate internet use
    WIFI- ON all the time
    MOBILE DATA: ON all the time
    Brightness: Auto
    Smartstay - ON
    12-20-2013 12:24 PM
  4. Kelly Kearns's Avatar
    Hi Kelly
    Thank you for your suggestion. I have installed wake lock and will conduct test. However it doesn't address why this awful drain is happening POST 4.3 update. I was perfectly happy getting 2 days out of a full charge on 4.1.2 I have actually uninstalled various apps since 4.3 to help reduce load etc so in fact I am running less on my phone (other than any new processes brought in by update and no I am not running Knox) than before. Wake lock may help identify what is causing the issue brought about solely by a supposed update.
    I also remain troubled by the inability to restore app saved data. Cheers.

    Posted via Android Central App
    Did you reset first? I never do an update without a reset after as many don't. Many of us have found there will be various problems after an update and most times a reset clears them up..
    12-20-2013 01:57 PM
  5. Kelly Kearns's Avatar
    The I had atleast 85% wakelock which started heppening some days back and the culprit was Google Play Service.. Nothing helped.

    There has been an update released :N7100XXUEMKD 3-4 days back.

    I just did factory reset -> installed the upgrade, then again factory reset.

    The wakelocks are gone.and my battery life is like 27 hrs approx with:
    Moderate internet use
    WIFI- ON all the time
    MOBILE DATA: ON all the time
    Brightness: Auto
    Smartstay - ON
    Most times just a reset after the update corrects it all, not always, but most of the time.
    12-20-2013 02:00 PM
  6. Kelly Kearns's Avatar
    Here are the wakelock images. Today aswell battery drained in about 15 hours. it seems that it doesn't even matter how much i use my phone, battery drains out in about 15-16 hrs. today my usage was calls and a bit of gaming. What can you make of the wakelock stats? Help me solve this.
    I don't remember..do you have an extended battery? I'm not sure what is wrong with 15 hour battery usage..that's a good battery usage.

    Post your battery screen and the detail screen of the battery graph.
    12-20-2013 02:02 PM
  7. Paul Ackers's Avatar
    Hi Kelly Yes I'd read the recommendation to do a factory reset as per my post and it is that which is the culprit for wiping my app data. I've reset and restored as much as I can following the 4.3 update but still poor battery life (another 40% drop with minimal/average use in 4-5 hours) and apps without data

    Posted via Android Central App
    12-20-2013 02:31 PM
  8. Kelly Kearns's Avatar
    Hi Kelly Yes I'd read the recommendation to do a factory reset as per my post and it is that which is the culprit for wiping my app data. I've reset and restored as much as I can following the 4.3 update but still poor battery life (another 40% drop with minimal/average use in 4-5 hours) and apps without data

    Posted via Android Central App
    Can you post some battery screenshots? The graph battery page and the detail also and the display info?
    12-20-2013 02:54 PM
  9. Rishi Ashar's Avatar
    Most times just a reset after the update corrects it all, not always, but most of the time.
    Actually I forgot to mention that I tried other things as well.
    This was my last resort, and i posted this coz it worked for me not once but thrice.

    So I would strongly encourage others to consider this option as promising, if other means don't fix your problem
    12-20-2013 04:11 PM
  10. beldie11's Avatar
    All I did was follow this sequence Factory reset->firmware upgrade->factory reset before use.
    Can you elaborate how did you do this? which software did you used for the "factory reset before use"? Because such opstion isn't on my note at all except for Settings>Accounts>BackUp and Restore>Factory Settings!!
    12-20-2013 06:52 PM
  11. srvctec's Avatar
    Can you elaborate how did you do this? which software did you used for the "factory reset before use"? Because such opstion isn't on my note at all except for Settings>Accounts>BackUp and Restore>Factory Settings!!
    I believe he was just giving a general statement of what he did, not the exact path on how to do it. You factory reset your device under backup and restore then download the update and install it and then factory reset again.
    12-20-2013 07:33 PM
  12. beldie11's Avatar
    I believe he was just giving a general statement of what he did, not the exact path on how to do it. You factory reset your device under backup and restore then download the update and install it and then factory reset again.
    Fair enough.
    But even so it doesn't makes sense. Everyone is in this thread is complaining about drain issues after installing 4.3. Now, even following the factory reset trough back up and restore there is no update...as it IS already installed. This is also confusing as some people here pointed at installing the firmware again.
    If I get that straight it should be mentioned that it should be reinstalled again trough Kies.
    12-20-2013 08:26 PM
  13. Kelly Kearns's Avatar
    Actually I forgot to mention that I tried other things as well.
    This was my last resort, and i posted this coz it worked for me not once but thrice.

    So I would strongly encourage others to consider this option as promising, if other means don't fix your problem
    Samsung told me there was a problem with Google location services and it was causing battery drain and connected to the play store. They also said Google is aware and working on a fix..
    anon(8408674) likes this.
    12-20-2013 09:41 PM
  14. Rishi Ashar's Avatar
    Samsung told me there was a problem with Google location services and it was causing battery drain and connected to the play store. They also said Google is aware and working on a fix..
    OH MY GOD!! you got that from Samsung??

    It's very unfortunate that Samsung don't even know here in India that a 4.3 release has been launched ...lol...I actually gave up all the hope on getting any help from Samsung, as they don't help such deep investigation (anything apart from their conventional process) like going and checking on the wakelocks.

    I don't have any explanation on how this works but the NlpWakeLock within google services was causing the battery drain.

    Now after the reset->firmware reinitialization (through kies) -> reset, I am using the same google play services, but don't see the phone battery being drained due to the wakelocks.

    As Samsung just released the N7100XXUEMKD update couple of days back (which is a bug fix release), after installing it I didn't find the wakelocks problem getting solved (of course it is solved after reset->firmware reinitialization but not immediately after the udpate without these steps).

    Let's hope they get this fix in their forthcoming update!
    12-20-2013 10:35 PM
  15. Rishi Ashar's Avatar
    Fair enough.
    But even so it doesn't makes sense. Everyone is in this thread is complaining about drain issues after installing 4.3. Now, even following the factory reset trough back up and restore there is no update...as it IS already installed. This is also confusing as some people here pointed at installing the firmware again.
    If I get that straight it should be mentioned that it should be reinstalled again trough Kies.
    Sorry for not being clear. what i meant was to connect to kies -> do the firmware re initialization (In case you have already installed the update).

    Thanks for clearing out the confusion. !

    I myself started this thread as I found that the 4.3 upgrade was a disaster, and it hampered the phone battery massively. and Samsung don't seem to have targeted this issue in their first bug fix release either.
    12-20-2013 10:50 PM
  16. Hamid Bhurgari's Avatar
    PROBLEM FIXED!
    I figured out the problem. After the 4.4.2 update I decided to use ART instead of Dalvic in the Developer Options in Settings. Right after that I started having battery issues. I revert it back to Dalvic but it did not fix the issue until I Factory re setted the phone. So, it seems 4.4x updated messed something up with ART and it can not be fixed unless A. you change the setting back to Dalvic, Reboot and B. Reset the phone. Must do both steps. Only changing the setting will not work. My battery life is back to normal now. I hope this helps others.
    12-21-2013 03:04 AM
  17. Paul Ackers's Avatar
    Can you post some battery screenshots? The graph battery page and the detail also and the display info?
    Thanks again Kelly for suggesting Wakelock. I have been running it for 4 hours and found Facebook and Samsung Push Services with 100+ times! I have removed many of the Facebook notifications and set refresh time to 2 hours (default 1 hour) and totally switched off Samsung Push notifications as this 100+ in 4 hours is extreme ffs. The next culprit is Screen (well I expected that) & Android OS. I'll wait to see how the Facebook and Samsung changes affect battery performance before I do anything else. However it does need to be noted that these apps/services were running on 4.1.2 perfectly well - 2 days battery on normal use!!

    What I STILL need to get to the bottom of is how I prevent total app data loss after a factory reset. As I said before I followed this instruction after I updated to 4.3 and it wiped all my saved/progress data and Calendar DESPITE me using KIES to back everything up!! Restoring only replaced the apps but NONE of the data/progress/saves or calendar items. I totally fear doing any further factory resets until I know how to save ALL my data and how to successfully FULLY restore it. Anybody help?
    12-21-2013 07:17 AM
  18. beldie11's Avatar
    Thanks again Kelly for suggesting Wakelock. I have been running it for 4 hours and found Facebook and Samsung Push Services with 100+ times! I have removed many of the Facebook notifications and set refresh time to 2 hours (default 1 hour) and totally switched off Samsung Push notifications as this 100+ in 4 hours is extreme ffs. The next culprit is Screen (well I expected that) & Android OS. I'll wait to see how the Facebook and Samsung changes affect battery performance before I do anything else. However it does need to be noted that these apps/services were running on 4.1.2 perfectly well - 2 days battery on normal use!!

    What I STILL need to get to the bottom of is how I prevent total app data loss after a factory reset. As I said before I followed this instruction after I updated to 4.3 and it wiped all my saved/progress data and Calendar DESPITE me using KIES to back everything up!! Restoring only replaced the apps but NONE of the data/progress/saves or calendar items. I totally fear doing any further factory resets until I know how to save ALL my data and how to successfully FULLY restore it. Anybody help?
    TBH I have never restored anything trough Kies, but regarding the calendar I have mine synced with the google one. It works. It doesn't matter haw many times I wipe my phone, I just resync it with the google one and everything is on my calendar as it used to be.
    12-21-2013 08:57 AM
  19. Kelly Kearns's Avatar
    OH MY GOD!! you got that from Samsung??

    It's very unfortunate that Samsung don't even know here in India that a 4.3 release has been launched ...lol...I actually gave up all the hope on getting any help from Samsung, as they don't help such deep investigation (anything apart from their conventional process) like going and checking on the wakelocks.

    I don't have any explanation on how this works but the NlpWakeLock within google services was causing the battery drain.

    Now after the reset->firmware reinitialization (through kies) -> reset, I am using the same google play services, but don't see the phone battery being drained due to the wakelocks.

    As Samsung just released the N7100XXUEMKD update couple of days back (which is a bug fix release), after installing it I didn't find the wakelocks problem getting solved (of course it is solved after reset->firmware reinitialization but not immediately after the udpate without these steps).

    Let's hope they get this fix in their forthcoming update!
    I'm not having a drain, but noticed a TON of wakelocks for Google Play. The rep I talked to said he actually f found something about it at xda. I think he was looming up the wakelock app I recommended to you guys because it was developed by someone from xda.
    12-21-2013 10:00 AM
  20. 1812dave's Avatar
    . I think he was looming up the wakelock app I recommended to you guys because it was developed by someone from xda.
    can u rephrase that? no idea what you meant
    12-21-2013 01:16 PM
  21. Kelly Kearns's Avatar
    He was looking up the wakelock app I recommended, it was developed by someone at xda and he saw on xda that others are having a problem with play store "running" all the time. He then researched more and found out Google is aware and working on a fix, it has to do with the Google location service.
    12-21-2013 11:30 PM
  22. jsmat's Avatar
    OK... still no luck with the issue.
    I unlocked developer options and clicked no background processes instead of Standard limit....now the wakelocks are at 81% instead of 77%.

    Samsung c'mon!!!
    12-21-2013 11:41 PM
  23. jsmat's Avatar
    PROBLEM FIXED!
    I figured out the problem. After the 4.4.2 update I decided to use ART instead of Dalvic in the Developer Options in Settings. Right after that I started having battery issues. I revert it back to Dalvic but it did not fix the issue until I Factory re setted the phone. So, it seems 4.4x updated messed something up with ART and it can not be fixed unless A. you change the setting back to Dalvic, Reboot and B. Reset the phone. Must do both steps. Only changing the setting will not work. My battery life is back to normal now. I hope this helps others.

    can you elaborate??? ART ? Dalvik?
    anon(8408674) likes this.
    12-21-2013 11:43 PM
  24. Paul Ackers's Avatar
    Hi beldie.. I too have now switched to google calendar away from S Planner because as you said it works. Yet another failing of Samsung. Just what is the point of Kies back up/restore if it is almost completely unfit for purpose.
    Samsung have yet to reply to my email from 3 days ago.
    Totally **** poor all round imho :/

    I am now considering rooting my note 2 and buying/using Titanium as that does support apps + data according to the specs. With so many ROMS/MODS out there I don't know where to start!!

    Posted via Android Central App
    12-22-2013 01:37 AM
  25. drniravchauhan's Avatar
    i have done exactly as you said but there is no improvement. Now what to do guys. I am tempting to go for root and custom roms but my warrenty will be voided.
    Kelly Kearns likes this.
    12-22-2013 04:26 AM
152 12345 ...

Similar Threads

  1. Replies: 53
    Last Post: 12-12-2013, 05:56 PM
  2. New fw update is a game changer!!
    By rajnet in forum Samsung Galaxy Gear
    Replies: 15
    Last Post: 12-02-2013, 05:28 PM
  3. Samsung Galaxy Note 3 - Update did not fix distorted calls - please help
    By MichaelNote3 in forum Samsung Galaxy Note 3
    Replies: 8
    Last Post: 11-23-2013, 08:40 AM
  4. Error with Google Play - Won't download/update
    By smathew4 in forum Google Nexus 4
    Replies: 8
    Last Post: 11-22-2013, 01:11 PM
  5. Tmobile Moto X KitKat update?
    By stockandroidguy in forum Moto X (2013)
    Replies: 7
    Last Post: 11-21-2013, 03:16 PM
LINK TO POST COPIED TO CLIPBOARD