1. crags13's Avatar
    Hello, I have the SGH i317M Galaxy Note 2, on Bell in Canada.

    I've downloaded the update but am very hesitant to install it based on all the negative feedback I've been reading. Just wondering if others with the same phone model have installed the 4.3 update, and if so what kind of issues have they been having, if any. I haven't been able to find much online as far as people in Canada's experience with the update.

    Thanks for any responses!
    Eric
    12-09-2013 12:24 PM
  2. flowrider's Avatar
    I've update mine on Telus network. I have to say I'm not impressed so far. I find it laggy compared to before but I do like the new colour scheme.
    12-09-2013 03:37 PM
  3. juicesrwild's Avatar
    Yes, dont't do it. I didn't see this post cause I just posted about my phone. NOthing but problems, apps opening all the time, some of them have stopped working all together. I am with Telus. NOt sure what to do, its so annoying.
    12-10-2013 11:32 AM
  4. crags13's Avatar
    Thank you both for your feedback. I'm going to hold off and wait for a stable release. I'm amazed that Samsung would release such a flawed OS, this is a colossal mess-up. Seems like nobody is happy with it.
    12-10-2013 12:29 PM
  5. juicesrwild's Avatar
    Hey have you contacted TElus?
    12-10-2013 01:29 PM
  6. vpblaze's Avatar
    You are smart to wait. I too have not been impressed with it at all. Lag, features taken away, etc. If I could I would go back to 4.1.2!

    Sent from my Note 2 using Tapatalk 4
    12-11-2013 04:43 PM
  7. GeoffWoo's Avatar
    can no longer share photos from the gallery. Pop up appears "unfortunately the gallery has stopped'
    I must open an app(hangouts,etc) and send it from there.
    12-11-2013 07:07 PM
  8. vpblaze's Avatar
    That ducks man. I can still share photos directly from the gallery.
    They actually added an option where I can do a quick send via BBM or whichever most recent social means I have shares. It's rather handy.

    Sent from my Note 2 using Tapatalk 4
    12-11-2013 10:13 PM
  9. flowrider's Avatar
    It's gotten a bit better since I first updated it but I still find it laggy. I'm also finding battery drain is quite a bit higher as well.
    12-12-2013 11:48 AM
  10. vpblaze's Avatar
    Hey flow, did you end up installing the Knox program?

    Sent from my Note 2 using Tapatalk 4
    12-12-2013 03:23 PM
  11. tireboy66's Avatar
    Since my 4.3 update The following has sucked... battery life, can not use voice commands with my t1 headset.. Is there a fix for it??
    12-13-2013 12:53 AM
  12. crags13's Avatar
    Just an update. Since I download the update my phone was periodically sending me reminders to install it. I accidentally clicked yes and installed it...terrifying moment indeed!

    However I have had little to no issues with the update since installing it. Battery life is similar to before, I find the apps for the most part run quicker than before. Still a few little hiccups here and there but nothing major. No issues with wireless or LTE connectivity. Overall I'm pleased with the update and very happy that I don't have to reinstall anything.

    One thing that I'm missing is the App manager. I used to use that regularly to shutdown apps that were running in the background. The widget has disappeared and I don't think I can reinstall it. That being said, apps such as the TSN.ca app, which used to cause me problems and I'd have to use the App manager to restart it, now work consistently. I'd still like to have the feature back. Any suggestions?
    12-31-2013 09:18 AM
  13. serpico's Avatar
    I updated my Telus Note 2 to 4.3 after a couple of weeks when it came out. The battery life was horrible at first but I turned the phone off/on and it fixed the battery issue. It was laggy at first but I installed Action Launcher and the Google Keyboard which helped a lot. The one thing that I'm upset at is the loss of bluetooth controls in my car and headphones. I've tried unpairing/pairing and not sure if a factory reset is the only solution. I contacted Telus and they told me to drop off the phone to send to a repair centre. I'm not sure if it's a hardware issue.
    01-02-2014 11:43 PM
  14. POSAnd's Avatar
    Can't remember when I did the update to 4.3 but it was a wee while ago. Didn't notice much until Jan 31, 2014 when all of a sudden MicroSoft Exchange ActiveSync broke. I can receive but not send emails using MSExAS. Have done hours of TS with ISP and Telus but no solution yet. I have tried Email Apps as a work-around but dislike most. Pop3 doesn't really work for me but it will have to suffice at this point.
    Samsung support would only do a 'hard' reset and then bailed. No chance to Escalate so am relying on Telus and ISP to do that.
    This may be the last Samsung for me.
    02-05-2014 03:35 PM
  15. vpblaze's Avatar
    Have you tried doing a factory reset? (not sure if that is the same as a hard reset)

    Sent from my Note 3 using Tapatalk
    02-05-2014 05:41 PM
  16. Ghostma77's Avatar
    Original rogers Note 2 unlocked and now on the Virgin/Bell network here. Zero issues on my end. Lightning fast with no glitches and amazing battery life!

    Posted via Android Central App
    02-06-2014 06:23 AM
  17. POSAnd's Avatar
    Yes I have. Samsung Support had me do it only 3 days after I had reset may phone through Backup and Restore Options (I'm getting almost quick at restoring all my apps) Hard reset is using volume up + Menu + Power which gets you the options to choose what you want to do.
    There was no difference and Samsung Support quit at that point claiming it was Not Their Fault. I am now dealing with Email Provider and Mobile Provider to ge tthis resolved but it is an extremely slow process.
    02-06-2014 07:17 AM
  18. POSAnd's Avatar
    Someone passed on a mysterious fix which so far has resolved the issue. Send a Calendar Appointment Invite to the broken account and when that account replies to the Invite - Miracle! the issue is gone and the account can send. No idea why or wherefore but it's fixed.
    02-11-2014 10:51 AM
  19. sdmf's Avatar
    I may be the oddball but I updated on Telus around Christmas and no issues whatsoever. I held off a little bit being cautious, but my battery has actually seemed better than before. No lag either.

    Sent from my SGH-I317M using AC Forums mobile app
    02-11-2014 09:15 PM
  20. NeoGrandizer's Avatar
    I've updated back in November (Telus). I did a clean install of the update.

    I also do not have any real major issues with the update to date. I do have lag on wake to lock screen. A few seconds worth sometimes (very noticeable) compared to 4.1.2 (which was always instant on). Battery drain is the major issue I have with this update (leaving everything enabled and the same as I had it in 4.1.2). Battery drain is significant under much more moderate to heavy use. But on days where I leave it alone (or use it very lightly), it is on par.

    I also have annoyances with this update. Removing features, annoying contact icons, light/bright coloured themes (for the stock apps), etc. Quite frankly, they removed more features than they added. Not pleased with that.
    02-13-2014 08:09 PM

Similar Threads

  1. undecided on root
    By wolfhead in forum New to the Forums? Introduce Yourself Here!
    Replies: 9
    Last Post: 12-17-2013, 08:21 AM
  2. Galaxy s3 hidden folders with the '.' and how to view them on the PC
    By Policeofficerpilot in forum General Help and How To
    Replies: 1
    Last Post: 12-09-2013, 05:54 PM
  3. Galaxy S4 running Google Play stuck on 3G
    By dlfoley in forum Verizon Samsung Galaxy S4
    Replies: 1
    Last Post: 12-09-2013, 12:11 PM
  4. Nexus Photography Project on Twitter
    By techMinimalist in forum General News & Discussion
    Replies: 0
    Last Post: 12-09-2013, 11:12 AM
  5. Web images posting to Facebook on Galaxy S4
    By ammojus in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 12-09-2013, 10:32 AM
LINK TO POST COPIED TO CLIPBOARD