1. Logotherapy's Avatar
    I have a Samsung Note II unlocked.
    I also have a 128 GB USB 3 Drive which had some data.
    I connected the drive to my Samsung Note in order to transfer some data using OTG.
    While I got a message that the USB drive was connected, I could not see the drive using my File Manager.
    When I tried to disconnect the USB connected (by pressing the button), it would show me 'App Info' button. When I clicked on it, my phone would hang.
    I tried to restart my phone a number of times but keep getting the same problem.
    Now my Mac does not read my drive because it tells me that the Drive cannot be mounted.
    I am at a complete loss and I am wondering if any of you could help me fuigure out what to do.
    I have spent over 04 hours trying to fix the issue and have failed.

    Many thanks for your help and advise

    03-16-2014 06:09 AM
  2. Beyond Fire's Avatar
    check to see if you have USB debugging turned on. It's under developer options. If you don't have developer options then go to..

    about phone > and tap on build number a few times until it tells you developer mode is on. After you turn on debugging, plug in your cable to your phone and pull down your notification bar and tap on USB. Make sure MTP or mass storage is enabled and you should be good to go.
    03-16-2014 06:30 AM
  3. Logotherapy's Avatar
    Many thanks.

    I had enabled that option earlier.

    When I attach the USB Drive, I get a message that USB Mass Storage is connected.
    When I try and disconnect it, it does not work. Nothing happens.
    When I keep pressing on that option, I get an option called App Info.
    When I click on that option, I get an option of Android System.

    How do I enable Mass Storage option in the phone?

    03-16-2014 06:39 AM

Similar Threads

  1. how to find USB mass storage
    By zchattha in forum AT&T Samsung Galaxy S4
    Replies: 3
    Last Post: 03-18-2014, 04:45 PM
  2. HELP - I have a messed Up Galaxy Note SGH-i717
    By rick2210 in forum Samsung Galaxy Note
    Replies: 3
    Last Post: 03-18-2014, 10:38 AM
  3. Galaxy S4: Disabling Youtube, Play books, Drive, Play Newsstand etc.
    By Omer San Gabriel in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 03-16-2014, 02:09 PM
  4. [Q] Issue with flashing phone. Please help.
    By abc08234 in forum Sprint Galaxy S III
    Replies: 1
    Last Post: 03-16-2014, 08:19 AM
  5. UNROOTED and completely stock N7 stuck on Google Screen (Bricked?) HELP
    By frenzy757 in forum Google Nexus 7 Tablet (2013)
    Replies: 1
    Last Post: 03-16-2014, 08:14 AM