1. serisu's Avatar
    I'm trying to get an older Note 2 phone to boot up after taking it out of a drawer to use again. It worked fine before I put it away and it has been a few months. When I first took it out, it wasn't doing anything so I left it to charge overnight. Then when I pressed the power button, it would show a gray battery. So I read some stuff online and decided to try using recovery mode to clear the cache. Now, the phone won't do anything at all. I tried using another battery from someone else's Note 2, but the phone still didn't respond. Is there anything I can do now?
    09-20-2015 11:55 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did you try pressing and holding the Power button for at least 10-15 seconds?
    09-21-2015 02:32 AM
  3. serisu's Avatar
    Thank you for the welcome.

    I have tried that! I just tried it again to be sure. There is no response from the phone, no lights or anything.
    09-21-2015 12:52 PM
  4. B. Diddy's Avatar
    Assuming your friend's battery was already charged up to full, then I'd suspect either a problem with the phone's Power button or the motherboard.
    09-21-2015 01:22 PM

Similar Threads

  1. Why aren't my facebook contacts syncing with my Galaxy S5?
    By AC Question in forum Ask a Question
    Replies: 9
    Last Post: 11-06-2015, 06:26 PM
  2. Replies: 3
    Last Post: 10-01-2015, 02:18 AM
  3. Skipping a track on a Note 5
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-21-2015, 07:39 AM
  4. Replies: 1
    Last Post: 09-21-2015, 02:36 AM
  5. Replies: 1
    Last Post: 09-21-2015, 02:35 AM