1. Kurt Unger's Avatar
    Hey all,

    I just upgraded from GS3 to Note 3 after my gs bricked. Upgraded to 4.4 when I got the device home, and now the GPS is totally useless (it worked well from the store to my house).

    Map app and Ingress app will only find my location after a few consecutive minutes standing totally still, and not at all in motion which kills functionality. I think its really only working when its on wifi. Any help? I've tried different GPS usage settings (network + wifi, network only, gps only) and nothing fixes it. I noticed that AT&T people in the US were having similar issues. I called both Rogers and Samsung and they were useless. Any fixes yet?
    03-27-2014 11:36 AM
  2. omu's Avatar
    Have you checked the Location services that all of the google location search has been checked on?

    You have 15 days to return or exchange the device, so I would suggest to do it.

    I just upgraded to GNote3 on Rogers yesterday and only updated the 30MB software update, then killed the 471MB update (assume to be KitKat) as I want the Gnote3 to work as 4.3.

    Gnote 3 on 4.3 works superb and amazed me. Altho it did kill my battery in first 4 hours due to the index service was running as initial yesterday.
    03-28-2014 02:12 PM

Similar Threads

  1. factory hard reset after you download kit kat so you want have any issues
    By zaydabarber in forum AT&T Samsung Galaxy Note 3
    Replies: 18
    Last Post: 08-14-2015, 07:49 AM
  2. Serious battery draining on 4.3
    By LauraBunnyyy in forum Samsung Galaxy SIII I9300
    Replies: 8
    Last Post: 04-02-2014, 04:20 PM
  3. Chromecast issues
    By Primer88 in forum Google Chromecast
    Replies: 0
    Last Post: 03-27-2014, 11:06 AM
  4. Replies: 0
    Last Post: 03-27-2014, 10:32 AM
  5. Consistent phone bug now..(Nova and/or proximity sensor issue?)
    By daves221 in forum Verizon Samsung Galaxy Note 3
    Replies: 4
    Last Post: 03-27-2014, 10:24 AM