1. Ben Harrison2's Avatar

    So I've got some issues trying to use safestrap to install custom ROM's on my Note 3. I have been searching the internet for answers and cannot seem to find anything to help. Let me give you guys all the information.

    I have successfully rooted my phone (checked with a root checker)
    I have Busybox Free and Busybox Installer on the phone
    I have ES File explorer
    I have [redacted]
    And obviously I have Safestrap (Version 3.75)

    So first I had problems with safestrap where the 'Reeboot to Recovery' box was constantly inactive and greyed out so I couldn't use it. I solved that issue by just finding a new version than the one I had with this problem, now that is fine and I was able to select 'Install Recovery' which worked and then selected 'Reeboot to Recovery'.

    Next I was in Safestrap from booting into it and created a backup as most guides for installing a custom ROM suggest.

    Now to the problem...once I am in Safestrap I need to select 'Boot Options' then select a ROM Slot (in this case ROM slot 1). The problem is that 'Selected Space' shows as 5512MB and 'Free Space' shows as 21MB. Why is that???

    I have hardly anything on the phone, I used apps to remove all bloatware, deleted all my music, videos and pictures, and when I return to the system (boot normally in to the phone) ES File Manager shows the structure as the following:

    / Device
    [picture of an SD Card] 0 (1.77 GB/26.32)
    [picture of an SD Card] extSdCard (5.39 GB/7.38 GB)

    What is the 0 ? and if it says that only 1.77GB of 26.32GB is used then why is safestrap only showing 21MB?

    Maybe there is something simple I'm missing or maybe I just don't understand something but all these guides and youtube videos make installing a custom ROM look so easy when really its not. I'm not beaten though and I don't want to give up because the phone is great and with custom ROM's it will be even better, I just need to be able to get it working.

    Thanks for your help guys,
    07-25-2014 03:40 AM
  2. Ben Harrison2's Avatar
    Just to add, I just clicked 'Root Explorer' to ON in ES File Explorer and additionally to what I was seeing before I also now see:

    [picture of a blue folder] /
    [picture of a blue folder] /storage/emulated/0/
    07-25-2014 04:24 AM
  3. Tommy Sebestyen's Avatar
    I don't know what safe strap is, and I've never used it, but I can help explain what 0 is, and what it means. When you don't have root access, 0 is sdCard0 which is you phone's internal storage. extSdCard should be pretty straightforward. Now, once you have root, you're able to see that your phone's internal storage is actually "/" (the root of the internal SD card) and to find your "non-root" internal storage, you navigate to /storage/emulated/0 (sdCard0). The external card is in the same place, just extSdCard rather than 0. Make sense now?
    07-26-2014 12:21 PM
  4. Rukbat's Avatar
    1) Safestrap sets up a "pseudo-environment". If your slot is set for X data space, and you use X - 21MB of space, you'll have only 21MB free - even though the SD card has gigs of free space.

    2) As of yet, many ROMS won't run in slots - you have to run them in the stock slot. The dev is working on that. Have patience. (Be glad that "brick" is now a term meaning "oh, drat, I'm going to waste 5 minutes", instead of "oops - I think I broke my phone". Even if you flash a keyboard to a slot and boot to it [don't ask me how I know this - it's too embarrassing], it only takes about 5 minutes to fix the problem - by flashing a real ROM to that slot.)
    07-30-2014 06:32 PM

Similar Threads

  1. HTC One M7 Google Play Edition Not Charging While on
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 08-13-2014, 08:35 PM
  2. Sorting Order on Android. 1, 10, 11, 2, 3, etc...
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-25-2014, 06:21 AM
  3. S5 - MyFiles can only see some files and folders on my PC
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-25-2014, 05:15 AM
  4. Just brought home Galaxy Note Pro and it died within hours
    By spineyone69 in forum Samsung Galaxy Note Pro 12.2
    Replies: 2
    Last Post: 07-25-2014, 02:50 AM
  5. having problem with downloading game
    By iljjaydk in forum Ask a Question
    Replies: 0
    Last Post: 07-25-2014, 02:20 AM