1. Hamed Momeni's Avatar
    I'm having this irritating problem with my GN3 (N9005) that it's USB connector isn't working.
    It started a few days ago. I was playing some game and suddenly the phone did a little vibration and the Dock page appeared and it was gone in no time.
    I considered it not important and kept playing. After some time I connected the phone to PC and it did not recognize the device.
    So I rebooted the phone and it didn't work again. Now the AC charger has the same problem, it won't charge the device.
    The weird part is that upon booting, after I enter the pin code the phone goes into USB mode without the cable even being connected.
    I even tried wiping the phone to no avail.
    I've tried different cables and different PCs to the same result.
    Today it's escalated to not working at all. No charging, no pc connection, nothing.
    Some said that it might be a loose port, but mine is completely snug.
    The only reaction I get from connecting the cable is when the phone is off and it goes into charging mode.

    So I'm in need of a desperate fix.
    04-03-2014 01:46 AM
  2. Hamed Momeni's Avatar
    After some more tampering I realized that if the battery percentage is more than a certain amount (somewhere between 50% - 80%) everything's fine but below that it gets messed up.
    04-03-2014 05:54 AM
  3. ubnserved's Avatar
    Are you using the original cord and charger? Older chargers (ones below 2 amps) may not charge your phone because they do not have enough power output.
    04-04-2014 11:44 AM

Similar Threads

  1. Working: HTC M8 with Samsung Galaxy Gear
    By mstrblueskys in forum HTC One M8
    Replies: 15
    Last Post: 12-02-2015, 06:20 PM
  2. d speak to text not working?
    By Frehley Mehaffey in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 04-07-2014, 01:01 PM
  3. Fetching media files form the Nexus 7 via USB
    By cab2 in forum Google Nexus 7 Tablet (2013)
    Replies: 3
    Last Post: 04-06-2014, 07:19 PM
  4. Touch Screen Unresponsive but works fine after lock screen
    By floey in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 2
    Last Post: 04-03-2014, 10:39 PM
  5. Nexus 7 - stuck in safe mode - volume button not working
    By Anils Chores in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 04-02-2014, 02:43 PM