1. FBA's Avatar
    Since loading KitKat a few weeks ago, I notice that the GPS is flaky. Sometimes I will get a GPS fix within 10 seconds, sometimes within 30 seconds and sometimes it just won't get GPS lock altogether. Other times, it will lock on, and then after some period of time, it will lose the GPS for a few seconds. Other times, it locks on and works fine.

    Rebooting doesn't help...and this happens when the device has a perfectly clear view of the sky. It's not hardware; I have never has an issue with GPS until KitKat.

    There seems to be quite a bit of chatter on the web about these issues --
    04-26-2014 09:57 AM
  2. Golfdriver97's Avatar
    Have you tried clearing cache in recovery?
    04-26-2014 10:03 AM
  3. ehosey2's Avatar
    As far as the AT&T Note 3 the 4.4.2 update was to provide a fix for the GPS issues. As stated, clear the cache in recovery but also download GPS Status and Toolbox. This application helps the GPS lock to a signal faster and works in unison with the built in GPS. It also provides advanced statistics with location and radar waypoints, etc. I have the Pro version and it works well. You can try the free version to see if it helps.

    Sent from my Samsung Galaxy Note 8.0.
    anon8380037 likes this.
    04-26-2014 11:14 AM
  4. FBA's Avatar
    I have tried clearing the cache partition, several times. The "fix" wasn't a fix for me; it was a break. It worked perfectly in JB, for months, until 4.42. I will try the GPS status and toolbox download. Thanks for the heads up!
    04-26-2014 12:05 PM
  5. ehosey2's Avatar
    Also, if I recall correctly someone had said they uninstalled the latest update to Google Maps to get their GPS to work properly again. I will see if I can find that in a search.

    Sent from my Samsung Galaxy Note 3.
    04-26-2014 12:10 PM
  6. FBA's Avatar
    Uninstalling the maps probably wouldn't address the issue.

    When GPS isn't available, it isn't available for any apps that ask for it; not just Maps.

    I just installed the toolbox and if it's a GPS fix issue, then this toolbox may fix it. The toolbox loads when Maps load, so I can see it speeds it up. I downloaded the Ephemeris data and it loaded the GPS fix on the map very quickly, so we'll see if this fixes the issue I'm experiencing.

    Question: Can the pro version be set to download the Ephemeris data automatically every few days?
    04-26-2014 12:26 PM
  7. ehosey2's Avatar
    These are your options for that data I think....KitKat and GPS issues...-uploadfromtaptalk1398533392840.jpg

    Sent from my Samsung Galaxy Note 3.
    04-26-2014 12:29 PM
  8. vpblaze's Avatar
    Hey FBA, have you had any luck as of yet?
    I recently updated to Kitkat, and my GPS isn't getting a lock at all!

    Scribbled on my Note 3 and then translated into readable words using Tapatalk
    05-03-2014 03:08 PM
  9. anon8380037's Avatar
    I had GPS location issues for a few weeks. I downloaded that GPS Status free app 3 days ago, and also 3 wifi apps. I am mostly in the city and have Location on high accuracy.

    I wasn't out and about to test GPS much - but I also found this week AccuWeather wasn't getting a fix most of the time so wouldn't update.

    Then yesterday I had the first patch (stability improvements) for KK @ 27.66mb.

    Anyways currently its locking on very quickly but I don't know what to thank for it.

    I will keep one of the wifi apps and ditch the others in time.

    Sent from my SM-N9005 using Tapatalk Pro
    05-03-2014 03:58 PM
  10. FBA's Avatar
    Yup, it turns out that K/K just takes a lot longer to get a fix. Originally, I was getting the GPS fix, but Google Maps would pop up the message "Waiting for location"...and it would never get the location, though I could see the location had clearly been established.

    I ended up removing and reinstalling Google Maps, and that seemed to resolve that issue.

    It takes from 10-30 seconds now to get a GPS Fix when I load the maps, or any other app requesting the use of the GPS, and that's way longer than it took on JellyBean, but it's working consistently and it hasn't failed to establish a GPS locate in maybe 200 + times that I ran the maps application, since the posts above.

    What seems to speed it up a bit, is the app I downloaded (see above - GPS Status and Toolbox). It downloads the Ephemeris data and provides it to all applications requesting use of the GPS. I have it set to 6 hours and older.

    So, no more issues with GPS, for now!
    anon8380037 and vpblaze like this.
    05-03-2014 04:04 PM
  11. vpblaze's Avatar
    Thanks man. Will have to give that a whirl. I did manage to get a connection earlier and yeah, it took almost 2 minutes. Which is 1:50 seconds longer then ever before.

    Scribbled on my Note 3 and then translated into readable words using Tapatalk
    05-03-2014 04:50 PM
  12. FBA's Avatar
    Are you now on KitKat by any chance?
    05-03-2014 10:44 PM
  13. vpblaze's Avatar
    Yeah. Just did the update yesterday.

    Scribbled on my Note 3 and then translated into readable words using Tapatalk
    05-04-2014 08:02 AM
  14. DawgPoP's Avatar
    I had the same issue, Galaxy S3 sprint updated to 4.4 and GPS couldn't get a lock. Made me get lost a few times. While I was unsure of how to remove google maps as it wasn't an option for me, just diasable and force stop, I did update google maps via google play and now it seems to lock on actually. I will try out getting the new Ephemeris data, maybe that will speed it up even more. Will try everything out this evening. Thanks for the help.
    07-19-2014 11:12 AM
  15. FBA's Avatar
    To do that, you just need to install the GPS Status and Toolbox app.
    07-20-2014 07:07 AM
  16. ackerrj's Avatar
    The KitKat gps issue bugged me for quite a while. I hate it when an "upgrade" turns out to be a "downgrade".

    After trying without success to get my device rolled back to pre kit kat mode, and fuming at Virgin Mobile/Sprint, Samsung and Google, I have done several of the workarounds mentioned in this thread, and one more... and now I can say the reliability is almost 100%.

    Heres what I have done:

    1. Download the latest patch for Google Maps.

    2. Download GPS status. In Settings >> GPS & Sensors >> Auto-download AGPS data >> Choose: One hour.

    3. Fire up GPS Status before starting the navigation app of your choice. Wait for a fix to be obtained (all numeric data (4 lines) shown by GPS Status).

    4. If GPS Status does not obtain a fix within a minute or two, turn off the gps location switch from the KitKat pull down. Wait a couple of seconds, and turn it on again. Answer "Yes" to Googles location permission popup. GPS Status should then obtain a fix almost immediately.

    5. Once GPS Status has a fix, wait a minute or so, then close it with the "home" button. Open your navigation app (I prefer Waze). If your navigation app obtains a fix, you are set. If it does not obtain a fix almost immediately, turn off gps location from the KitKat pull down, then turn it on again. Answer Googles permission popup positively. Your maps app should then obtain a fix.

    Yes this is a pain in the a__... but clearly there has been a bug introduced in KitKat effecting communication between the apps using the gps data and the gps itself. This method seems to overcome the bug for me almost 100% of the time.

    Best wishes.

    Bob A.
    Samsung S3 on Virgin Moble.
    07-24-2014 11:30 PM
  17. delflow's Avatar
    My Google Maps app stopped working as soon as I installed the Kitkat update 1 1/2 weeks ago. I spent a lot of time on the phone with Verizon trying different things including clearing the cache and nothing worked. The tech support person ultimately said that Google Maps is not compatible with the update.
    07-29-2014 09:12 AM

Similar Threads

  1. Galaxy S5: Picasa and Gallery
    By Even4steven in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 03-06-2015, 01:18 PM
  2. htc one max connecting to hard disk issue
    By Nancysikka93 in forum HTC One Max
    Replies: 3
    Last Post: 05-25-2014, 04:11 AM
  3. Black Box & Modem Issue
    By AhmadS3 in forum Samsung Galaxy SIII I9300
    Replies: 11
    Last Post: 04-30-2014, 06:58 AM
  4. S5 and 1password
    By planemech326 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-26-2014, 01:07 PM
  5. control multiple devices remotely and simultaneously
    By Goldentongs in forum Software Development and Hacking
    Replies: 0
    Last Post: 04-26-2014, 05:05 AM