1. Python49's Avatar
    I have tried to use the toothbrush method to clean the usb or charging port. Have tried rapidly making battery and charger tips touch method. Have tried blowing into there but it's clean considering the phone is only like one month old. I have used a new battery that is fully charged and it's not turning on or any red light when plugged in for charging. Have used new charger and wall outlet. Have held down the volume up/home/power buttons. Taken battery in and out numerous times. Any help?
    08-01-2014 07:24 AM
  2. B. Diddy's Avatar
    Ugh, sounds like you've tried everything I would have suggested. The last time it powered down, did you do it yourself, or did it shut down by itself? It sounds like a major hardware failure--possibly the motherboard. I think you'll probably have to contact Samsung for repairs--hopefully it's still under warranty.
    08-01-2014 12:21 PM

Similar Threads

  1. Replies: 7
    Last Post: 02-05-2015, 04:12 AM
  2. LG G3 RAM and internal storage question
    By Marv701 in forum LG G3
    Replies: 5
    Last Post: 08-06-2014, 09:52 AM
  3. New Touchwiz?
    By shaundiesel in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 08-01-2014, 11:10 PM
  4. Headset mode activated with head phones in
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-01-2014, 12:22 PM
  5. My OS crashed
    By Ammar Jamil in forum General Help and How To
    Replies: 6
    Last Post: 08-01-2014, 09:59 AM