1. W1911's Avatar
    T-mobile Note 3. As the title says, I plug it in, it thinks it's charging but battery percentage continues going down. I replaced the charging port circuit board with a brand new one, still has the same problem. Did factory reset (5.0), still nothing. Tried two different chargers with four different cables, still nothing. There is no apparent damage or debris on the connector that attaches to the charging circuit board. I have no idea what the problem could be.
    03-20-2016 07:54 PM
  2. themaq's Avatar
    How To UPDATE NOTE 3 (Almost All Models) TO OFFICIAL FIRMWARE, complete guidance is provided with pictures. Links are also provided: UPDATE NOTE 3 (Almost All Models) TO OFFICIAL FIRMWARE - AndroidApt...
    04-06-2016 01:36 PM
  3. Domestoboto92x's Avatar
    Hey. I used to have that problem with my Note 3 Global unit.

    I suggest trying the following.

    - A fatter and/or shorter USB 3.0 cable. Western Digital (that's the only one I'm absolutely sure of) Hard Drives use USB 3.0 and the cable's really short, try getting one, or at least a cable significantly fatter than the OG Samsung cable.

    - A 2.1Amp charger. Maybe an iPad charger or anything that gives higher wattage and current than the OG Samsung charger.

    - Airplane mode. Or shutting down the device while charging.

    - You also mentioned that the charging board was replaced. Maybe that's where the problem lies, and there's not much you can do if it does.

    I hope it's fixed and these helped in any small way...

    This Galaxy Note 3 with the AC App is On Fleek.
    04-08-2016 12:15 AM
  4. flintlock's Avatar
    You mentioned the board. What about the plug? Try a different cord. Newer and of good quality.

    My S3 did that or charged slow, replaced with a S7E. I think the port needed replacement.
    04-08-2016 12:26 AM

Similar Threads

  1. Is there a way to lower the volume on texts?
    By AC Question in forum General Help and How To
    Replies: 3
    Last Post: 03-29-2016, 08:47 AM
  2. Why is my battery dying within 5 minutes?
    By j3monkeymama in forum Batteries
    Replies: 1
    Last Post: 03-24-2016, 07:21 PM
  3. Why is my location being accessed while location is disabled?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-21-2016, 02:08 AM
  4. My phone is froze on cm security blue screen
    By Dominikantwon61011 in forum General Help and How To
    Replies: 1
    Last Post: 03-20-2016, 11:45 PM
  5. I have a note 3 and cant use 4G lte what can i do to access
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-20-2016, 06:42 PM
LINK TO POST COPIED TO CLIPBOARD