1. BarryAllen97's Avatar
    Hello, I have a problem with my Samsung Galaxy Note 3.
    I am stuck on the Samsung Logo when i try to power up my phone.
    I have tried to factory reset the phone, but it didnt help.
    Anyone got any idea of how to fix this? Please let me know
    08-11-2016 05:39 PM
  2. B. Diddy's Avatar
    Are you able to boot into Recovery and wipe the cache partition? https://support.t-mobile.com/docs/DOC-11017

    Also, if you have an SD card inserted, try removing it and trying again.
    08-11-2016 08:30 PM
  3. BarryAllen97's Avatar
    Tried both, but didnt work :/
    08-12-2016 05:01 AM
  4. B. Diddy's Avatar
    See if you can boot into Download (Odin) Mode to re-flash the stock ROM: http://forums.androidcentral.com/amb...interface.html
    08-14-2016 01:05 AM

Similar Threads

  1. question on att next
    By nonie in forum Samsung Galaxy Note 7
    Replies: 48
    Last Post: 09-02-2016, 12:41 PM
  2. Moving on up!
    By zita williams in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 08-12-2016, 07:08 AM
  3. Replies: 2
    Last Post: 08-11-2016, 11:24 PM
  4. Replies: 0
    Last Post: 08-11-2016, 05:05 PM
  5. My samsung pay on gear s2 is not workimg
    By Charles456k in forum Samsung Gear S2
    Replies: 2
    Last Post: 08-11-2016, 04:19 PM
LINK TO POST COPIED TO CLIPBOARD