1. Blipstein's Avatar
    So when I go into Google Now settings>voice>"Ok Google" detection and then click "Always On" it prompts me to say "Ok Google" four times to record my voice. When I attempt this it will not pick up my voice. It did it successfully when I first got the device on Friday (after everything was set up and restored as it was in my N3). When I got to this screen it would show the sound waves that it was recording my voice successfully. Now.... Nothing. Not hearing anything.... Just sits and waits to pick up my voice (see screen shot) Note 4 Having problems setting up "Ok Google"-uploadfromtaptalk1413992858997.jpg

    Side notes:
    The voice memo app is working so the mic does work correctly.

    I use Nova launcher. It has its own "Ok Google" setting (it doesn't work when the phone is a sleep or on the lock screen unlike the Google Now version) and that worked fine when I activated it. It picks up my voice from the home screen without even pre recording it

    Also, the N4 seems to kick in S Voice to record my voice in the Google Now "Ok Google" set up. The N3 stayed in the Google Now app. Maybe this is a factor?


    Any ideas on what to try? What would be interfering with the mic? Any help is appreciated. Thanks in advice
    10-22-2014 11:51 AM
  2. mhunter6378's Avatar
    Go into your phone settings, default applications - and see if S Voice is listed as a default, if it is clear it and then try your Google set up.
    10-22-2014 12:04 PM
  3. Blipstein's Avatar
    It's not. Google is the default

    I think S Voice taking over the "Ok Google" recording is an N4 feature now
    dmakun likes this.
    10-22-2014 12:16 PM
  4. Cnote187's Avatar
    This is happening to me too.... Anybody else have any idea as why this would be happening. as of right now Google Now does not recognize any speech fromt he mic
    10-23-2014 03:51 PM
  5. ohbreeeezy's Avatar
    Does this drain the battery?
    10-23-2014 05:15 PM
  6. clevin's Avatar
    Does this drain the battery?
    Good question, i bet it does, how much, that is the problem.

    It's also silly to converse with a phone, not many people starts a conversation with "ok", no matter how many times Google headquarters geek play that 5 movie clips ad to convince you otherwise. Lol

    For op, there is another thread on this topic, with much more information, search for it.
    10-23-2014 07:59 PM
  7. karsdroid's Avatar
    so i've just been trying to set up my 'ok google' to activate on any screen.....i had the same problem as the op and tried turning off s voice which allows me to run through the ok google set up and voice training. hooray.......however, after the ok google waking up on any screen once, it then for some reason doesn't work again, and when i return to settings the "from any screen" setting is turned off. anyone solve this issue?
    01-15-2015 06:09 PM
  8. Coolboy32's Avatar
    Not exactly sure how to fix the problem, I have S voice turned off, in my "ok Goggle" settings i have "From the Goggle App" set ON, "Always On" set On, and "Personal Results" set off, I'm running Nova Prime, and my ok goggle works fine when the screen is both on and off.

    I usually find that turning off my phone, waiting about 5 seconds, and powering it back on fixes a lot of my problems, try that, then go back to your settings to make sure you have the settings like mines, hold the phone in the position and length that you would normally hold the phone and not too up close and retrain your voice for ok goggle.

    Sorry not much of a help but hope this works for you, I honestly don't know why some people are having troubles with theirs. I guess I'm fortunate to have a Note 4 working exactly how its suppose to.
    01-15-2015 06:35 PM
  9. EKFone1's Avatar
    It seems that you have to switch off Bluetooth or disconnect any Bluetooth devices / accessories (ie smartwatches, etc) from the Note 4 BEFORE setting up the hot word detection and training the phone to recognise your voice. Once that is done, you can switch Bluetooth back on and reconnect your Bluetooth devices.

    In my case it doesn't seem to have anything to do with S Voice.
    WingNutLori likes this.
    02-06-2015 04:26 AM
  10. slackerjack's Avatar
    You can't disable SVoice if you want okay google to work. Svoice is the audio in platform for the Note 4, so it has to be left on. That doesn't mean you'll ever use it...but it needs to be on if you want to use voice commands (you can still disable the home screen shortcut)

    Posted by my Note 4, or Nexus 9...****, maybe by a Note 2014 ed. or hell...maybe it was this Nexus 4 or 5...oh, snap...there's Nexus 7. okay, I need to clean...
    dmakun likes this.
    02-06-2015 06:09 AM
  11. MWalden824's Avatar
    This worked for me, thanks. I just began the process of training it, but at first, it was stuck on the first one and wouldn't go any further... I searched for hours trying to find a solution, and turning the screen off, then back on worked like a charm.

    Thanks again man,
    Mike

    Not exactly sure how to fix the problem, I have S voice turned off, in my "ok Goggle" settings i have "From the Goggle App" set ON, "Always On" set On, and "Personal Results" set off, I'm running Nova Prime, and my ok goggle works fine when the screen is both on and off.

    I usually find that turning off my phone, waiting about 5 seconds, and powering it back on fixes a lot of my problems, try that, then go back to your settings to make sure you have the settings like mines, hold the phone in the position and length that you would normally hold the phone and not too up close and retrain your voice for ok goggle.

    Sorry not much of a help but hope this works for you, I honestly don't know why some people are having troubles with theirs. I guess I'm fortunate to have a Note 4 working exactly how its suppose to.
    07-01-2015 09:08 PM
  12. dmakun's Avatar
    This is the solution to this problem. I re-enabled S Voice and now the Ok Google hot word works from off screen and any screen again on my note 4. Thanks a million Slackerjack
    09-05-2015 11:11 PM
  13. nahoku's Avatar
    You can't disable SVoice if you want okay google to work. Svoice is the audio in platform for the Note 4, so it has to be left on. That doesn't mean you'll ever use it...but it needs to be on if you want to use voice commands (you can still disable the home screen shortcut)

    Posted by my Note 4, or Nexus 9...****, maybe by a Note 2014 ed. or hell...maybe it was this Nexus 4 or 5...oh, snap...there's Nexus 7. okay, I need to clean...
    This isn't right. What part of Ok Google needs S Voice? I have S Voice turned off and my Ok Google works just fine.
    09-06-2015 06:05 AM

Similar Threads

  1. Why can't I sing in on my Google account?
    By Zohaib Siddique in forum Ask a Question
    Replies: 4
    Last Post: 09-18-2015, 01:44 AM
  2. HTC One M7 having issues with calls.
    By Lucidgeek in forum HTC One M7
    Replies: 6
    Last Post: 04-01-2015, 07:36 PM
  3. Problem checking for software update
    By letitbleed in forum HTC One M8
    Replies: 6
    Last Post: 10-25-2014, 05:35 PM
  4. New Note 4 Setup
    By rinconmike in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 10-24-2014, 08:21 AM
  5. Where are my call settings on my Samsung gt s6810p?
    By wee wifie in forum General Help and How To
    Replies: 1
    Last Post: 10-23-2014, 06:21 PM
LINK TO POST COPIED TO CLIPBOARD