1. raf66's Avatar
    I've got a huge problem with nearly unbearably long lag when I open the non-gmail email app.

    I don't use gmail as my email address. I use yahoo for personal and Microsoft Exchange for professional. When I set up the Microsoft account it automatically put it under the generic email app, along with the yahoo account. That one app therefore handles two different accounts, and both are pretty active.

    When I open the email app to check or send emails, or when I get notification of an email in the notification bar and click it, it takes forever to open the app and show the email. Interesting, when I open the gmail app it opens immediately, with no lag or hesitation whatsoever. I have experienced no other lag or stutter on this phone at all.

    Would I be better off using the yahoo email app? I'm assuming that even if I do that my Microsoft Exchange emails will still come to the generic email app. Maybe getting both accounts' emails to that one app is the culprit?

    I hope to get this resolved because the delay I'm experiencing is literally intolerable.

    Thanks.


    Sent via Tapatalk on my Samsung Galaxy Note 4
    hdhuntr likes this.
    10-26-2014 12:21 AM
  2. FBA's Avatar
    The stock Samsung e-mail app is very poorly executed and laggy. I use Nine Folders for my Exchange accounts and the stock Gmail app for my Gmail accounts. Both have the identical look and feel.
    hdhuntr likes this.
    10-26-2014 03:36 AM
  3. raf66's Avatar
    Thanks FBA. Does the Nine Folders app handle other email accounts besides Exchange?

    Sent via Tapatalk on my Samsung Galaxy Note 4
    10-26-2014 12:36 PM
  4. FBA's Avatar
    Currently not, but they say it's going to --
    10-26-2014 12:55 PM
  5. Litlprince2's Avatar
    The stock Samsung e-mail app is very poorly executed and laggy. I use Nine Folders for my Exchange accounts and the stock Gmail app for my Gmail accounts. Both have the identical look and feel.
    Well this is one mans opinion.. Here's another.... It works fine. I have 4 email accounts linked to it and no lag at all... Its all pretty smooth and fast.. Im not sure whats happening with yours OP.. i guess you can try removing all your accounts and re adding them.. Also define "forever" are we talking seconds or minutes.. try not to be so vague.
    10-26-2014 01:30 PM
  6. FBA's Avatar
    Do you have an Exchange account in it? If not, your post is irrelevant to the OP's thread starter...
    10-26-2014 02:59 PM
  7. raf66's Avatar
    I actually think I may have solved the problem. I checked the settings on each of the two accounts in the email app and I had set both to sync ALL emails. I got a popup that said it was syncing the max 5,000 emails. When I changed the settings to sync emails from only the last 30 days, the lag basically disappeared. It's not lightning fast necessarily, but it no longer takes 30-45 seconds to load.

    Thanks for the guidance.

    Sent via Tapatalk on my Samsung Galaxy Note 4
    hdhuntr likes this.
    10-26-2014 05:43 PM
  8. hdhuntr's Avatar
    I am going to try this (I did but no new emails yet. Thanks for posting it. Meanwhile I put this in from another thread. Interested in opinions.

    "Stock is ok for me except I'll get unread count on the homepage (Nova/Tesla)...I go to email and it then cycles and gets the email. Strange. Everything set to push. I might try Mailbox or are there any others with good Office/Exchange sync (all I need) and a dark theme? I also don't love that stock won't let me put stuff in Sent file if I want to. And slightly off-topic... I HATE the new open apps button instead of what we had. I hope Nova adds programming for it. I don't know if I'll ever get used to it."

    I actually think I may have solved the problem. I checked the settings on each of the two accounts in the email app and I had set both to sync ALL emails. I got a popup that said it was syncing the max 5,000 emails. When I changed the settings to sync emails from only the last 30 days, the lag basically disappeared. It's not lightning fast necessarily, but it no longer takes 30-45 seconds to load.

    Thanks for the guidance.

    Sent via Tapatalk on my Samsung Galaxy Note 4
    10-27-2014 09:39 AM
  9. strauss884's Avatar
    After you changed the sync period did everything over a month old disappear or did you have to do something else, all of my e-mails still seem to be there.
    10-01-2015 08:07 AM

Similar Threads

  1. Is it just me or... does the Note 4 lag?
    By Mac58 in forum Samsung Galaxy Note 4
    Replies: 235
    Last Post: 11-09-2015, 12:33 AM
  2. MultiTasking Lag
    By SpookDroid in forum Samsung Galaxy Note 4
    Replies: 24
    Last Post: 11-24-2014, 01:48 AM
  3. Need help with email
    By Simaan5 in forum Samsung Galaxy Note 4
    Replies: 4
    Last Post: 10-25-2014, 08:32 AM
  4. S5 Active email arrow for sent or replied missing? or?? help
    By JTHDPE in forum Samsung Galaxy S5 Active
    Replies: 3
    Last Post: 10-24-2014, 07:39 PM
  5. Email questions
    By thatdarnpunk in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 10-24-2014, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD