1. charleskoz's Avatar
    Hi there,

    Bit of a newbie question. I'm new to Samsung phones (and smartphones in general). Somehow I have managed to get 225 contacts in my phone, most of which have no relevance to me. I think they were automatically imported by Google and/or Facebook.

    I no longer even have Facebook on the phone but I still see Facebook people there. I turned off contact syncing for my Google accounts but they are still there too.

    I can't figure out how to delete these. When I go into the contact app, it only shows me 20 or so of them, but if I do a search it still shows 200+ contacts. Help?

    Thanks.
    10-29-2014 12:57 PM
  2. SpookDroid's Avatar
    When you do a search, where are they showing? You say that the Contacts app only shows 20 contacts.
    10-29-2014 01:03 PM
  3. charleskoz's Avatar
    I hit the green phone button bottom left, hit Contacts top right and it shows just a small number of contacts. But as soon as I try to type anything in the Search box, 200+ (now 300+!) additional entries magically appear. Are these being dynamically found by Google or something?

    Honestly at this point I would be happy with simply wiping all my contacts and starting over with nothing put in there except what I choose to manually put in there. Can I do this?

    Thanks.
    10-29-2014 01:55 PM
  4. SpookDroid's Avatar
    Yeah, if you go to Settings, Application Manager, ALL tab, find the Contacts app and wipe out cache and data. This will erase ALL CONTACT DATA from your phone. However, if you've set your phone to sync with Google or Facebook contacts, it will just re-sync them eventually.
    10-29-2014 02:48 PM
  5. charleskoz's Avatar
    Thanks for the reply. I didn't know there were tabs in the Application Manager.

    I did as you instructed, and I have Facebook uninstalled and my Google accounts set not to sync data, but everything is still there. :/
    10-29-2014 04:04 PM
  6. SpookDroid's Avatar
    Could you take a snapshot of your dialer 'predicting' these contacts? Just make sure you blur out or cover any full names, numbers, or e-mails (public forum and all; if you can't edit the picture, then just send it to me via Private Message).
    10-29-2014 05:10 PM
  7. charleskoz's Avatar
    Not sure how to do that but I'll figure it out.

    These all seem to be coming from Gmail. I want Gmail to update me when new mail arrives, but I don't want every person I've ever emailed in my phone, which is what seems to be the case now. I can't seem to get rid of this junk. Sigh.
    10-29-2014 05:47 PM
  8. charleskoz's Avatar
    Even went into Application Manager and cleared everything out of Gmail and these things are STILL there!

    Changing the display settings, unchecking pretty much everything, and it still shows hundreds of contacts as soon as I start typing anything in the search box.

    I'm ready to factory wipe this thing to be honest, I am so irritated. (But I appreciate your efforts to help, thank you.)
    10-29-2014 05:49 PM
  9. SpookDroid's Avatar
    OK, when going into the Contacts tab, tap the three dots on the right. Select Settings, Contacts, Accounts. Do you see any accounts there? If so, try to disable the ones you don't want.

    Also, check the ONLY CONTACTS WITH PHONES option. Now, go to CONTACTS TO DISPLAY and select Device (if you really don't want your Google or other account's contacts, but I strongly suggest using Google's because, well, that way your contacts are safe in the cloud and you don't lose them should you lose your phone and it's easier to transfer everything once you get a new one).
    10-29-2014 05:54 PM
  10. charleskoz's Avatar
    Thanks.

    In a fit of pique I actually did reset my phone. I've only had it a week, I've made several foolish decisions since then and I figured I might as well start with a clean slate now that I have a bit more experience.

    That did of course get rid of everything.

    The problem began to return when I re-enabled my Google account. By default it syncs contacts and once they are in there it seems impossible to get rid of them. I actually had to enter the Google account, turn on airplane mode, edit the sync options so it would not do contacts, and that seems to have worked. Really annoying.

    Now if only I could figure out how to get Google Maps to use the new voice files I downloaded.

    Thanks for your patience and assistance.
    10-29-2014 09:40 PM
  11. Jay Contacts's Avatar
    OMG thankyou so much !!!

    I have to admit I am oldschool and liked my contacts on my phone and nowhere else. When lollipop killed all my phones contacts and populated my contacts list with GARBAGE (because I have my phone synced to the hotmail account I've been using for 15 years) I flipped out. Like just flipped.

    While my faith in google is completely lost and will likely never return, I WANT TO THANK YOU A MILLION TIMES !!! Even after disabling every Sync function and option I still couldnt remove the ten thousand email contacts, because of you I was able to delete them... A start in the right direction

    I have since started a new gmail address strictly for the purpose of storing my contacts. I will never email anyone from it, its just an address book.
    01-25-2015 11:01 PM

Similar Threads

  1. Contacts are not showing up in iPhone Hangouts App after SMS integration
    By shanezam203 in forum The Android Central Lounge
    Replies: 6
    Last Post: 02-01-2015, 09:27 PM
  2. Replies: 2
    Last Post: 12-09-2014, 01:32 PM
  3. soft key delete photo from gallery not working
    By ivory_kitten in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 10-31-2014, 07:30 AM
  4. How do I delete a second wifi user name off of my router?
    By Kimberly Guns in forum General Help and How To
    Replies: 5
    Last Post: 10-29-2014, 02:17 PM
  5. Replies: 1
    Last Post: 10-29-2014, 01:03 PM
LINK TO POST COPIED TO CLIPBOARD