07-21-2017 12:24 AM
282 ... 34567 ...
tools
  1. sparksd's Avatar
    Other than things such as what I listed rooting, I think will be the only thing that will ever come close to a fix. This problem has gone on so long across so many different Samsung platforms that if it were going to be fixed by them I would have to think it would be fixed by now.
    What stuns me is that their isn't more information on this topic and I don't know why.
    Maybe still just too many people out there that only use Bluetooth for phone calls which are not a problem. Perhaps as headphones and speakers become more popular, it will get fixed in a couple of years. I hear the GS6 even still has the same problem so no end near.
    Isn't just a Samsung issue - it's been reported on other platforms as well. If indeed the problem is related to CPU clocking (as it appears to be), then any device that similarly reduces clockspeed willl experience this.
    05-18-2015 07:46 AM
  2. dmagikwand's Avatar
    Isn't just a Samsung issue - it's been reported on other platforms as well. If indeed the problem is related to CPU clocking (as it appears to be), then any device that similarly reduces clockspeed willl experience this.
    Yeah, I've seen the blame game going on out there in the net. Some, not all of these other folks, with different companies seem to be complaining about different things sometimes though than this specific glitch, whether they believe they are or not, whereas right here we all know damn well which specific problem it is.
    Another thing, Samsung switched from the Snapdragon processor to an 'in house' model on the GS6 and if it is truly having the similar Bluetooth issues then it shoots down blaming Snapdragon...other phones/carriers on the market probably also had Snapdragons (or Hummingbirds) in previous generations but it will be only Samsung hardware on this go round, I've been told. This Bluetooth problem persisting on a Samsung built CPU (GS6) is incriminating of Samsung, IMO, with Google being "a person of interest" in the case.
    05-18-2015 08:28 AM
  3. Arjan Strijland's Avatar
    Rooting also does not always work...
    I just have my Galaxy S6 for a few weeks and it also has the ocassional hiccup when streaming spotify or using the stock music app when connected to my bluetooth headphones.
    No suggestions have worked so far... I've rooted the phone and increased the CPU speeds, it has no external sd card so removing it isn't an option, turning off gps does not work and even the leave the screen on method does not work with me.

    I'm really clueless here...
    dmagikwand likes this.
    05-18-2015 11:45 AM
  4. sparksd's Avatar
    I was unable to find any decent information on the net for this long going problem other than:


    1. Leave your screen on all day while listening (ridiculous, but it does work FWIW)
    or
    2. If you are a rooter, then root the phone and get an app that will let you overclock your CPU while the phone is asleep.

    The theory seems to be that the problem is that the CPU slows down too much in sleep to consistently push the BT.

    I'm not a rooter and the screen fix is unacceptable to me so.....

    This is how I fixed the problem:


    I thought I would look for an app that would continuously prod at the CPU by running to keep it from deep sleep, yet not pull too much battery drain.
    I already had an app on my phone called simply "Stopwatch & Timer" by Jupiter Apps.
    It can be downloaded from Play for free
    Download it
    Install
    Open
    Use the timer feature
    Set the timer to about the amount of time you will be using BT audio or as long as you want (the max is 9 hrs and 59 minutes on the free version)
    You can set the alert of your choice when the countdown is complete or choose no alert, whatever works best for you.
    Start the countdown, play some tunes and enjoy skip free music for the duration of the timer, all while saving your beautiful screen from burnout.

    If the timer runs out it takes about 2 seconds to start it again from the task bar. You can repeat the old timer or make a new timer for a different amount of time. I'm currently keeping mine around 5 hours and will tweak as I go along....it is easy to change the times.

    I haven't been using this fix long enough to determine just how much battery the timer uses but one would think it would be much, much, less than leaving your screen on all bloody day, right?

    Disclaimer: This was done on a my GS5 and works perfectly. The problem is so similar across so many Galaxy devices that I can't imagine this so called 'fix' not working almost all the same devices. What would be nice though, is a REAL FRIGGIN' FIX, but obviously that is not gonna come so I guess a crumb is better than hungry.

    NOTE: I thought this might be obvious, but just in case, you do not have to stay in the "timer screen". Once you got the timer rolling, just hit the middle button at the bottom of the phone and the timer will just have a little icon at the top of the task bar/notification bar and are free to proceed with doing whatever you normally do the rest of the day.
    OK, I downloaded the app and gave this a try and it so far, so good - it appears to suppress the skipping when I listen to music with the screen off (screen on was the only other workaround that worked for me). Configuration: Sprint Note 4 using PowerAmp and Jaybird BlueBuds.
    05-18-2015 12:02 PM
  5. dmagikwand's Avatar
    OK, I downloaded the app and gave this a try and it so far, so good - it appears to suppress the skipping when I listen to music with the screen off (screen on was the only other workaround that worked for me). Configuration: Sprint Note 4 using PowerAmp and Jaybird BlueBuds.
    Still working for me. I listened to 5 consecutive albums last night with the stock player and no skips. I thought it did for a minute but it turned out somebody had just sent a message and this caused the volume to lower a bit. 3 hours of Pandora the day before with no skips. So far the timer doesn't seem to cause too much drain and not really a nuisance at all running a bit behind the scenes. Also, I like the idea of being able to easily control how long it runs. If I set it for 5 hours, then it will do its 5 hours and stop instead of running forever until I kill it. Just have to remember to turn it back on when listening to tunes...my phone would skip about every 30-40 seconds without it so that would be an easy reminder lol.
    I keep forgetting to check the battery usage because I keep plugging my phone in at night and forget about it until the next day.

    Galaxy 5 4.4 (downgraded from 5.0 because I loathe it and it also had no effect on the skipping)
    Sprint
    LG Tone Infinim BT earbuds
    Players tried: Stock player, Pandora. Will try Google and Amazon music next.
    05-18-2015 11:23 PM
  6. dmagikwand's Avatar
    Rooting also does not always work...
    I just have my Galaxy S6 for a few weeks and it also has the ocassional hiccup when streaming spotify or using the stock music app when connected to my bluetooth headphones.
    No suggestions have worked so far... I've rooted the phone and increased the CPU speeds, it has no external sd card so removing it isn't an option, turning off gps does not work and even the leave the screen on method does not work with me.

    I'm really clueless here...
    This is good to know. I've never rooted, but this issue has made me come damn close in recent months. Knox scares me too much though. Does the GS6 only do it with the screen off or does it matter?

    EDIT: Nevermind. I see where you said the screen on method doesn't work either :/
    05-19-2015 03:10 AM
  7. dmagikwand's Avatar
    Still working for me. I listened to 5 consecutive albums last night with the stock player and no skips. I thought it did for a minute but it turned out somebody had just sent a message and this caused the volume to lower a bit. 3 hours of Pandora the day before with no skips. So far the timer doesn't seem to cause too much drain and not really a nuisance at all running a bit behind the scenes. Also, I like the idea of being able to easily control how long it runs. If I set it for 5 hours, then it will do its 5 hours and stop instead of running forever until I kill it. Just have to remember to turn it back on when listening to tunes...my phone skips about every 30-40 seconds without it so that is an easy reminder lol.
    I keep forgetting to check the battery usage because I keep plugging my phone in at night and forget about it until the next day.

    Galaxy 5 4.4 (downgraded from 5.0 because I loathe it and it also had no effect on the skipping)
    Sprint
    LG Tone Infinum BT earbuds
    Players tried: Stock player, Pandora. Will try Google and Amazon music next.

    UPDATE:
    OK, so now this is getting weird. After using the timer workaround very, very heavy for the past 3 days with no glitches ( I was using headphones and listening intently for skips so I'm positive), I decided to turn the timer off after it had ran for a couple of hours on day 3 and see what happened. Guess what? NO SKIPS. I tried everything, running stock player and Pandora to get a skip. I was practically begging for a skip, but then I played 2 or so more hours after turning the timer off and nothing. No skips whatsoever. I'm a guy that has had a really bad case from the beginning, like a skip every 30-40 seconds per song. But now I was getting nothing, no skips after turning the timer off and screen was still off.
    Then I made the apparent mistake of rebooting the phone, re-paired with my headset and the skips were back to normal with the screen off.... a skip every 30-40 seconds.
    I go back to the "screen on" method, setting my display time out to 10 minutes and now we are back to no skipping while the screen is on.
    So now I decide to stop the music momentarily and set up the timer again....stop music, screen timeout back to 1 minute, timer back on, music on.
    Skipping is back to normal with the screen off and the timer running. I have never previously made it 3 minutes much less the 3 days and I thoroughly enjoyed this workaround I thought I had found. I was happy enough I was just getting ready to take advantage of a deal on Amazon and get another pair of my LG Infinims for 89 dollars (a great price on these) and then crash, boom.
    Depressing.
    All I can think of at this point is clearing the main cache partition, the Bluetooth cache, then running the timer again and seeing what happens.


    Update #2:
    Things seem better using the timer after the reboot if I let the screen time out naturally instead of hitting the power/lock button as my hands have been taught to do over the years. Naturally and with timer progressively gets better as more tracks play. Still not perfect as it had been the past three days but I can get several songs to play without a skip until not really very noticeable (5-20 minutes clear play early on the post-reboot experiment so far) after the first couple or three songs have a little skipping so long as I don't hit the lock button to turn the screen off. Still better than the every 30-40 second cut outs. The last time wasn't just luck...I just know it, I just don't know why my reboot killed it?


    Update #3
    Screw it. This is still irritating me. Update #2 information isn't as solid as I first thought it was. It varies. Sorry about that. And then I shouldn't have to spend my hours trying all this crap when it is probably a simple patch with the right update if a certain company or two would just do it. I'm getting a new phone. I'm first going to try and push the 1 year warranty at the Sprint store and hope for a straight up exchange for a brand new GS5 that might not have a problem (I'll have it running 4.4.4 by the end of the day). I LOVE the GS5 with KitKat other than this little bug, dammit. I don't want to quit the phone but I'm not afraid to switch carriers. If they try and force me to pay 200 for a refurb, then I will tell them to stick it and buy out the rest of my contract.
    05-19-2015 05:28 AM
  8. Arjan Strijland's Avatar
    Well I live in the Netherlands and here the vendors have to give warranty even when a phone is rooted I really hope the lollipop 5.1 update will fix this issue for me as I have heard that changing roms or kernals sometimes improves the matter.
    05-19-2015 09:15 AM
  9. dmagikwand's Avatar
    I'm very close to doing some serious reading up on rooting...if somebody can positively show me they fixed their issue without triggering knox, then I am all ears. Otherwise, tomorrow or the next day I'm pitching my GS5 onto the Sprint counter and will cross my fingers that the Bluetooth misbehaves while they are listening. I've learned that it is to your advantage to be two steps ahead of them like when they say "well, we'll try so and so" and I'm like," dude, I've done that a dozen times...it is a waste of time." Usually a quicker route to getting what I need and a time saver.
    My problem is I bought the phone at Radio Shack because the people that work there are smarter. Heck, maybe Radio Shack will just switch me out phones even. Fingers crossed.
    05-19-2015 09:43 AM
  10. PlanetPluto7's Avatar
    Doing the same. i still get a few skips at the gym but hardly any.
    05-19-2015 04:18 PM
  11. PlanetPluto7's Avatar
    No. I used one of those screen always on Apps and that cut it down to almost none at the Gym. Lost the app somehow??? so I need another; it's not in "my apps". No change when I went to Lollipop; Did'n reset or anything. Keeping the screen on worked greet on both OSs.
    05-19-2015 04:26 PM
  12. sparksd's Avatar
    No. I used one of those screen always on Apps and that cut it down to almost none at the Gym. Lost the app somehow??? so I need another; it's not in "my apps". No change when I went to Lollipop; Did'n reset or anything. Keeping the screen on worked greet on both OSs.
    This is what I use:

    https://play.google.com/store/apps/d...uttoggle&hl=en
    05-19-2015 05:03 PM
  13. tlo07's Avatar
    Rooting also does not always work...
    I just have my Galaxy S6 for a few weeks and it also has the ocassional hiccup when streaming spotify or using the stock music app when connected to my bluetooth headphones.
    No suggestions have worked so far... I've rooted the phone and increased the CPU speeds, it has no external sd card so removing it isn't an option, turning off gps does not work and even the leave the screen on method does not work with me.

    I'm really clueless here...
    I'm not having this issue at all with my GS6. I'm not using Nova on the GS6 like I did on the Note 4. Are any of you guys having skipping issues using the stock launcher? Maybe it's 3rd party launchers causing the issue?

    Sent from my iPad using Tapatalk HD
    mountainbikermark likes this.
    05-19-2015 07:17 PM
  14. dmagikwand's Avatar
    Does this app keep the screen lit when the phone is also in the lock screen in addition to the main screens to prevent things such as [language removed by moderator] dialing? I have tried 2 others but they don't work on the lock screen.
    05-20-2015 04:06 AM
  15. kgk1985's Avatar
    I'm starting to think mine is a hardware defect. If I have my phone in my picket and push it against my leg, it skips every time. And if I have the battery door off and push hard just to the right of the camera it skips too. Maybe a sensor?
    05-20-2015 04:39 AM
  16. sparksd's Avatar
    Does this app keep the screen lit when the phone is also in the lock screen in addition to the main screens to prevent things such as [language removed by moderator] dialing? I have tried 2 others but they don't work on the lock screen.
    It does but it it leaves a notification up that the screen will remain on.
    dmagikwand likes this.
    05-20-2015 11:02 AM
  17. dmagikwand's Avatar
    It does but it it leaves a notification up that the screen will remain on.
    Ah, OK. I see. If I hit the power/lock button it goes blank, but then if I hit the button again the phone lights up again in the lock screen and then stays on until I either hit he button again or unlock the phone and turn the app off. Took me a few minutes to figure that about the lock button.
    I'm keeping my screen dimmed all the way unless I'm using it for something else. Pretty good workaround. This is overall unacceptable from Samsung, however.
    Thanks.
    05-20-2015 05:47 PM
  18. sparksd's Avatar
    Going back to the idea that this problem is related to CPU slowdown: I found this app on the Play Store (RedEye Stay Awake):

    https://play.google.com/store/apps/d...eye.free&hl=en

    I downloaded the free version and have been trying it out. With this enabled and the screen turned off, I've listened to several songs consecutively over Bluetooth without a single skip. I'm not ready to commit to this as a confirmed workaround yet but I wanted to get this out there for others to give a try.
    05-20-2015 06:17 PM
  19. Soreloser's Avatar
    Having battled with this issue since I bought the phone, I recently tried something that at this time appears to have fixed it for me.

    That said, what I have done is turn on the Ultra Power Savings mode and then turn it back off so that my phone is not in any sort of power savings mode. At that point I have no skips or other issues with my music through blue tooth UNTIL I reboot the phone for any reason. Then the problem reappears until I do the on then off of the Ultra Power Savings mode.

    Does this work for anyone else?
    05-20-2015 06:45 PM
  20. Carl Andrews1's Avatar
    Yeah I have the Note 4 with Lollipop 5.0.1 and it is horrible when running or even walking using my LG Bluetooth head phones , it skips maybe once a song when played through my Eonon stereo.
    05-20-2015 11:24 PM
  21. dmagikwand's Avatar
    Having battled with this issue since I bought the phone, I recently tried something that at this time appears to have fixed it for me.

    That said, what I have done is turn on the Ultra Power Savings mode and then turn it back off so that my phone is not in any sort of power savings mode. At that point I have no skips or other issues with my music through blue tooth UNTIL I reboot the phone for any reason. Then the problem reappears until I do the on then off of the Ultra Power Savings mode.

    Does this work for anyone else?
    Not for me.
    I turned on Ultra
    Connected Bluetooth
    Turned off Ultra
    Works fine until screen turns off as usual and then it
    still Skips about every 40 seconds or so on both stock player, Pandora, etc.

    Was there any specific order you did these steps?
    05-21-2015 02:17 AM
  22. dmagikwand's Avatar
    Going back to the idea that this problem is related to CPU slowdown: I found this app on the Play Store (RedEye Stay Awake):

    https://play.google.com/store/apps/d...eye.free&hl=en

    I downloaded the free version and have been trying it out. With this enabled and the screen turned off, I've listened to several songs consecutively over Bluetooth without a single skip. I'm not ready to commit to this as a confirmed workaround yet but I wanted to get this out there for others to give a try.
    I've downloaded it and am willing to experiment. Could you confirm the Red Eye settings you are using (e.g Awake level, etc)?
    05-21-2015 02:33 AM
  23. dmagikwand's Avatar
    Having battled with this issue since I bought the phone, I recently tried something that at this time appears to have fixed it for me.

    That said, what I have done is turn on the Ultra Power Savings mode and then turn it back off so that my phone is not in any sort of power savings mode. At that point I have no skips or other issues with my music through blue tooth UNTIL I reboot the phone for any reason. Then the problem reappears until I do the on then off of the Ultra Power Savings mode.

    Does this work for anyone else?
    I forgot to ask, are you running Lollipop or Kitkat and what version?
    05-21-2015 06:57 AM
  24. sparksd's Avatar
    I've downloaded it and am willing to experiment. Could you confirm the Red Eye settings you are using (e.g Awake level, etc)?
    Been playing with it and finding that it has some wonky behavior on the Note 4 (at least on mine). After I open the app once and it starts its service, I can no longer open the app though I can toggle the enable/disable it through its notification icon. I have to force stop it and then select the Open option for it in the Play Store to open the app. Also, it seems to have short-term effects on the back button. I was choosing "CPU Only" awake level, don't start on boot, don't enable at start, disable on low battery, don't enable on AC, don't disable when screen off, don't disable icon.
    05-21-2015 08:38 AM
  25. Soreloser's Avatar
    I turned the phone on, connected bluetooth, set it in Ultra, turned ultra off, reconnected bluetooth; Running AT&T Lollipop. I use the Google Music player. I do not use any streaming like Pandora, just music I have put on the phone. I am not using any memory card either. just the built in memory on the phone.
    05-21-2015 08:41 AM
282 ... 34567 ...

Similar Threads

  1. What's a Good Bluetooth Kit for your Vehicle/Note4?
    By DMarie04 in forum Samsung Galaxy Note 4
    Replies: 10
    Last Post: 03-23-2015, 01:41 PM
  2. Replies: 1
    Last Post: 01-03-2015, 11:08 AM
  3. Why do the images on my Note 4 looked blocky?
    By bedfordharpist in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 01-02-2015, 05:04 PM
  4. Replies: 0
    Last Post: 01-02-2015, 11:35 AM
  5. For the Samsung Galaxy Note 4 is there a simple audio reminder app?
    By isabel95 in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 01-02-2015, 09:46 AM
LINK TO POST COPIED TO CLIPBOARD