1. Kollie's Avatar
    I sync to Outlook on my PC using Samsung Kies3
    01-06-2015 11:33 AM
  2. MightyMike's Avatar
    I had hundreds of contacts from Facebook in my contacts because I screwed up and synced all those people I don't know in person. Facebook went rogue that day. One thing you can do is go into the contacts app, click the 3 dots, select "settings", choose "contacts to display", there you will have a list of different contact books you can choose to display on your device.

    This might help. Worth a shot.

    MAY THE 4 BE WITH YOU!
    01-06-2015 01:02 PM
  3. makie's Avatar
    I had hundreds of contacts from Facebook in my contacts because I screwed up and synced all those people I don't know in person. Facebook went rogue that day. One thing you can do is go into the contacts app, click the 3 dots, select "settings", choose "contacts to display", there you will have a list of different contact books you can choose to display on your device.

    This might help. Worth a shot.

    MAY THE 4 BE WITH YOU!
    Yea got this as well.. Owned many phones and always paid attention not to sync these things.. Such a shame I never noticed it on my note 4.

    Like mike says, let the phone show phone contacts or sim contacts.

    Posted via the Android Central App
    01-06-2015 02:28 PM
  4. Timonthestoop's Avatar
    I had this problem on my Samsung S6 since Sept 2016. My phone contacts are normally Synced with Gmail. However I noticed that Microsoft Exchange Server is also now syncing and that's whats caused the unknow names to be populated. To fix the problem, I:
    1. Went to Accounts and first removed syncing for Microsoft Exchange Server ;
    2. Went into Contacts, clicked "More" (top right), "Settings" and then, in "Contacts to display" selected "Microsoft Exchange ActiveSync". This meant I was only seeing the contacts from my hotmail (i.e. isolated the contacts I didn't need, including all the 'unknown name' ones). Then I pressed and held an Unknown Name contact, hit "delete" and selected the 'all' checkbox. After that, I went back into settings and selected 'All' in "Contacts to display" to bring back in my other contacts.

    Hope this helps,
    Tim
    10-17-2016 12:26 PM

Similar Threads

  1. Why does my S5 screen turn on and off during phone calls?
    By magicalstephie in forum Ask a Question
    Replies: 4
    Last Post: 11-13-2017, 04:26 PM
  2. Has anyone else tried the new version of S Note on their 8?
    By the wallpaperguy in forum Samsung Galaxy Note 8.0 Tablet
    Replies: 11
    Last Post: 11-03-2016, 05:51 PM
  3. Why won't my unknown sources box stay checked??
    By Danawelch1 in forum Ask a Question
    Replies: 6
    Last Post: 02-16-2015, 06:01 PM
  4. How do you factory reset an Android tablet?
    By snoppy92 in forum Ask a Question
    Replies: 3
    Last Post: 01-07-2015, 11:31 AM
  5. Replies: 1
    Last Post: 01-06-2015, 05:58 PM
LINK TO POST COPIED TO CLIPBOARD