1. Yadadi's Avatar
    I was able to add Smart Lock as a Trust Agent, and then I added my Moto360 as a trusted device. But I'm still being forced to key in a pin or swipe my thumb when my device is locked. Any ideas? Is Knox the culprit? I do have it installed as part of my corporate mail setup.
    03-07-2015 02:02 PM
  2. LA2two's Avatar
    I'm having the same exact issue with the same setup. Moto 360 and corporate account on my phone. Hopefully someone can help us.
    03-08-2015 07:41 PM
  3. y2whisper's Avatar
    Posting this here as well just do the same with your moto 360 as well as the places (side note Moto 360 - jealous)

    Here is what worked for me on my N6 and N9.

    Turn off smart unlock on your home and work and remove any other addresses.

    under security in the advanced section choose trusted agents
    Turn off smart unlock
    back out (might not be necessary)
    go back in and turn it on

    Now add back in your addresses.

    Hope this helps.
    03-11-2015 02:53 PM
  4. Nitro211K's Avatar
    I have a Pebble that I tried this with, and I have a JVC car receiver, and I also have Knox for my Corp. e-mail. I am not having the issue you are. So it may very well be the Moto360. Also make sure not to swipe the Lock icon on the bottom (between the Phone and the Camera icons) since that will override the smart lock feature even if you are near a trusted device/location.(just swipe in the middle of the screen instead)
    03-11-2015 03:28 PM
  5. Yadadi's Avatar
    Whisper and Nitro, thank you for the help. Unfortunately, I tried Whisper's sequencing and it didn't help. I also tried another Bluetooth device and I'm having the same issue, so I don't think it's Moto360 problem. Perhaps this is particular to the way my company has configured Knox?
    03-12-2015 09:13 AM
  6. y2whisper's Avatar
    it could be. Since Knox is at system level. if you can try going to a Best buy or somewhere and try to do it with a demo unit. if it works for them I would guess you are on to something about it being Knox' fault
    03-13-2015 01:13 PM
  7. Yadadi's Avatar
    A colleague at the office has an S5 and he was able to get Smart Lock working fine though conceivably he is dealing with the same Knox limitations. I reviewed his settings and they appear to be identical to mine. Smart lock works as expected with his S5 but not at all for my Note 4. I can't get Smart Device or Smart Location to work! This is driving me crazy as Smart Lock is one of my favorite Lollipop features! Any ideas?
    04-02-2015 08:43 PM
  8. PookiePrancer's Avatar
    Mine works fine (Sprint).

    Posted via the Android Central App
    04-02-2015 09:26 PM
  9. Yadadi's Avatar
    Just tried a Factory Reset. It did the trick. Smart lock is now working.
    05-02-2015 07:22 AM

Similar Threads

  1. Replies: 2
    Last Post: 03-21-2015, 10:29 AM
  2. Replies: 1
    Last Post: 03-08-2015, 01:13 AM
  3. Maxx not connecting to Blue tooth
    By Racerb0y in forum Motorola Droid MAXX
    Replies: 1
    Last Post: 03-08-2015, 01:08 AM
  4. Replies: 1
    Last Post: 03-07-2015, 03:03 PM
LINK TO POST COPIED TO CLIPBOARD