1. rgn4's Avatar
    I've just upgraded my N910F to Lollipop 5.0.1 using Odin, no problem there.

    Went through the Google apps to disable for things I don't use - Play Music, Play Books etc.
    I've done this before without a hitch, but this time its gone wrong.

    I must have disabled something I shouldn't, because now I can't open Play Store from the phone - it just hangs.

    I can open the Play Store on my PC and send apps to the phone, so I know the account is set OK, but I can't open it directly from the phone.

    I don't want to go a factory reset because it would take me hours to reset all the apps and data the way I have them.

    Is there a way to just reset the Google apps? I've gone through the Apps Manager but can't see anything that should be turned back on.
    04-13-2015 06:36 AM
  2. Javier P's Avatar
    Go to settings - apps - "all" tab and make sure these apps are enabled:

    Google Play services.
    Google Play Store.
    Google Services Framework.

    If you disabled any of them they will be in the disabled tab. If so enable them back.
  3. Javier P's Avatar
    Go to settings - apps - "all" tab and make sure these apps are enabled:

    Google Play services.
    Google Play Store.
    Google Services Framework.

    If you disabled any of them they will be in the disabled tab. If so enable them back.
    skatergirl likes this.
    04-13-2015 06:47 AM
  4. rgn4's Avatar
    Thanks for quick reply!
    Those three services all seem to be running - They all have a Disable button, not Enable.
    I can't see a Disabled Tab at all.

    Edit:
    As an experiment I disabled Google Play Services, and it appeared in a Disabled tab. I enabled it again.
    04-13-2015 07:20 AM
  5. Javier P's Avatar
    Being a Samsung phone that tab could be named "turned off" apps. Try to find it and see what's in there.

    Also, you could try to boot your phone into recovery mode and wipe the cache partition. That's always recommended after a system update. No data will be lost.
    04-13-2015 07:24 AM
  6. rgn4's Avatar
    I've done the cache wipe, no difference. If I start Play Store it just hangs at a plain gray screen.
    There are no disabled services. I tried that, per my edit above.

    This is looking very like I'm going to have to do a factory reset - not happy about that.
    04-13-2015 08:05 AM
  7. maduro78's Avatar
    Is your time and date correct?

    Moto X 2014
    rgn4 likes this.
    04-13-2015 08:12 AM
  8. rgn4's Avatar
    Yep!
    04-13-2015 08:17 AM
  9. rgn4's Avatar
    I've tried with my old Note2 with the same account settings, and it opens the Play Store straight off
    04-13-2015 08:35 AM
  10. sparksd's Avatar
    How about reinstalling Play Store. APK available here (via Android Police, a trusted source):

    Google Play Store 5.4.10 APK Download - APKMirror
    rgn4 likes this.
    04-13-2015 09:23 AM
  11. rgn4's Avatar
    sparksd
    Yes! That did it. I installed the latest version on that site and it's good to go!

    Thanks a million!
    04-13-2015 10:02 AM
  12. sparksd's Avatar
    sparksd
    Yes! That did it. I installed the latest version on that site and it's good to go!

    Thanks a million!
    Excellent - glad to have helped.
    04-13-2015 10:03 AM

Similar Threads

  1. [APP][3.0+] TimeBoss 2.0: set multiple timers for everyday tasks
    By EdwinBos in forum Android App Inventor
    Replies: 12
    Last Post: 01-29-2016, 06:38 AM
  2. Replies: 1
    Last Post: 04-15-2015, 09:02 AM
  3. Replies: 1
    Last Post: 04-13-2015, 12:10 PM
  4. Google Contacts - Backup from Windows PC.
    By pollensa1946 in forum General Help and How To
    Replies: 0
    Last Post: 04-13-2015, 05:30 AM
  5. Replies: 0
    Last Post: 04-13-2015, 02:28 AM
LINK TO POST COPIED TO CLIPBOARD