1. vettech29's Avatar
    Unable to activate device administrator in settings for Android device manager. Will not select. The app locates my phone fine but when I go to set up lock and erase for some reason it does not allow me to activate as device administrator... I have a Verizon Galaxy Note 4. Stock.
    R0tten likes this.
    04-13-2015 06:53 AM
  2. skatergirl's Avatar
    Unable to activate device administrator in settings for Android device manager. Will not select. The app locates my phone fine but when I go to set up lock and erase for some reason it does not allow me to activate as device administrator... I have a Verizon Galaxy Note 4. Stock.
    I wish I could help you. Hopefully someone comes along soon. I use AGV anti-virus and have activated a device manager through this app.
    04-13-2015 10:15 AM
  3. beh's Avatar
    I believe you first have to give the App authorization to have administrative privileges. You may wish to check Settings>Security>Phone Administrators. If Listed but not Checked check it. If it isn't listed there you may wish to try uninstalling and reinstalling the Android Device Manager and check for it being listed again.
    junk forever and R0tten like this.
    04-13-2015 08:39 PM
  4. Paul Owens1's Avatar
    Know how to do it. But it won't respond.??
    03-23-2016 01:11 PM
  5. nahoku's Avatar
    Android Device Manager is Google Play Services. Try force stopping Google Play Services, and turning it off... this should remove Android device manager from Device/Phone Administrators. Then turn Google Play Services on again... this will make it show up in Device/Phone Administrators again. Hopefully, you can activate it with no problems.
    03-23-2016 06:07 PM
  6. candyearlier's Avatar
    I had this issue and found this page, but my issue turned out to be a red light filter app (Twilight) that was blocking it. Disabling the app allowed the "activate" button to work.

    Hope this helps someone.
    birdae, R0tten and plamen-vn like this.
    02-21-2017 03:31 AM
  7. David Nugent's Avatar
    I had this issue and found this page, but my issue turned out to be a red light filter app (Twilight) that was blocking it. Disabling the app allowed the "activate" button to work.

    Hope this helps someone.
    Sure did! Had me scratching my head big time until the word "twighlight" was mentioned.. right on the money. Just pausing it is enough, can switch it back on immediately once settings are changed.

    Thank you.
    R0tten likes this.
    06-20-2017 07:53 AM
  8. birdae's Avatar
    I had to do the same thing -- except in my case, the culprit was my BLUE light filter!
    R0tten likes this.
    09-09-2017 06:28 PM
  9. R0tten's Avatar
    I registered just to say THANK YOU to @candyearlier for the SOLUTION and @vettech29 for the REPORT! If it wasn't for these 2 folks I never would've figured it out!

    In my case, the problem was with an app called "Lux."
    CosmicFurface likes this.
    11-15-2017 01:41 PM
  10. CosmicFurface's Avatar
    "lux" was also my problem, thanks all!
    01-13-2018 10:36 AM
  11. plamen-vn's Avatar
    Thank you @candyearlier! In my case (Samsung S8) it was built-in Blue Light filter feature. After (deactivating it I can manage device administrators. Strange bug, still not fixed.
    02-14-2018 02:56 PM
  12. Kapil Bansal's Avatar
    1. Apps such as Blue light filter apps constantly appear on the top of your screen thus breaking some of the on screen functionalities. Try disabling display over other apps permission of such apps and you should be fine. If you don't know which apps to disable, first enable show system apps and then disable all apps.

    2. If you have custom ROM installed such as Resurrection Remix(which was my case) who provides Smart Pixels feature under Settings ->Configurations -> Interface -> Smart Pixels , try disabling that too and you will be able to toggle device admins as well as accessiblity of apps.

    3. Also, sometimes it is because of your custom launcher, so try switching to your stock launcher if above solutions don't work.

    4. If Accessibility for some apps are on then try disabling them first then try to enable for the apps you wanted to.

    5. Uninstalling the anti-virus helps sometimes.

    P.S. : Of all the above possible solutions, try the ones which are more suitable to your condition. For eg. you can't try solution number 2 if your ROM doesn't have Smart Pixels.

    Hope it helps.
    09-02-2018 12:44 PM

Similar Threads

  1. S6 Ported Rom for i9500 ANDROIDSHQIP ROM V2 FOR THE i9500 coming SOON !!
    By Elton Krasniqi in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 04-13-2015, 06:19 AM
LINK TO POST COPIED TO CLIPBOARD