1. anon(52425)'s Avatar
    So my home internet connection (Comcast XFinity Wi-Fi) SUCKS on my Note 4. And only on my Note 4 (My Macbook, girlfriends iPhone, Smart TV, etc all work just fine). I thought maybe there was something wrong with the WiFi module in my Note 4 so I went over to my friends house and connected to him and it worked excellent. I tested this one more time by walking over to Starbucks and connected to them. Same result, worked great. But when I am back home, it connects but is extremely sluggish and slow. It can take about 20-30 seconds to load a simple page, pulling up Facebook takes a long time to load stories and images. Does anyone happen to know what is up with that? It's so slow that I have been sticking to my LTE data connection (T-Mobile) but I don't have unlimited so I will burn through that real quick here soon.

    Thanks!
    06-17-2015 08:39 AM
  2. VW Maverick's Avatar
    06-17-2015 08:44 AM
  3. anon(52425)'s Avatar
    Thanks, i'll check it out!
    06-17-2015 08:52 AM
  4. tsells's Avatar
    So my home internet connection (Comcast XFinity Wi-Fi) SUCKS on my Note 4. And only on my Note 4 (My Macbook, girlfriends iPhone, Smart TV, etc all work just fine). I thought maybe there was something wrong with the WiFi module in my Note 4 so I went over to my friends house and connected to him and it worked excellent. I tested this one more time by walking over to Starbucks and connected to them. Same result, worked great. But when I am back home, it connects but is extremely sluggish and slow. It can take about 20-30 seconds to load a simple page, pulling up Facebook takes a long time to load stories and images. Does anyone happen to know what is up with that? It's so slow that I have been sticking to my LTE data connection (T-Mobile) but I don't have unlimited so I will burn through that real quick here soon.

    Thanks!
    See this:
    https://plus.google.com/+DerekRoss/posts/iTMnRL4ZPhB
    anon(52425) likes this.
    06-17-2015 09:19 AM
  5. anon(52425)'s Avatar
    Thanks for the nudge in the right direction. A combination of those things from the tutorial seemed to do the trick.
    06-17-2015 09:21 AM
  6. anon(52425)'s Avatar
    Thanks so much for that as well. I used the guide and it seemed to have fixed this issue but if it does down again then I will know that is a Comcast thing. I appreciate you sharing that!
    tsells likes this.
    06-17-2015 09:22 AM
  7. beh's Avatar
    Unfortunately for me the work around doesn't work on my Note 4 or roommates S5.
    06-17-2015 11:06 AM
  8. anon(52425)'s Avatar
    Sorry to hear that. It was very very frustrating.

    My only other complaint is that the battery life is horrible. Lollipop seems to be a huge drain. I can't compare it to KitKat as my Note 4 came with Lollipop out of the box but from what I read on the forums, Lollipop has big battery issues. I can't wait for a fix to that. I ended up buying a spare battery after 2 hours with the phone.
    06-17-2015 11:59 AM
  9. anon(52425)'s Avatar
    Well that lasted about an hour and it's back to being slow. How very annoying.
    06-17-2015 12:27 PM
  10. kirksucks's Avatar
    I'm getting the same with my suddenlink WiFi. I have 50 down and I get...... loading... On many apps. Chromecast keeps screwing up.

    Posted via the Android Central App
    06-17-2015 11:07 PM
  11. sweetypie31's Avatar
    It's a Comcast!/xfinity issue. I was having connection issues on my note a few months ago. I even had the issue on kit Kat. After many resets of the phone and the modem it eventually fixed itself. Every now and then it will stop working but then it will go back to normal.
    06-18-2015 05:07 AM
  12. beh's Avatar
    It's a Comcast!/xfinity issue. I was having connection issues on my note a few months ago. I even had the issue on kit Kat. After many resets of the phone and the modem it eventually fixed itself. Every now and then it will stop working but then it will go back to normal.
    I too have had this issue with more than one phone and have found if I reboot the modem it clears for some time. I also have noted that the problem for me seems to occur on Sundays much more often than any other day of the week.
    06-18-2015 11:38 AM
  13. sweetypie31's Avatar
    I too have had this issue with more than one phone and have found if I reboot the modem it clears for some time. I also have noted that the problem for me seems to occur on Sundays much more often than any other day of the week.
    I was also having issues with other devices. The first reset of the modem helped those devices, but my note still was slow and sometimes wouldn't connect.
    06-18-2015 05:51 PM
  14. anon(52425)'s Avatar
    I was also having issues with other devices. The first reset of the modem helped those devices, but my note still was slow and sometimes wouldn't connect.
    I have reset/rebooted my modem 3 times since posting this. Each time, my Note 4 speed is excellent and normal for about 2 hours and then I loose it. I hope this is addressed ASAP.
    06-18-2015 09:44 PM
  15. sweetypie31's Avatar
    I have reset/rebooted my modem 3 times since posting this. Each time, my Note 4 speed is excellent and normal for about 2 hours and then I loose it. I hope this is addressed ASAP.
    My issue eventually fixed itself on my note.
    06-18-2015 10:06 PM
  16. Scottahart65's Avatar
    So my home internet connection (Comcast XFinity Wi-Fi) SUCKS on my Note 4. And only on my Note 4 (My Macbook, girlfriends iPhone, Smart TV, etc all work just fine). I thought maybe there was something wrong with the WiFi module in my Note 4 so I went over to my friends house and connected to him and it worked excellent. I tested this one more time by walking over to Starbucks and connected to them. Same result, worked great. But when I am back home, it connects but is extremely sluggish and slow. It can take about 20-30 seconds to load a simple page, pulling up Facebook takes a long time to load stories and images. Does anyone happen to know what is up with that? It's so slow that I have been sticking to my LTE data connection (T-Mobile) but I don't have unlimited so I will burn through that real quick here soon.

    Thanks!
    11-24-2015 04:48 PM
  17. Scottahart65's Avatar
    Could you guys please help I just replaced my note 4. I have Comcast wifi with the exact same issue. .. what did you do to fix this... I have 50mbs down but lagging on loading all pages and Facebook and YouTube app.... so slow like 30 seconds to load small page
    11-24-2015 04:50 PM

Similar Threads

  1. Is the Nexus 6 the best unlocked phone for Verizon?
    By Frenzytom in forum Google Nexus 6
    Replies: 7
    Last Post: 07-05-2015, 12:50 PM
  2. Whatsapp stopped sharing media, is there a fix for this?
    By AC Question in forum Android Apps
    Replies: 3
    Last Post: 06-22-2015, 10:28 AM
  3. Replies: 1
    Last Post: 06-19-2015, 02:58 PM
  4. Slow Group Texts On Android 5.0?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-19-2015, 02:40 PM
  5. Blutooth connection in Car with Samsung S6
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-19-2015, 12:33 PM
LINK TO POST COPIED TO CLIPBOARD