1. hopefulfarm's Avatar
    After the Lollipop update, my Sprint Note 4 GPS has been MISERABLE.

    I use my phone when I run and cycle, to track my routes for training. I used to use JogTracker Pro. When the GPS issues started I thought maybe it was the software, so I switched to Runtastic Pro. It appears the problem is the phone. I never had so much trouble before! The GPS loses signal in the middle of town! And then it can't re-establish GPS for LONG amounts of time! Sometimes 1.5 miles, sometimes 15 miles! It is INSANE how poor the GPS has gotten.

    Sunday I went on a 2 hour cycling ride, 1 mile in it lost GPS signal and NEVER regained the signal. Over 30 miles of open road riding and the GPS never re-connected.

    I have tried all the various GPS settings in the settings menu (under Location - Mode). GPS only. Power saving. High accuracy. They all SUCK at this point. What happened? Is it only the Sprint Note 4? Is it all Note 4? Is it Lollipop on all phones?

    I am SO disappointed. I had NO problem tracking training routes up until the Lollipop update! Looks like I'm going to have to invest in more technology (running watch, cycling computer) when previously I didn't have a need.
    07-06-2015 01:26 PM
  2. jreuschl's Avatar
    There isn't a 5.1.1 update yet. There was a bug fix update today. See if that fixes any issues and clear cache after.

    5.1.1 is still in testing.
    07-06-2015 04:32 PM
  3. hopefulfarm's Avatar
    Yeah I"ve been talking so much about 5.1.1 because of my Moto 360. REGARDLESS. Since my N4 has received Lollipop, the GPS SUCKS. I don't think the Reactivation Lock update will improve the GPS issue.
    07-07-2015 08:10 AM
  4. goin_nil's Avatar
    Not seen this issue on Verizon Note 4. Good luck.
    07-07-2015 08:30 AM
  5. goin_nil's Avatar
    This might be worth a try:
    "The other thing I've noticed since lollipop is i have to make sure Goople maps is installed and updated and until i open Google maps and let it get a fix my gps seems to be wonky."

    Suggestion from here:
    http://forum.xda-developers.com/note...ssues-t3112887
    07-07-2015 08:37 AM
  6. natehoy's Avatar
    AT&T Note 4 here, and the GPS has been "not great" since KitKat on mine. Lollipop initially made it much worse, but a factory reset made things better than KitKat had been (which is to say, I'll sometimes have the GPS stop following me for a short period of time, say up to about a minute, then it'll hurry along and catch back up). It used to be that the GPS would stay in place for 30-90 seconds, then I'd lose GPS signal entirely for 30 seconds or so, then it would pop back into place.

    A few things to try, in order of impact.

    1. Clear the cache partition. This is usually done by turning the phone off, then pressing and holding POWER - HOME - VOLUME UP until the phone vibrates, then release the other two and hold VOLUME UP until a menu appears. One of the options is "clear cache partition". Run that once or twice, then select "reboot phone".

    2. Turn off LTE services. You'll still get LTE data, but you won't be using Voice over LTE or some of the other stuff. Dunno why that seems to help, but it made mine marginally better. Menus vary a bit, but on mine it's Connections / More Networks / Mobile Networks / Mobile Data. Uncheck "Enhanced 4G LTE Services".

    3. Turn off "Smart Network Switch" - that's under WiFi. That also seemed to make a marginal improvement to my GPS stability.

    4th and last resort: Factory reset.

    I ended up with a factory reset, THEN turning off LTE and Smart Network, and the GPS is working fairly well now. Not perfect, but sufficient for my use.
    07-07-2015 09:30 AM
  7. Splissplos's Avatar
    My s4 doesn't connect to gps after lollipop update. If I restart then it will connect straight away. Haven't found any other way to get to work.
    08-27-2015 12:28 PM
  8. bassplayrguy's Avatar
    My solution to this will be buying a Note 5.
    08-27-2015 01:03 PM
  9. bgbagz's Avatar
    Had a similar problem with my T-Mobile note 4... They sent me a replacement... Something about when a customer does the update thier self vs a manufacturer doing it.... Works great now

    Sent from my SM-N910T using Tapatalk
    08-27-2015 09:06 PM
  10. roxetak's Avatar
    It is a android lollipop 5.1.1 problem. I´ve got the same problem after updating my Sony Xperia m2 to lollipop. Poor Terrible. ******* Google. What permission they broke? Or block, or make a bug in droid?
    10-05-2015 11:18 AM
  11. canonmaster's Avatar
    Try enabling Airplane Mode, or whatever disables your phone connection, it works on my Sony Xperia M2. You may not be able to make/receive calls but the GPS works
    01-01-2016 12:45 PM

Similar Threads

  1. Why can I not update the Google Play Store?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-07-2015, 09:06 AM
  2. Replies: 0
    Last Post: 07-06-2015, 12:38 PM
  3. Replies: 0
    Last Post: 07-06-2015, 11:32 AM
  4. Why do my Android Mi4 songs change automatically after 23 seconds?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 07-06-2015, 11:06 AM
  5. Alarm after skipping a day
    By tdizzel in forum Motorola Droid Turbo
    Replies: 1
    Last Post: 07-06-2015, 09:20 AM
LINK TO POST COPIED TO CLIPBOARD