1. muwu's Avatar
    I've been noticing a sharp uptick in the speed my battery has been draining since about a week ago. What's peculiar is that the battery drain is quite noticeable even when I'm not using the phone or even when it's in ultra power saving mode. I've lost 7% power in ultra power saving mode yesterday in like 2 hours, when normally I would lose only 2% in 6 hours or so. Looking at my power saving settings today, the main user seems to be google services with 12%. But I don't think that would cause the sharp drop in battery I've been experiencing, I've lost almost 50% in 6 hours with very little usage. My battery or phone isn't old either, it's less than 6 months old. What could be causing this?

    This all started last week when I was surprised when my alarm didn't sound only to find out my phone had died during through night, and that perplexed me since I had 40% or something and that should be more than enough to last the night especially with no usage. I've also tried clearing the partition cache to no effect
    09-28-2015 02:48 PM
  2. nahoku's Avatar
    You need to start your phone in Safe Mode to see if the problem persists. If the problem goes away, then it's an app you installed that's causing it. Before safe mode, you could also install Quick System Info to see if an app is using a lot of CPU cycles.

    Of course, it could also just be a bad battery even though the phone is new.
    09-28-2015 08:41 PM

Similar Threads

  1. Replies: 3
    Last Post: 10-22-2015, 05:52 PM
  2. Replies: 5
    Last Post: 10-04-2015, 06:36 PM
  3. Note 3 [Grey Battery, Vibration, not charging] N9005
    By shrry8 in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 09-28-2015, 01:37 PM
  4. Replies: 0
    Last Post: 09-28-2015, 08:13 AM
  5. Which is the best battery backup for Android mobiles in normal price?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-28-2015, 02:20 AM
LINK TO POST COPIED TO CLIPBOARD