1. hyfurd2112's Avatar
    Hello everyone. I have a Samsung Note 4 910T from t mobile. The reason why I didnt list my os im running is because even though I downgraded from lollipop to kitkat, it didnt fix my problem. The problem is my OTG connector. Here is the story:
    A couple days ago, I bought a MHL connector where you can connect a sd card, micro sd card, usb, and hdmi. Its basically a 5 in 1. The HDMI worked, but all the other functions did not. I thought it was the connectors problem, but when I plugged in an OTG cable I had with a USB the Note 4 was not able to detect the USB. The OTG connector and USB are working as I have fully tested out its functionality on another tablet, the Samsung TAB A. However, in the notification bar on my Note 4 it does say "USB Connector Connected" But, even using My Files to search for USB Drive A or using a third party program like ES File Explorer I was not able to find the USB Drive connected. I have tried factory resetting, clearing catche, and even downgrading from lollipop to kitkat. Does anyone have a solution?
    10-17-2015 02:27 PM
  2. onefastneonrt's Avatar
    I am having the same exact problem!!!!!!!
    New Verizon Note 4 running lollipop 5.0.1 with the VRU2BOG5 baseband. I have tried all 3 of my OTG cables including my Samsung one and none of them work with a flash drive. Like the OP has said, when the cable is connected the phone displays "USB connector connected" in the drop down notification menu. From there the phone does nothing and the light within the flash drive does not illuminate. On the other hand if I remove the flash drive and install a dongle for a wireless mouse or keyboard etc. voila it works. I have done everything as the OP has from clearing cache to reinstalling firmware via Kies, tried 5 different flash drives and have had no luck.
    Please please please any help from someone would be greeeeeaaaatly appreciated.
    10-18-2015 12:03 PM
  3. hyfurd2112's Avatar
    Sorry I have "liked" your post onefastneonrt. That is kinda messed up I didn't realize. Anyways, I am thinking this could be a problem with the hardware like the USB charging port on the Note 4 maybe? If not it could be something else like firmware although this shouldn't be happening because I don't remember abusing my phone in any way shape or form. There is a way to shed some more light on this subject. My friend also has a Note 4 T-Mobile and for him the OTG works perfectly. I am going to try out the MHL 5 in 1 adapter with his phone to see if it is a problem with something else. Fingers crossed for tommorow.
    10-18-2015 03:25 PM
  4. hyfurd2112's Avatar
    Replied to your post, I forgot to use this feature.
    10-18-2015 03:26 PM
  5. onefastneonrt's Avatar
    No worries hyfurd2112. Yes I haven't figured if its a hardware issue or a firmware problem, I'm leaning towards a hardware issue. What's funny is I have tried my OTG/ flash drive combos on multiple phones (GS4, GS5, GS6, and a Note 5) all with different services (Sprint, T-Mobile, Verizon, and even Straight Talk) and they all worked. I am currently Odin flashing the phone again but I do not have high hopes. Hope you figure something out.
    10-18-2015 04:41 PM
  6. hyfurd2112's Avatar
    Yep, I definitly agree with you. When I used the exact same OTG connector and flash drive on my tab, it worked perfectly with no problems at ALL. I am stumped but I will be able to gather some more knowledge tomorrow.
    10-18-2015 04:46 PM
  7. hyfurd2112's Avatar
    So I just tested out the adapter on my friends T Mobile Note 4. All functions of the adapter work perfectly on his phone and his otg cable. This means that it is a problem that is most likely specific to the phone. I am wondering if any physical changes resulted in me not being able to use the otg function.
    10-19-2015 04:59 PM

Similar Threads

  1. Why Llama wasn't working on my Moto X Pure
    By Jay Sullivan in forum Moto X Pure Edition
    Replies: 4
    Last Post: 03-29-2016, 08:46 AM
  2. Grand Prime Html5 Font tag not working
    By mehigh101 in forum Ask a Question
    Replies: 0
    Last Post: 10-17-2015, 01:51 PM
  3. Why is my samsung s3 mini stuck on the loading icon`
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-17-2015, 01:49 PM
  4. Replies: 0
    Last Post: 10-17-2015, 01:46 PM
  5. Replies: 0
    Last Post: 10-17-2015, 12:54 PM
LINK TO POST COPIED TO CLIPBOARD