1. d4691's Avatar
    So, out of nowhere, my MMS decided to stop working. My APN stayed the same and I was unable to send group messages, and pictures, but could receive them. It was very odd. After two calls to "customer support", I got online to chat with a representative. this is what he said to do:

    "Please go to phone and enter this code: *#*#4636#*#* Then, click on phone information ... scroll down... you will see SMSC address... 701970010 click refresh and make sure it is +19703769830. If it's not that, please enter that in the field and click UPDATE."

    My SMSC address was empty. so perhaps this might fix it. I can send pics now, but its kinda late to test group text. lol.
    B. Diddy, Rukbat and aximtreo like this.
    01-30-2016 11:22 PM
  2. B. Diddy's Avatar
    Thanks for the tip!
    01-31-2016 02:40 AM
  3. Rukbat's Avatar
    Evidently they changed their SMS center (that's what SMSC is) phone number, and at least one phone got a null number when Cricket sent out the update. Some day, Google is going to learn that it's the 21st century. (Errorless updating is at least as old as 1989. That's when I wrote a system, and I'm sure I wasn't the first one to do it.)
    aximtreo likes this.
    01-31-2016 06:05 PM
  4. Pref0ntaine's Avatar
    How did you solve this issue? or did it just resolved on its own?

    This exact same thing is happening to me right now.

    I can receive MMS but cannot sent it and get in red "Message not sent: service not activated on network".

    I have not touched any APN settings and just yesterday I was sending MMS just fine.

    I dialed #*#4636#*# and the SMSC was blank so I hit "refresh" and this # came up 19703769830 then I hit update and nothing happens but that # remains.

    On this thread I'm not sure I read what the solution was.
    10-02-2016 06:54 AM
  5. Pref0ntaine's Avatar
    Well, just an update.

    I turned it off and removed the SIM card then turned it back on and its now working.

    Issue Solved!
    10-02-2016 07:12 AM
  6. vice86's Avatar
    How did you solve this issue? or did it just resolved on its own?

    This exact same thing is happening to me right now.

    I can receive MMS but cannot sent it and get in red "Message not sent: service not activated on network".

    I have not touched any APN settings and just yesterday I was sending MMS just fine.

    I dialed #*#4636 #*# and the SMSC was blank so I hit "refresh" and this # came up 19703769830 then I hit update and nothing happens but that # remains.

    On this thread I'm not sure I read what the solution was.
    i typed that in and I get "Connection problem or invalid MMI code"...wtf
    07-28-2018 06:02 PM

Similar Threads

  1. Replies: 3
    Last Post: 02-25-2016, 10:56 AM
  2. T-Mobile Autopay Issue - Anyone Esle?
    By SRFast in forum T-Mobile
    Replies: 3
    Last Post: 02-02-2016, 07:38 PM
  3. Contacts issue - can't see all info and edit some contacts?
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 01-31-2016, 06:18 PM
  4. I get an mms fail when I try texting a picture to someone
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-30-2016, 11:22 AM
  5. Replies: 0
    Last Post: 01-30-2016, 07:53 AM
LINK TO POST COPIED TO CLIPBOARD