1. mak916's Avatar
    For some reason my wifi keeps turning off and on by itself. It is making my phone hot and running down my battery. I have restarted the phone and it still does not help. Any Ideas as to what is going on?
    11-12-2016 03:59 PM
  2. mak916's Avatar
    Problem solved.
    11-12-2016 10:42 PM
  3. dseelye's Avatar
    What was the resolution? My phone is now doing this as well so interested in how you fixed the problem as I can't tell what is causing the wifi to turn on and off constantly and it's killing my battery life.
    11-13-2016 01:49 AM
  4. ghumlic1's Avatar
    Please let us know what worked to fix this! This is happening to me as well and I cannot figure out a fix!
    11-13-2016 08:41 AM
  5. davey_boyuk's Avatar
    I've got exactly the same problem ever since the last software update. I can fix it temporarily by quickly forgetting my WiFi network but once I've reconnected it soon happens again.

    Is this specific to the Samsung Galaxy s7 edge, which is what I have?

    Cheers, David
    11-13-2016 12:50 PM
  6. Andrewks's Avatar
    Work around from another thread. Settings to location to improve accuracy, turn off Wi-Fi scanning.
    tcmeiss likes this.
    11-13-2016 02:55 PM
  7. mak916's Avatar
    Work around from another thread. Settings to location to improve accuracy, turn off Wi-Fi scanning.
    This is the solution.
    ermitico likes this.
    11-13-2016 11:56 PM
  8. kasul's Avatar
    I had the exact same problem with the latest update (Android 6.0.1, security level Nov 1, 2016) on a Samsung Galaxy S7 Edge.

    I went so far as to do a hardware exchange to solve the problem - of course the problem came back on the second device.

    Solution posted here immediately fixed the issue. I called T-Mobile to let them know.
    12-06-2016 12:42 PM
  9. tcmeiss's Avatar
    Work around from another thread. Settings to location to improve accuracy, turn off Wi-Fi scanning.
    THANK YOU! This has been bugging me for weeks now. I thought it was an app, but couldn't figure out which one.

    ETA: It only seems to happen on my GS7 edge. Doesn't seem to do it on my Note 5...
    12-07-2016 08:31 AM
  10. maginoz's Avatar
    Work around from another thread. Settings to location to improve accuracy, turn off Wi-Fi scanning.
    OMG! Thank you so much! This finally worked. I thought I would need to buy a new phone! I was trying all sorts of things with settings and removing apps. Glad I don't have to waste more time on that.

    The only thing I found is that when i turned on location settings again it had this box ticked again - at least the first time. We'll see if it does it again. Thanks!
    12-09-2016 06:54 PM
  11. pchakr's Avatar
    Thanks! Immediately fixed my issue. So to document solution for my Google Pixel XL:

    Symptom: WiFi button kept turning off and on over and over again in infinite loop (not sure if the auto retry was my Tasker app trying to re-enable WiFi since I was at my home cell tower).

    Resolution: Go to Settings > Location > Scanning > disable "Wi-Fi scanning" (and I also disabled "Bluetooth scanning" for good measure). Tasker was then able to turn on my WiFi automatically and immediately stay connected to my home router.
    12-16-2016 10:38 PM

Similar Threads

  1. Download pending on Google Play Store how do I fix that
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-09-2017, 02:12 AM
  2. Black Friday deals on Moto Mods?
    By benjamminh in forum Moto Mods
    Replies: 7
    Last Post: 11-27-2016, 05:48 PM
  3. Replies: 3
    Last Post: 11-14-2016, 12:08 AM
  4. back on android S7
    By ep1 in forum Samsung Galaxy S7
    Replies: 6
    Last Post: 11-13-2016, 10:32 PM
  5. Replies: 1
    Last Post: 11-12-2016, 06:04 PM
LINK TO POST COPIED TO CLIPBOARD