1. Android Central Question's Avatar
    Hey guys, I'm pulling my hairs out on this problem I am getting with my note 4.

    This thing had a cracked screen - but worked great before that (no GPS problems) and I used it a good year before breaking it. So I bought a N910A (ATT) note 4 to use the screen to fix my trusty note.

    I gutted both phones, and put my N910T motherboard in the N910A's frame, with the screen still attached to the frame. I kept the N910A's USB daughterboard (with the charging port) because in the research I did, it seemed basically identical to the one from my broken screen frame, and I knew it would be tricky to get that out and into the new one without busting the new glass or destroying the flex cables.

    So after some trouble with the S pen not working initially (the cable didn't press in fully, had to stick paper behind the flex cable and it went in properly) I was able to get the phone up and running again, and all features seemed to work great again.

    However - I noticed after a couple days that the GPS was super spotty, so bad it was mostly unusable. I noticed that AGPS was on and it was using wifi and mobile data to help get a fix, so I turned it to GPS only mode. In GPS only mode the phone gets not signal whatsoever, no matter where I am.

    I tried the simple fixes many recommend online, one which is to try tightening the screws a bit, and in fact, as this process continued I opened and closed up the phone several times, making sure to carefully but tightly screw all the screws back into place. That didn't help. I also tried making sure the compass calibration was good - and it made no difference.

    I got to thinking, perhaps its a issue with the small bendable pins that press from the motherboard into the mid-frame not making good contact, so I tore the phone down a couple more times, slightly bent out - very carefully - all the pins that press into the mid-frame to make them all have a solid contact, and even tried to get any corrosion or debris from the pads on the mid-frame. I even made sure there was contact for those little ones alone the sides of the phone which seem to have something to do with the buttons rather than what I'm dealing with.

    Still no luck, so I tried doing a NV rebuild, which I read might solve getting 0 sat fixes, and discovered my phone wouldn't let me into that menu of the service options, so I had to install root and then do it through shortcut master instead. Once I finally was able to get to the menu and run the NV rebuild.... nothing changed.

    So I am fresh outta ideas, and I'm thinking that A) that ATT USB daughterboard actually plays a part in GPS somehow and I need to take my TMO one out of the old phone and put it in the new frame and screen.... or B) Something is damaged on my motherboard.... or C) Somebody out there has a better solution

    Any ideas, experiences of what worked are all appreciated!
    02-08-2018 09:54 AM
  2. MD_Reptile's Avatar
    BUMP --------

    Still having this issue. Tried opening it up, and realllllly making sure those antenna springs are making contact, and I made sure the contacts on the mid frame are clean.

    I tried TopNTP and that made no difference. Here is an image of whats going on when I run GPS Test:

    Note 4 GPS never gets fix - N910T Refurbished-79ff56a47d6c73dfe25c699dc66db450.png
    02-10-2018 02:20 PM
  3. natehoy's Avatar
    The NV rebuild is only available (at least on the AT&T version) when you pull the AT&T SIM. But root works, too.

    If you've done the NV rebuild then the only thing I can think of is a hardware problem.

    It doesn't seem logical that there would be significant hardware differences between the two major GSM models - having said that the AT&T one was the one that had more reported GPS problems than all the others so there could be something wonky going on there.
    02-13-2018 08:41 AM
  4. MD_Reptile's Avatar
    Well since the motherboard is a T mobile one, I would hope it wouldn't have any issues.

    Should I go so far as to try putting the T mobile daughterboard with the usb on it, into the ATT shell? Instead of the (apparently identical) ATT daughterboard?
    02-15-2018 11:28 PM

Similar Threads

  1. Lenovo k8 note dropping cellular network signal on both sim cards frequently
    By Android Central Question in forum Ask a Question
    Replies: 6
    Last Post: 02-09-2018, 03:33 PM
  2. LG V20 can't get my Pandora to play through Bluetooth in car
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2018, 11:41 AM
  3. Replies: 1
    Last Post: 02-08-2018, 11:36 AM
  4. Why is WhatsApp pending but never download
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-08-2018, 11:28 AM
  5. How to get Simple Calendar Widget to display days when no appointment
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-08-2018, 06:07 AM
LINK TO POST COPIED TO CLIPBOARD