1. AC Question's Avatar
    I recently moved from an iphone to Android and trying to get used to it. One thing I'm noticing is that it feels like I have to jump through flaming hoops to keep my privacy. Can someone help me understand how I can set up my phone to connect automatically to my home/work wifi but not connect to every unsecured wifi network available as I go about my day? I have everything set to off but it still connects to random networks.
    09-05-2015 10:00 AM
  2. Sergio Armenta's Avatar
    Go into settings>wifi>more (top right corner)> and make sure that all of the switches are off. And then go back to wifi>hit more again> and in smart network switch make sure that is off as well. And that should keep your phone from connecting to any wifi network that you haven't connected to.
    09-05-2015 10:13 AM
  3. ela829's Avatar
    Sergio - I do not have a Smart Switch setting in the location you mention - or anywhere for that matter (unless I just haven't found it yet). I'm with AT&T. I have everything in my wifi advanced setting turned off including and I can still see that the phone is scanning for networks even though i'm connected to my stable home wifi.
    09-05-2015 01:02 PM
  4. Sergio Armenta's Avatar
    Sergio - I do not have a Smart Switch setting in the location you mention - or anywhere for that matter (unless I just haven't found it yet). I'm with AT&T. I have everything in my wifi advanced setting turned off including and I can still see that the phone is scanning for networks even though i'm connected to my stable home wifi.


    Does your options show up like this?

    If not, you probably have an advance option perhaps and it might be under that. Or if not try searching for smart network switch within the settings up to see if you have that at all. It might just be a Sprint thing.

    Sent from my SM-G920P using Tapatalk
    09-05-2015 01:34 PM
  5. ela829's Avatar
    Did a search - not found on my AT&T phone
    I also found I have to turn wifi off in order to be able to use data - ridiculous. why in the world should i be required to turn my wifi on and off constantly? I might be going back to my iphone.
    09-05-2015 10:00 PM
  6. AllPhones's Avatar
    I have an ATT version and have the smart network switch feature available when I click the more button on the top right.

    Posted via the Android Central App
    09-06-2015 07:03 AM
  7. MDMcAtee's Avatar
    Did a search - not found on my AT&T phone
    I also found I have to turn wifi off in order to be able to use data - ridiculous. why in the world should i be required to turn my wifi on and off constantly? I might be going back to my iphone.
    Check your settings again. You do not have to turn off the WiFi to use data. Follow the instructions given above and it will work just fine.

    It can be frustrating for a iPhone user to get everything set up properly, but don't give up so easily. If you just don't like it, that's one thing, but help is here when you need it.

    Posted from my Galaxy Note 5
    09-06-2015 08:32 AM
  8. Note5User's Avatar
    Sergio - I do not have a Smart Switch setting in the location you mention - or anywhere for that matter (unless I just haven't found it yet). I'm with AT&T. I have everything in my wifi advanced setting turned off including and I can still see that the phone is scanning for networks even though i'm connected to my stable home wifi.
    To enable Smart Switch you have to turn on Mobile networks/4G and wifi both. Then only you will be able to see this option
    09-12-2015 12:30 PM
  9. spasell's Avatar
    I'm on Verizon. I'm attaching the setting I selected since I know for a fact that for Verizon users WiFi in combination with Cell drains battery much faster. So I don't want my WiFi on when my screen is off.

    However it's so frustrating because my WiFi still runs constantly despite this setting being selected. What in the hell is going on? Am I doing something wrong?

    Posted via the Android Central App
    Attached Thumbnails Why is my Note 5 wifi automatically connecting even though options are turned off?-466.jpg  
    09-12-2015 03:19 PM
  10. Sodiq Agbabiaka's Avatar
    My Galaxy note keeps connecting to a network I did not approve. The network does not show on the list of wifi network, hence i was unable to disconnect unless i switch my wifi off. its frustrating, how do i stay safe.
    10-20-2015 11:07 AM
  11. Sodiq Agbabiaka's Avatar
    I have checked all above suggestion but no help yet
    10-20-2015 11:11 AM
  12. T_M's Avatar
    Turn on smart network switching so it will switch to Data when WIFI is unstable.
    12-11-2015 10:55 AM
  13. Stephanie Beal's Avatar
    i have checked all above suggestion but no help yet
    i figured it out!!! I have a samsung galaxy note 5. Open the wifi that keeps trying to connect or connecting and press it down. A screen will come up that says forget this wifi!!! Hell yes! Click on that and poof it will be fixed!!!!
    05-27-2016 01:04 PM
  14. Munciegirl1974's Avatar
    I recently moved from an iphone to Android and trying to get used to it. One thing I'm noticing is that it feels like I have to jump through flaming hoops to keep my privacy. Can someone help me understand how I can set up my phone to connect automatically to my home/work wifi but not connect to every unsecured wifi network available as I go about my day? I have everything set to off but it still connects to random networks.
    I have a note 5 ....click settings. Click on WiFi setting. Click setting in upper right corner (3dots) click advanced. Under that menu make sure smart network switch is not checked.
    08-27-2016 04:01 AM

Similar Threads

  1. Why are there so many ads on everything from Google play?
    By Garyharders in forum Ask a Question
    Replies: 2
    Last Post: 09-08-2015, 09:17 AM
  2. Replies: 1
    Last Post: 09-08-2015, 08:17 AM
  3. My Galaxy Note 5 impressions
    By D13H4RD2L1V3 in forum Samsung Galaxy Note 5
    Replies: 19
    Last Post: 09-07-2015, 08:40 AM
  4. Replies: 0
    Last Post: 09-05-2015, 09:13 AM
  5. Note 4 - Sdcard Behavior
    By rllor in forum Ask a Question
    Replies: 0
    Last Post: 09-05-2015, 09:09 AM
LINK TO POST COPIED TO CLIPBOARD