1. Carnyewest's Avatar
    Some websites say "unable to load page" asking me to check my connection. They load on wifi, other websites load just fine on mobile data. For some reason, when I go to forum.darkspyro.com for example I get the error message. Anyone know how to fix this?
    I've done factory reset, wiped data, wiped cache, made sure app settings are on default and still the same thing. It also does this no matter which browser I use. Anyone have this issue and know how to fix it? I should've probably stayed with Verizon, what kind of crap is this?

    Posted via the Android Central App
    12-22-2015 02:19 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you spoken to AT&T about this?
    12-23-2015 12:48 AM
  3. athomas917's Avatar
    How good is your mobile signal strength? I get crappy reception in my house and have to use my wifi most of the time at home. When I'm in an area with a strong mobile signal, I can load pages no problem.

    Posted via the Android Central App
    12-24-2015 06:42 PM

Similar Threads

  1. Samsung Note 4 keeps freezing and restarting, how can I fix this?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 10
    Last Post: 08-17-2016, 09:25 PM
  2. Note 4 (SM-N910T) no Gallery App thumbnails, very confused
    By chrisingrassia in forum Samsung Galaxy Note 4
    Replies: 15
    Last Post: 12-23-2015, 07:27 PM
  3. Replies: 1
    Last Post: 12-23-2015, 01:16 AM
  4. Replies: 1
    Last Post: 12-23-2015, 12:58 AM
  5. Note 4 battery life won't last 6 hours, how can I fix this?
    By Abdulrauf tashkandi in forum Batteries
    Replies: 1
    Last Post: 12-22-2015, 09:45 AM
LINK TO POST COPIED TO CLIPBOARD