10-08-2017 08:47 AM
59 123
tools
  1. wendemi's Avatar
    I have been having problems with OK google and it seems to have started after updating to Marshmallow. 90% of the time, when I say "OK Google" I get a screen message saying "offline" and giving me sample offline commands I can use. Yet I have a very good connection whether Wi-Fi or Cellular data. Any ideas what can be causing this? I have retrained my voice as suggested somewhere but it didn't change anything.

    Edit: when I try Now on Tap, it says "Google now cannot be reached at the moment".

    Posted via the Android Central App
    03-14-2016 08:18 PM
  2. Trees's Avatar
    Sounds like Google Now may have been temporarily unavailable. I've had this happen a few times recently, and like you had good network connection.

    I just realized that Google Now on Tap was not turned on in Settings. Enabled it, so will use it for a while and see if that surfaces any problems.
    03-15-2016 06:54 AM
  3. CocoaBeachDan's Avatar
    I am having the same, or similar problem with my Galaxy S6. It started after the update to Android 6. VERY annoying. I turned off the "power saving mode" and now it seems to function properly, but now my battery will not last all day.
    Margerie Highfield likes this.
    04-13-2016 07:57 PM
  4. gozirra's Avatar
    Make sure location is on and date/time are correct. Don't just assume, actually check them against a known good source.
    04-13-2016 08:08 PM
  5. BB Markk's Avatar
    If wifi and bluetooth are both on... switch one off.
    04-16-2016 09:20 PM
  6. Magicfan33's Avatar
    I have been having problems with OK google and it seems to have started after updating to Marshmallow. 90% of the time, when I say "OK Google" I get a screen message saying "offline" and giving me sample offline commands I can use. Yet I have a very good connection whether Wi-Fi or Cellular data. Any ideas what can be causing this? I have retrained my voice as suggested somewhere but it didn't change anything.

    Edit: when I try Now on Tap, it says "Google now cannot be reached at the moment".

    Posted via the Android Central App
    Is your S voice disabled? I found that it caused my ok google to say offline all the time, when it was disabled.
    newswatcher likes this.
    04-19-2016 04:45 PM
  7. kirkjwalker's Avatar
    Did you ever resolve your problem? I have the same problem and none of the suggestions on the forum solved my problem
    05-15-2016 08:59 AM
  8. fahtas's Avatar
    I have the same problem. I have to ask ok google twice. First time says I'm offline whether I'm on wifi or mobile. the second time works. Very annoying.
    05-22-2016 01:15 PM
  9. ashley3689's Avatar
    Were you able to find a solution? I tried disabling S Voice, turning on/off Wifi/Bluetooth, and turning on the tap thing but it still isn't working for me.
    06-02-2016 07:09 PM
  10. Trees's Avatar
    Problem occurred again for me a few times this week. I didn't make any changes to phone settings, and had good mobile network signal. Could be that the Google Now service was having intermittent problems.
    06-03-2016 06:01 AM
  11. Rumpelstiltskin Peabody's Avatar
    This also happened to me... For over 9 weeks I couldn't use my " ok google" ...kept.. saying offline.. but I had 4G LTE .. and wifi.. to fix it.. I went into my phone "settings" .then went into the "applications" tab.. drop down to "google app" then .. you need to clear everything! Google cache.. google search history.. Browser history.. saved data.. Even your home screen data.. after clearing everything.. make sure you have all the settings correct.. Then boom it should work fine...
    06-06-2016 09:33 PM
  12. asommers815's Avatar
    This also happened to me... For over 9 weeks I couldn't use my " ok google" ...kept.. saying offline.. but I had 4G LTE .. and wifi.. to fix it.. I went into my phone "settings" .then went into the "applications" tab.. drop down to "google app" then .. you need to clear everything! Google cache.. google search history.. Browser history.. saved data.. Even your home screen data.. after clearing everything.. make sure you have all the settings correct.. Then boom it should work fine...

    Power Saving mode causes this. In Power Saving settings, you have to turn off "restrict background data".
    newswatcher likes this.
    06-18-2016 09:12 PM
  13. greenguyali's Avatar
    mine is a Galaxy s6. I check and the Restrict Background data option is disabled for Google App but I still have this issue. I noticed one behavior though. If i turn off the screen with the Power saver on, and then after like 5 to 6 seconds, i turn the screen back on and say Okay Google, it recognizes text but says Offline check your connection. But When I turn off the power save and repeat the same test again, it returns the results fine.

    I noticed one another behavior. If I am on Skype or Viber and I put the phone close to my ear for speaking, the data connection is lost and then eventually the call drops. So, for me it seems to be happening in the Power Saver mode and after the display goes off. Is there any setting anywhere on a Galaxy S6 Edge Plus that says turn off data when screen is off? Perhaps I need to check that one.
    06-21-2016 07:20 PM
  14. greenguyali's Avatar
    I think I found the solution,,, well, atleast to my scenario.

    1. Go to settings
    2. Tap Battery
    3. Tap Battery Usage
    4.Tap ''More'' on top right corner
    5. Select Optimize Battery Usage
    6.Select All Apps from the drop down menu
    7. Go to the app you are having issue with and then slide the button next to it to 'Off'

    Google Voice Search seems to be working fine now
    06-21-2016 07:35 PM
  15. giancahwu's Avatar
    I had the same problem. I ended up signing out from my google account and that worked! hope it helps you
    06-21-2016 09:46 PM
  16. Jneddy's Avatar
    This worked for me using a galaxy s6
    07-09-2016 11:59 AM
  17. jlost's Avatar
    I have been having problems with OK google and it seems to have started after updating to Marshmallow. 90% of the time, when I say "OK Google" I get a screen message saying "offline" and giving me sample offline commands I can use. Yet I have a very good connection whether Wi-Fi or Cellular data. Any ideas what can be causing this? I have retrained my voice as suggested somewhere but it didn't change anything.

    Edit: when I try Now on Tap, it says "Google now cannot be reached at the moment".

    Posted via the Android Central App
    My wife and i have the note 5. We both updated to marshmallow. I and find in this regard and she gets the same exact thing your get. Any help?
    07-10-2016 12:20 AM
  18. jlost's Avatar
    Problem occurred again for me a few times this week. I didn't make any changes to phone settings, and had good mobile network signal. Could be that the Google Now service was having intermittent problems.
    Nope as my wife can't do it, but i can and we have the same phone and update.
    07-10-2016 12:22 AM
  19. Lamby44POD's Avatar
    It worked! I have been fighting this problem for so long. The Chrome talk to text works, but if i used the Google widget, it always said I was offline. It was incredibly annoying.
    Clearing the cache works too, but only temporary.

    Hopefully this is a permanent fix!

    Thanks for the help!
    07-15-2016 09:50 AM
  20. Simone Rogers's Avatar
    I have been having problems with OK google and it seems to have started after updating to Marshmallow. 90% of the time, when I say "OK Google" I get a screen message saying "offline" and giving me sample offline commands I can use. Yet I have a very good connection whether Wi-Fi or Cellular data. Any ideas what can be causing this? I have retrained my voice as suggested somewhere but it didn't change anything.

    Edit: when I try Now on Tap, it says "Google now cannot be reached at the moment".

    Posted via the Android Central App

    When okay Google starts to listen I have to say okay Google again then ask my question or it tells me I am offline. Hope you got this resolved!
    07-15-2016 02:50 PM
  21. juxt417's Avatar
    Is your S voice disabled? I found that it caused my ok google to say offline all the time, when it was disabled.
    Thanks mate fixed everything right up on my s7 edge
    07-17-2016 02:29 PM
  22. staceylee's Avatar
    i been having issues for a week....i uninstalled and reinstalled....same thing over and over. So I signed out of goolge completely, then signed back in and TADAAAAAAAAAAA it is now working! so if you been having issues with this ok google saying you are offline, try that sign out and then back in...been working ever since!
    08-01-2016 08:52 PM
  23. pawesomegirl's Avatar
    All of the suggestions above did not work for my Motorola G4. What is S Voice?
    08-02-2016 06:50 PM
  24. pawesomegirl's Avatar
    I'm getting overwhelmed, how do you sign out of Google completely? Where is that, please?
    08-02-2016 06:53 PM
  25. Potentzero's Avatar
    I'm getting overwhelmed, how do you sign out of Google completely? Where is that, please?
    I was having the same problem on my s7edge for about two weeks now.

    Nothing here had helped. But going into the settings of the app itself, you can restore it to factory settings. This just helped me. Only used it to set an alarm and I'm still unsure if it will stick. I'll be back with updates. As of now, this seems to do the trick!
    08-04-2016 11:17 AM
59 123

Similar Threads

  1. Replies: 1
    Last Post: 03-14-2016, 07:25 PM
  2. Replies: 0
    Last Post: 03-14-2016, 06:31 PM
  3. Google Play won't open
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-14-2016, 05:20 PM
LINK TO POST COPIED TO CLIPBOARD