06-23-2017 06:29 PM
50 12
tools
  1. bassoprofundo's Avatar
    Just from favorites, but only activate couple.

    Btw I have s7.
    Tried that on my Note 5 again just to check, but it didn't have any effect. I did finally get a chance to contact Samsung today, and the rep said they have an updated version of the software dropping within a week that has a bunch of fixes included. She said to wait until the next version drops, install, retest, and then contact them back if it isn't resolved.
    05-05-2017 04:54 PM
  2. lepa71's Avatar
    Just fyi. I think I spoke too soon. It's back. I also posted review and created a thread in Samsung community forum. We all should do it to get Samsung's attention.
    05-05-2017 07:41 PM
  3. ytcyguy's Avatar
    I went to the Samsung Community and found a thread of this problem. It suggests clearing the Cache of the Calendar program. That worked for me!

    https://us.community.samsung.com/t5/...ht/true#M24290

    FYI - ytcyguy
    05-06-2017 06:10 PM
  4. ytcyguy's Avatar
    Nevermind - spoke too soon also! I worked once but not the next time.
    05-06-2017 06:51 PM
  5. bassoprofundo's Avatar
    Got an update from Samsung Pay 2.7.03 today to 2.7.05, which I'm assuming is the software update they referenced when I called last week, but it didn't fix the issue. Just verified again by going into Samsung Pay post-update, checking the box to add one of my cards to favorites, and the calendar notification and phone call issue reappears. Guess I'm going to have to call them again... ARGH
    05-11-2017 11:41 AM
  6. lepa71's Avatar
    We have a thread and working with Samsung person.
    https://us.community.samsung.com/t5/...hread-id/23936
    05-12-2017 03:49 PM
  7. bassoprofundo's Avatar
    We have a thread and working with Samsung person.
    https://us.community.samsung.com/t5/...hread-id/23936
    Thanks, I posted over there as well.
    lepa71 likes this.
    05-12-2017 04:50 PM
  8. RAWedges's Avatar
    My wife and I are having the same issue. I turned off the lock screen and screen off features under favorite cards and it appeared to fix the issue.
    05-21-2017 08:11 AM
  9. bassoprofundo's Avatar
    My wife and I are having the same issue. I turned off the lock screen and screen off features under favorite cards and it appeared to fix the issue.
    Interesting. I tried that before on both my phones, and it didn't seem to make any difference.
    05-21-2017 10:08 AM
  10. StatuSChecKa's Avatar
    Hi guys I'd like to post another potential fix. This worked for me. I use Samsung Pay, but I read that if you disable lock screen access for Samsung Pay the calendar event won't keep your screen on. I can live with unlocking my phone before I use Samsung Pay.

    Here the fix: open the SP app. Tap the three little dots to go into settings. Under 'Use Favorite Cards', uncheck lock screen.
    05-23-2017 06:57 PM
  11. bassoprofundo's Avatar
    Hi guys I'd like to post another potential fix. This worked for me. I use Samsung Pay, but I read that if you disable lock screen access for Samsung Pay the calendar event won't keep your screen on. I can live with unlocking my phone before I use Samsung Pay.

    Here the fix: open the SP app. Tap the three little dots to go into settings. Under 'Use Favorite Cards', uncheck lock screen.
    Same as RAWedges mentioned above... I'd tried this on both the Note5 and S7 edge originally, and it had no effect for me. Going to try again here ASAP to see if maybe that changed with the latest Samsung Pay update.
    05-23-2017 07:04 PM
  12. StatuSChecKa's Avatar
    I failed to throughly test it. I'm sorry.
    If the Samsung Pay is open in the background my method works.
    If I force close SP then lock my phone, my method does not work.
    Last Sunday night in church my pocket was Hella Hot. I didn't find out why untill I got to my car.
    05-23-2017 07:09 PM
  13. StatuSChecKa's Avatar
    The only consistent fix I have is by going into each card and removing it from favorites. And then removing favorites from sleep, home, and lock screen.

    While this is inconvenient; it works for me as I only use Samsung Pay once a week or so. And I can launch a card by launching the SP app.

    I believe Samsung will find a fix since this can be replicated on various basebands and models.
    05-23-2017 07:32 PM
  14. bassoprofundo's Avatar
    I failed to throughly test it. I'm sorry.
    If the Samsung Pay is open in the background my method works.
    If I force close SP then lock my phone, my method does not work.
    Last Sunday night in church my pocket was Hella Hot. I didn't find out why untill I got to my car.
    Haha. Np. So frustrating, isn't it?

    I did notice the same in that if you open the SP app and leave it backgrounded, the problem doesnt occur. Good point to call out and one that I don't think I have up to this point.
    StatuSChecKa likes this.
    05-23-2017 07:32 PM
  15. cmarquis88's Avatar
    Thanks everyone. Unchecking favorites in Samsung Pay fixed the issue. Interestingly it fixed a very similar issue with Verizon Visual Voicemail. I would play the message, the screen would go black, immediately turn back on and pause the voicemail playback. Unchecking the SP favorites allowed full playback of the voicemail. This is on the Galaxy S8.
    05-24-2017 08:37 AM
  16. bassoprofundo's Avatar
    Thanks everyone. Unchecking favorites in Samsung Pay fixed the issue. Interestingly it fixed a very similar issue with Verizon Visual Voicemail. I would play the message, the screen would go black, immediately turn back on and pause the voicemail playback. Unchecking the SP favorites allowed full playback of the voicemail. This is on the Galaxy S8.
    Wow. That's bizarre. This is obviously something more serious than a minor glitch in one app. We have the calendar notification issue, the keep alive during phone calls issue I mentioned, and now your issue with the voicemail app... all fixed by turning off the favorite cards feature in Samsung Pay. Not good...
    05-24-2017 09:01 AM
  17. RAWedges's Avatar
    Interesting. I tried that before on both my phones, and it didn't seem to make any difference.
    Yeah, it worked for a second. I've turned off favorite cards and its still happening.

    I'm disabling lock screen calendar notifications. Not the preferred solution.
    05-25-2017 10:54 AM
  18. StatuSChecKa's Avatar
    Hey guys just checking in. Unfortunately I still have Favorite Cards disabled, so paying with NFC requires way too many clicks. The Samsung forums are not providing a solution. The Moderator/Employee says the built in Calendar and Pay apps both need updating to fix the glitch, and because it's two different teams, there is no ETA.
    06-01-2017 11:47 AM
  19. srgonu's Avatar
    Has anyone tried changing the default calendar to Google or something else other than Samsung's? Does this problem still happen?
    06-04-2017 10:31 AM
  20. 11B1P's Avatar
    I use the Google calendar, favorite card in SP and calendar notifications remain on the screen. Dismissing the calendar notification from my Gear S3 also clears it from my GS7.
    06-04-2017 07:33 PM
  21. WoofboyX's Avatar
    The below mentioned update did not fix it for me BUT I finally figured out a work around to keep all the functionality but still stop the battery drain/always on.

    I went to the Android app store and downloaded GOOGLE CALENDAR app. Apparently the S7 calendar app is NOT the stock nougat calendar. I then turned of notification in the version of the calendar that comes with the S7. Default settings for the google calendar were fine, I didn't bother to configure everything and the notifies are still following the times set in the appointments in Exchange. You can override that in the google calendar if you want, or not if you are happy with that. Now when the notify occurs, it buzzes the phone (i usually leave my phone in vibrate, if audio was on it would chime), puts a tiny calendar icon in the always on display (I use my phone as a watch so I want to see the low-power always on), and keeps the notify led flashing until i swipe away the notify (or opening it by tapping it). It never turns on the screen. I assume if you turn off the always on display in nougat settings it just flashes the blue notify and buzzes without doing anything else.

    At that point, you can choose to still manage all your appointments through the existing calendar app, or you can use the google one you just installed. You don't have to change anything with accounts or sync. And it works with multiple calendars syncing as normal (mine syncs with ms exchange).

    The one difference is if you actually tap on the icon to open it, it will open in the google calendar. Still perfectly fine compared to a phone where the first meeting of the morning was knocking down my phone's battery and making it get hot in my pocket.


    Tried that on my Note 5 again just to check, but it didn't have any effect. I did finally get a chance to contact Samsung today, and the rep said they have an updated version of the software dropping within a week that has a bunch of fixes included. She said to wait until the next version drops, install, retest, and then contact them back if it isn't resolved.
    06-08-2017 08:52 AM
  22. bassoprofundo's Avatar
    The below mentioned update did not fix it for me BUT I finally figured out a work around to keep all the functionality but still stop the battery drain/always on.

    I went to the Android app store and downloaded GOOGLE CALENDAR app. Apparently the S7 calendar app is NOT the stock nougat calendar. I then turned of notification in the version of the calendar that comes with the S7. Default settings for the google calendar were fine, I didn't bother to configure everything and the notifies are still following the times set in the appointments in Exchange. You can override that in the google calendar if you want, or not if you are happy with that. Now when the notify occurs, it buzzes the phone (i usually leave my phone in vibrate, if audio was on it would chime), puts a tiny calendar icon in the always on display (I use my phone as a watch so I want to see the low-power always on), and keeps the notify led flashing until i swipe away the notify (or opening it by tapping it). It never turns on the screen. I assume if you turn off the always on display in nougat settings it just flashes the blue notify and buzzes without doing anything else.

    At that point, you can choose to still manage all your appointments through the existing calendar app, or you can use the google one you just installed. You don't have to change anything with accounts or sync. And it works with multiple calendars syncing as normal (mine syncs with ms exchange).

    The one difference is if you actually tap on the icon to open it, it will open in the google calendar. Still perfectly fine compared to a phone where the first meeting of the morning was knocking down my phone's battery and making it get hot in my pocket.
    I did have the exact same thing configured, and it does address the calendar notification issue. It's been a bit since I tested, but I'm 99.9% sure it did not fix the issue with the phone screen staying on during a call. Again, the common thread is the Samsung Pay favorite cards feature. In my case, I decided that if I was going to have to have that feature disabled in order to be able to take calls with the phone in my pocket, there was really no point in switching calendars, too.
    06-08-2017 09:34 AM
  23. mdicnman's Avatar
    Turning off the use favorite cards for Lock Screen and Screen Off resolved my pop up issue. The phone issue is not a Samsung Pay issue though. My wife has the same issue with her shiny new S7.
    06-19-2017 11:08 AM
  24. bassoprofundo's Avatar
    Turning off the use favorite cards for Lock Screen and Screen Off resolved my pop up issue. The phone issue is not a Samsung Pay issue though. My wife has the same issue with her shiny new S7.
    You mean the phone staying on during a call? That also went away for me when I either 1) Turned off the favorites in Samsung Pay or 2) backgrounded the dialer screen while in a call
    06-19-2017 11:13 AM
  25. bassoprofundo's Avatar
    Now I just got an update Samsung Pay up to version 2.7.11, and lo and behold, the calendar notification issue appears to be fixed!!! I just ran a test with a notification on all 3 devices I had with the issue (S8+, S7E, and Note 5), and after the notification fires in the default calendar and the screen is allowed to time out, it stays off. If you're having the issue, check Google Play for an update rolling out today, install it, and test again.
    06-23-2017 06:29 PM
50 12

Similar Threads

  1. Change Background in Conversation Screen
    By lax4545 in forum Samsung Galaxy S7
    Replies: 5
    Last Post: 05-03-2017, 11:47 PM
  2. Replies: 1
    Last Post: 04-26-2017, 11:22 AM
  3. Samsung Mega 6.3 stuck on startup, what do I do???
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-23-2017, 11:39 AM
  4. iOS gear s3 managing app
    By noah_lundberg in forum Samsung Gear S3
    Replies: 0
    Last Post: 04-23-2017, 08:42 AM
LINK TO POST COPIED TO CLIPBOARD