1. pantlesspenguin's Avatar
    I had the Note 4 and the GPS was awful. I'd constantly lose signal when in motion. I went through many warranty replacements, did several factory resets, and tried countless troubleshooting tips. How is GPS fairing for you all? I've switched to iPhone, and really want to come "home" to Android.
    08-19-2016 07:04 PM
  2. alejovh1#AC's Avatar
    I used it for an hour and a half taking the bus back home today and it was super accurate. I habe the T-Mobile version.
    pantlesspenguin likes this.
    08-19-2016 07:16 PM
  3. Almeuit's Avatar
    Fine so far on my T-Mobile Note 7. Used it to work and back.
    pantlesspenguin likes this.
    08-19-2016 09:20 PM
  4. Stealthieone's Avatar
    Also t-mobile version... Worked flawlessly. Had Lg G5 and it was always looking for gps... Crappy phone

    Posted via the Android Central App
    pantlesspenguin likes this.
    08-19-2016 09:23 PM
  5. pantlesspenguin's Avatar
    Please pardon the bump. Just wanted to see if anyone had more input on this. I bit the bullet amd ordered one today. I want to love it so much, and I'm hoping I didn't just make an expensive mistake!
    08-21-2016 06:34 PM
  6. ace-r1's Avatar
    I too have the tmo version and while using waze, it gets confused by thinking I'm using the off ramp on a highway.. This leads the app to re-routing me, only to realize 5 secs later that I didn't take the off ramp, thus readjusting itself. It quite frustrating honestly and come to think of it my note 5 didn't have this issue.
    pantlesspenguin likes this.
    08-21-2016 07:02 PM
  7. dsignori's Avatar
    Mine's been great
    pantlesspenguin likes this.
    08-21-2016 07:05 PM
  8. pantlesspenguin's Avatar
    Eep. I'm getting the tmo version too. My iPhone does this sometimes, but there is a lot of construction in my area and a lot of the exits are being redone.
    08-21-2016 07:07 PM
  9. rushmore's Avatar
    Connects much faster than Note 4.
    pantlesspenguin likes this.
    08-21-2016 09:23 PM
  10. DamianP's Avatar
    I'm having the same issue with Waze for the past 2 days. Just drove from NY to Mass and it kept thinking I was slightly off the highway and redirecting me at times when I am obviously on the highway. I am using high accuracy location. This is on ATT. It also seems to lag on destination distance at times too. Very odd. No issues on the S7E, S7 or OP3.
    Using Google maps/Nav, no issues. Seems to be specific to waze. No issues with my OP3 at in the same car with Waze.
    I deinstalled Waze for now and will try it another day.


    I too have the tmo version and while using waze, it gets confused by thinking I'm using the off ramp on a highway.. This leads the app to re-routing me, only to realize 5 secs later that I didn't take the off ramp, thus readjusting itself. It quite frustrating honestly and come to think of it my note 5 didn't have this issue.
    pantlesspenguin likes this.
    08-21-2016 09:28 PM

Similar Threads

  1. Best time to buy the Honor 8
    By lumivalo in forum Honor 8
    Replies: 46
    Last Post: 10-14-2016, 09:56 AM
  2. Chrome the Nexus 6P heater?
    By Markxmlx in forum Chrome
    Replies: 3
    Last Post: 09-11-2016, 06:07 PM
  3. What is the Factory Ringtone
    By cardboard60 in forum Samsung Galaxy Note 7
    Replies: 1
    Last Post: 08-19-2016, 10:09 PM
  4. Replies: 1
    Last Post: 08-19-2016, 07:36 PM
  5. How to unlock Nexus 6P if not booting ?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-19-2016, 06:42 PM
LINK TO POST COPIED TO CLIPBOARD