1. shaw1234's Avatar
    Switched from Verizon to at&t and bought two note 7's. Turns out cell service is weak in my house. Supposedly WiFi calling handles texts as well so should be no big deal right? Not really...
    I activated WiFi calling on both phones. Both have strong signal to router (5ghz N, Asus rt-n66). 90Mbps down 6 up. Web browsing, email, speed test, etc all fine. No drops, no lag, perfect.
    But the WiFi calling logo comes and goes every few minutes intermittently. When it's on (and wife's is on) sending MMS goes fine though built in message app (with advanced messaging enabled). But when it goes back to the regular WiFi symbol (no little plus indicating WiFi calling enabled) mms won't work, texts work only 75% of the time, basically garbage and unacceptable. I would jump back to Verizon but at&t works better at my work where there is no WiFi option, so ideally getting WiFi calling to work right at home and staying with at&t is ideal.
    Any ideas/suggestions as to why it's intermittent or what I can do to fix it?
    08-21-2016 07:47 PM
  2. shaw1234's Avatar
    I should add that both note 7's are doing the same thing...
    08-21-2016 08:50 PM
  3. biswasd's Avatar
    I'm seeing the EXACT same symptoms with wifi calling on AT&T as you described. Wifi calling "+" sign keeps coming and going.....calls not going thru on wifi calling to other at&t recipients as well as non at&t recepients. i called tech support and they dont have any info on the issue - surprise surprise.

    I hate to compare, but our iphone 6plus's in our family have no problems with wifi calling....thing is i hate iphones....not sure what to do.

    i'm sure some will post that we should wait for a software update, but i'm not sure that this is software issue - i've also noticed less than strong reception on 5gh band on my netgear nighthawk router.

    any advice anyone?
    08-21-2016 09:07 PM
  4. Lobwedgephil's Avatar
    I have similar experience with At&t wifi calling. It works 95% of the time or more on my iPhone, so I knows its not my wifi. It only works maybe 20% of the time on my Note 7.
    08-21-2016 09:25 PM
  5. shaw1234's Avatar
    I might just go back to Verizon then. WiFi calling is what makes At&t useable at my house. If it's not going to be solid I can't accept the level of signal.

    Have you noticed if your time when it doesn't work correlates to weaker WiFi signal? Time of day? Anything?

    I've been sitting 10 feet from my router and it's been on for a solid hour (watching tv, not staring at the WiFi icon lol). But I knew earlier in the same room it wasn't working. Strange.
    08-21-2016 09:32 PM
  6. boufa's Avatar
    To narrow possibilites down, put both phones into airplane mode. Turn on WiFi. Let it connect to your network. See how stable it is then. If its unstable, then its your WiFi thats causing the problem. If not, then I suspect its the way that the phone is handling the low signal. In a perfect world, any time you have "less than 2 bars" or more accurately low signal at some set level, the phone should roll over to WiFi automatically. Then roll back when signal changes. This should be seamless.

    I noticed something else today that might apply. My grocery store is a known dead spot for coverage. It just is, not sure why, but it always has been. I was playing with my new phone, and I noticed I had 4 bars, but no 4g LTE logo next to it. That is odd. So my guess is that I was hitting a semi-compatible network (when I tried to dial it said emergency calls only). I would be curious if something like that (a strong worthless signal) would throw off the hand over to WiFi calling.

    Just some thoughts. Good luck to you.
    08-21-2016 09:35 PM
  7. neo Jeets's Avatar
    I've been having the same issue with my Note 7 on AT&T as well. Before upgrading to the Note 7, I've always been on AT&T and have been using an iPhone 6. Cellular service is pretty bad in my area so I had Wifi calling on all the time which drastically improved my ability to receive and make phone calls. On the iPhone 6, Wifi calling was always enabled and active automatically whenever I'm home. My home wifi is also rock solid with a 180 Mbps down/12 Mbps upload. Calls were nice and clear with few dropped calls.

    With the Note 7, I've noticed the same intermittent loss of Wifi Calling since I enabled it. I've called into AT&T customer support but couldn't resolve the problem at all. My only guess as to why Wifi calling drops in and out is because it only comes becomes active when the cellular service drops very low. The Note 7's threshold level for cell service strength when Wifi calling kicks in is set too low and therefore it is active less often. Not really sure though.

    For me, turning airplane mode on then off (while Wifi calling is set to On) sometimes turns wifi calling on temporarily.

    I hope this issue is discussed more so it might be addressed soon.
    08-21-2016 09:39 PM
  8. shaw1234's Avatar
    Thanks for the suggestions. Will try it out tomorrow after work. I wish there was a setting to always use WiFi calling when connected to your home WiFi. The whole low cell signal transition to WiFi makes sense though...perhaps software update would clear it up. But, I've got 12 more days to cancel my service and go back to Verizon and I doubt we'll see an update that addresses the issue by then.

    Not sure I want to play Russian roulette with my service waiting for a fix.
    neo Jeets likes this.
    08-21-2016 09:45 PM
  9. double923's Avatar
    ATT WiFi calling is working great for me. I had multiple calls and the clarity was excellent. I think it might be a bit better than my 6s plus on WiFi calling. I have not seen it switching on and off. And again I am talking on the phone I didn't pay attention to the icon. I will have to try that next on the call.
    08-21-2016 09:52 PM
  10. KupKrazy's Avatar
    I don't have my Note 7 yet, but AT&T added WiFi calling just a few weeks ago and frankly I think they've implemented it poorly. Like someone said above, the WiFi calling (and texting, etc.) will only come on if your cellular service is just about non-existent. Contrast to the way T-Mobile handles it - and that is it is on whenever you are connected to a WiFi network. AT&T's approach is to use it only as a backup to when you have no cellular signal and I think that's not a great approach because the signal strength is often not an accurate indicator of your service. Regardless, though - I'm not sure why they don't just let WiFi calling stay on. AT&T charges you the same either way, regardless of whether you're on WiFi or cell network. Anyway, that is my experience with it so far. It's head scratching the way they implemented this...
    08-21-2016 10:11 PM
  11. shaw1234's Avatar
    Ok so I woke up this morning, no WiFi calling symbol. Tried airplane mode, WiFi back on and boom, WiFi calling active. Sent texts, made a call, working fine. Been stable for half hour so far.
    It think this might be a workaround for now.
    08-22-2016 05:16 AM
  12. duke1231's Avatar
    I had the same problem. I got home from a cider festival yesterday, did an AT&T software update and now it works awesome
    08-22-2016 05:49 AM
  13. shaw1234's Avatar
    3 hours later and every time I looked at the icon it has wifi calling enabled. Still working perfectly. I think the low signal handoff is the culprit. Keeping it on airplane mode with wifi and bluetooth turned on has made it work fine.

    Now, I want to automate this so I don't have to change the settings everytime I get home or leave. Recommendations for an app to do this? I'd prefer not to use NFC tags. I'd like to just come home, it detects my wifi, turns on airplane mode, turns wifi and bluetooth back on. Also, when it loses my home wifi, I'd like to automatically turn airplane mode off.
    Cowboy8467 likes this.
    08-22-2016 08:17 AM
  14. Cowboy8467's Avatar
    3 hours later and every time I looked at the icon it has wifi calling enabled. Still working perfectly. I think the low signal handoff is the culprit. Keeping it on airplane mode with wifi and bluetooth turned on has made it work fine.

    Now, I want to automate this so I don't have to change the settings everytime I get home or leave. Recommendations for an app to do this? I'd prefer not to use NFC tags. I'd like to just come home, it detects my wifi, turns on airplane mode, turns wifi and bluetooth back on. Also, when it loses my home wifi, I'd like to automatically turn airplane mode off.
    I asked the exact same question you did on reddit, I haven't found a work around yet. To be clear though, turning on airplane mode and then turning wifi and bluetooth back on works flawlessly for me, both text messages and phone calls are fast and crystal clear. This works well as long as I'm at home but it's a pain to have to remember to turn airplane mode off when I leave the house.

    I would love it if there was some way to automate it.
    08-22-2016 09:25 AM
  15. shaw1234's Avatar
    The digging I did on Google ended up a dead end. From what I gather, switching Airplane mode on/off is a system function, and therefor apps can't do it without root access. So, it looks like there is no way to automate it without getting root on this phone. I'm going to call AT&T and let them know what the issue is, and ask that they consider adding a setting that forces WiFi calling to stay active. I have little faith the rep will do anything with my suggestion, but it can't hurt, right?
    08-22-2016 09:37 AM
  16. Cowboy8467's Avatar
    Can't hurt. I know that with T-mobile they have it set up so that Wi-Fi calling is preferred if you're in an area with a strong wifi signal, regardless of what your cell connection is like. ATT only swaps when it deems your cell connection is too low, and as others have mentioned, the threshold is way too low.
    08-22-2016 09:42 AM
  17. Kaylee Lockheart's Avatar
    To start we don't really have service, in a practical sense, at our house...our internet also sucks, but whatever.


    My only guess as to why Wifi calling drops in and out is because it only comes becomes active when the cellular service drops very low. The Note 7's threshold level for cell service strength when Wifi calling kicks in is set too low and therefore it is active less often. Not really sure though.
    I think you're onto something here. Very occasionally are you standing in just the right spot that day on the property to have something strong enough to send something out...phone call is totally not happening, but the phone tries to trick you sometimes.


    For me, turning airplane mode on then off (while Wifi calling is set to On) sometimes turns wifi calling on temporarily.
    I put mine into airplane mode, and have thus far just left it there, and as soon as the wifi was turned back on wifi calling became enabled and has held fast even when I turn on a game.

    Then turning airplane mode off it held the wifi calling for a time and I got a few texts out it eventually dropped. As you suggested the phone seems to be temporarily possessing cell service, but maybe not 4G, and thus the wifi calling cuts out.

    Putting it back into airplane mode, as it did the first time, once the wifi is turned back on wifi calling comes straight on, and functions perfectly well. I suppose if you're using wifi calling in the first place you don't have reliable cell service at that location, so what the heck does it matter to be in airplane mode?
    04-20-2017 09:32 PM

Similar Threads

  1. How Do I Hide Sharing My WiFi Connection w/my PC?
    By ricoramiro in forum Ask a Question
    Replies: 4
    Last Post: 08-24-2016, 09:18 AM
  2. Why is wifi using almost 50% of my battery?
    By acles003 in forum Samsung Galaxy Note 5
    Replies: 3
    Last Post: 08-22-2016, 07:01 PM
  3. Turning emergency calls off
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-21-2016, 06:40 PM
  4. Why don't I have a Call Forwarding option on my Galaxy S7
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-21-2016, 06:37 PM
  5. My phone doesn't allow me to answer incoming calls
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-21-2016, 06:15 PM
LINK TO POST COPIED TO CLIPBOARD