1. Daniel Mott's Avatar
    This is the first phone I have owned on Verizon that could do the wifi calling and I don't think it's working right. I had a Nexus 6p on Fi and it would connect through the cellular network first then go to wifi if there wasn't one. This phone will do wifi first and won't use the cellular connection if there is one. Verizon's website says

    In order to provide you with the most reliable experience, calls will use the cellular network when available.

    I have talked to a couple of reps and they say my phone is doing what it is supposed to using wifi first. I then had a rep tell me it's an antenna issue and exchange the phone. I also get the message must turn off airplane mode to make calls when i only have wifi signal. At my work I have no cell signal but I have wifi so I put it on airplane mode to save battery. I was able to fix this issue with a factory reset but it doesn't feel like I should have to do one on a new phone so quickly. I don't want to go through the hassle of an exchange if the wifi calling is working as intended on this phone. Please help me.

    (Another Verizon rep told me iPhones won't do this because of their lithium core, that is why I came to here I don't think they know what they are talking about.)
    08-26-2016 06:12 PM
  2. Clocks's Avatar
    /edit I misunderstood at first

    I just did a test on my Verizon note 7. I turned on airplane mode, then turned on wifi, and then successfully placed a call using wifi calling.

    I also had my wife call me with airplane mode on while connected to wifi, it worked as well.

    Pretty cool, didn't know it would do that.

    08-26-2016 07:17 PM
  3. pcsperson's Avatar
    /edit I misunderstood at first

    I just did a test on my Verizon note 7. I turned on airplane mode, then turned on wifi, and then successfully placed a call using wifi calling.

    I also had my wife call me with airplane mode on while connected to wifi, it worked as well.

    Pretty cool, didn't know it would do that.
    This is a recent change, while this works on my note 7,when I first received by S7 Edge but something changed to allow it woke which has been great! It is nice feature to have on our phones, I think the Note 7 does much better with a with switching to wifi, than my S7 Edge did. Both phones are on Verizon as well.
    08-26-2016 07:28 PM
  4. Daniel Mott's Avatar
    The main problem I am having with it is that I have a decent cell signal at home but it still calls over my wifi because it's stronger. This wouldn't be a problem except when I was grilling last night people could hear me only when I stood in my garage but not by my grill which is right outside of the garage. The calls kept going over wifi when I had this problem. I turned off wifi and no calling issues. I don't want to have to turn off wifi calling depending on my surroundings, I would rather turn it on and forget about it.
    08-26-2016 10:38 PM

Similar Threads

  1. How to get incoming calls to vibrate phone more than once?
    By ManofmanyStangs in forum Samsung Galaxy Note 7
    Replies: 8
    Last Post: 09-26-2016, 02:20 PM
  2. Galaxy Tab S 10.5 Wifi/Bluetooth Stopped Working - HAYELP!
    By WeeMikeSilver in forum Samsung Galaxy Tab S 10.5
    Replies: 3
    Last Post: 09-04-2016, 11:45 AM
  3. Replies: 2
    Last Post: 08-26-2016, 05:29 PM
  4. Replies: 1
    Last Post: 08-26-2016, 04:27 PM
  5. contact name not displaying when receiving a call only number
    By perithimus in forum Samsung Galaxy Note 7
    Replies: 0
    Last Post: 08-26-2016, 03:14 PM
LINK TO POST COPIED TO CLIPBOARD