1. Grigori316's Avatar
    I have a Note 8, and I bought a 64gb SD card for it, however every time I try to write anything to it I get an error message then the Note 8 stops reading the card all together until I remove the card and re-insert it.
    Now, I've tried three different makes of SD card (Samsung, ScanDisk & Kennsington) and I've had the same problem each time. I've tried formatting the card both while in the Note and while plugged directly in to my PC.

    After trying three different cards I thought I may have bought a faulty tablet so I send it back and got a replacement, well... I am now on to my second replacement.

    I don't seem to have this problem with any of my 32gb SD cards only the 64gb. On the Samsung website, including the all the reviews and even on the box it came in it clearly states that it can take 'up to 64gb' expanded memory. I have even asked Samsung directly if there is a known fault with the Note 8 reading and writing to a 64gb micro SD card and they have said 'No'.
    So here I am asking the community if there is any one else out there who has had the same or similar problem with their Note 8?
    03-25-2014 05:27 AM
  2. Joshua Lye's Avatar
    My note 8.0 with SanDisk SDXD 64gb, is working well that it able to write, but i face the same problem with my S4 (will appear as blank disk)

    but if your Note 8.0 or S4 is Kitkat 4.4, you will not able to write on SD card not matter what size, due to Google remove the write permission on 3rd party app
    03-27-2014 11:53 PM

Similar Threads

  1. FLOPPY TUBE...an alternative way to play at Flappy Bird
    By felixiuc91 in forum Android Apps
    Replies: 1
    Last Post: 07-03-2014, 11:45 PM
  2. HELP! HTC One not recognized when in fastboot mode
    By Jude Okun in forum HTC One M7
    Replies: 2
    Last Post: 06-26-2014, 05:09 PM
  3. Replies: 5
    Last Post: 04-07-2014, 02:54 PM
  4. I need help. How to fix this?
    By tehkie04 in forum HTC One S
    Replies: 1
    Last Post: 03-25-2014, 03:59 AM
  5. Samsung G4 - Samsung Account back up not working
    By judgecartman in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 03-25-2014, 03:17 AM