1. jgtw's Avatar
    I recently bought a Kingston SDXC 64GB class 10 card to replace the 32GB which I have installed and which works flawlessly. I formatted the card in the tablet and it showed something 59GB available (which seems ok).
    Then I tried to copy files from my PC to it via USB. That worked for a few files then it stopped. Tired it again and again, reformatted, but always the same result.
    For me it was clearly a problem of the card (as the 32GB card worked all the time). I contacted Kingston, they were kind and quick to respond and will replace the card once the have received the old one.

    So far so good. However, in the meanwhile I came across quite a few reports of Samsung devices which should according to spec be able to work with 64GB cards causing problems of different kinds.

    I contacted Samsung, they advised me to reset the tablet to factory settings (which seems to be their standard advice for all sorts of things). I have not done that yet.

    Has anyone come across a real solution or explanation for this problem?
    Is it likely that a reset will cure it?
    Should I format the new card when I get it?
    If yes should I format it in the tablet, or via the PC, and in that to which format?

    Thanks in advance!
    06-12-2014 10:17 AM

Similar Threads

  1. Note 3 - Pausing media when using hardware volume button.
    By AkterSnurra in forum Samsung Galaxy Note 3
    Replies: 5
    Last Post: 05-07-2016, 02:14 AM
  2. What is safe to disable on the Note 3??
    By deanodrums in forum Samsung Galaxy Note 3
    Replies: 11
    Last Post: 06-17-2014, 11:30 AM
  3. Replies: 2
    Last Post: 06-13-2014, 12:23 AM
  4. Not reading SD cards
    By Megan K in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 06-12-2014, 09:24 AM
  5. Few questions about the galaxy gear neo
    By Borgador17 in forum AT&T Galaxy Note 2
    Replies: 0
    Last Post: 06-12-2014, 08:17 AM