1. everway9's Avatar
    Ello again everyone.

    I'm getting so frustrated because I just cannot get 'OK Google' working on my Note 8. It was working on my previous Note 8 but I had to have it replaced.

    When I go to turn on 'OK Google detection' the options are greyed out and it says... 'To turn this on go to settings> language & input> voice input and select enhanced google services. Howevef when I get there, enhanced google services is missing.

    The Google app is up to date and Google assistant is selected as my default assistant app.

    I've been going round and round in circles and am getting very frustrated.

    Please will you help me?

    Thank you.
    K Alnory and androGx like this.
    10-01-2017 08:14 PM
  2. Javier P's Avatar
    Mod note. I moved your thread to the Note 8 forum where it'll be easier getting help from other owners.
    10-01-2017 08:20 PM
  3. everway9's Avatar
    Mod note. I moved your thread to the Note 8 forum where it'll be easier getting help from other owners.
    Sorry... I keep on posting in the wrong places. Thanks for moving it.
    Deanig_12 likes this.
    10-01-2017 08:24 PM
  4. kitmo's Avatar
    I just asked my Google Assistant what to do lol. Hold Home. Touch Next.Touch Get Started. To teach Google Assistant to recognize your voice and complete the set up, say "ok Google" three times. Maybe this is not what you are asking for? Hope it is.
    10-01-2017 09:53 PM
  5. broderwd's Avatar
    Ello again everyone.

    I'm getting so frustrated because I just cannot get 'OK Google' working on my Note 8. It was working on my previous Note 8 but I had to have it replaced.

    When I go to turn on 'OK Google detection' the options are greyed out and it says... 'To turn this on go to settings> language & input> voice input and select enhanced google services. Howevef when I get there, enhanced google services is missing.

    The Google app is up to date and Google assistant is selected as my default assistant app.

    I've been going round and round in circles and am getting very frustrated.

    Please will you help me?

    Thank you.

    Not sure if this is what you did by triying to turn on "ok google dictation," but...

    Open google app, top left bars, settings, settings again, then phone under devices, theres an option to turn on Google Assistant.

    If that is what you did, then sorry for wasting your time lol.

    Just to let you know, with mine on, i do not see the Enhanced Google Services that you speak of.
    10-01-2017 10:10 PM
  6. TechnologyTwitt's Avatar
    Ello again everyone.

    I'm getting so frustrated because I just cannot get 'OK Google' working on my Note 8. It was working on my previous Note 8 but I had to have it replaced.

    When I go to turn on 'OK Google detection' the options are greyed out and it says... 'To turn this on go to settings> language & input> voice input and select enhanced google services. Howevef when I get there, enhanced google services is missing.

    The Google app is up to date and Google assistant is selected as my default assistant app.

    I've been going round and round in circles and am getting very frustrated.

    Please will you help me?

    Thank you.
    After almost 10 days of trying to figure it out & going back/forth with Samsung Support on Twitter, I found out my problem was, OK Google will not work in Battery saving/Power saving mode.

    It's been working perfectly as long as Note 8 is not in any kind of power saving mode.
    pkguy323 likes this.
    10-02-2017 05:53 AM
  7. everway9's Avatar
    I just asked my Google Assistant what to do lol. Hold Home. Touch Next.Touch Get Started. To teach Google Assistant to recognize your voice and complete the set up, say "ok Google" three times. Maybe this is not what you are asking for? Hope it is.
    Thanks for your reply. Yeah... the thing is... all my google settings on my old note 8 were saved/synced with the cloud so when I first logged in to google on my new note 8 everything was synced again. Because of that... when I holded the home button for the first time the initial 'get started' bit never happened. Instead the usual assistant opened with 'hi, how can I help'. However, when i talked it didn't register it, even when I pressed the microphone. That was when I went to try and setup 'ok google' only to realise the settings were all greyed out, and it said the thing about turning on enhanced google services. Which is where I'm now stuck.

    Thanks for trying to help though.
    kitmo likes this.
    10-02-2017 05:44 PM
  8. everway9's Avatar
    Not sure if this is what you did by triying to turn on "ok google dictation," but...

    Open google app, top left bars, settings, settings again, then phone under devices, theres an option to turn on Google Assistant.

    If that is what you did, then sorry for wasting your time lol.

    Just to let you know, with mine on, i do not see the Enhanced Google Services that you speak of.
    Thanks but google assistant is already turned on.
    10-02-2017 05:45 PM
  9. everway9's Avatar
    After almost 10 days of trying to figure it out & going back/forth with Samsung Support on Twitter, I found out my problem was, OK Google will not work in Battery saving/Power saving mode.

    It's been working perfectly as long as Note 8 is not in any kind of power saving mode.
    Good idea thanks... but the phones not/wasn't in any power saving mode. And the app is not set to sleep.
    pkguy323 likes this.
    10-02-2017 05:46 PM
  10. everway9's Avatar
    The problem is... the enhanced google services setting is not where it should be. Google assistant is set as the default assistant yet all ok google voice/detection settings are greyed out.

    I'm totally confused.

    Does anyone know how to reinstall or reset googke assistant? Maybe thats going to be the only way.

    Thank you all for your time.
    10-02-2017 05:50 PM
  11. srvctec's Avatar
    Have you tried wiping the cache partition?

    Back up data on the internal memory.

    Turn off the device.

    Press and hold the Volume Up key and the Bixby key, then press and hold the Power key.

    When the green Android logo displays, release all keys ('Installing system update' will show for about 30 - 60 seconds before showing the Android system recovery menu options).

    Press the Volume down key several times to highlight 'wipe cache partition'.

    Press Power button to select.

    Press the Volume down key until 'yes' is highlighted and press the Power button.

    When the wipe cache partition is complete, “Reboot system now” is highlighted.

    Press the Power key to restart the device.

    I do this whenever I have weird stuff happening on my Android devices and sometimes it clears up the issue. I've never lost any data doing this procedure. Just make sure you don't accidentally select factory reset, or you'll have to start from scratch setting up your phone again (although, it still might be required to fix your issue).
    10-02-2017 06:02 PM
  12. everway9's Avatar
    Have you tried wiping the cache partition?

    Back up data on the internal memory.

    Turn off the device.

    Press and hold the Volume Up key and the Bixby key, then press and hold the Power key.

    When the green Android logo displays, release all keys ('Installing system update' will show for about 30 - 60 seconds before showing the Android system recovery menu options).

    Press the Volume down key several times to highlight 'wipe cache partition'.

    Press Power button to select.

    Press the Volume down key until 'yes' is highlighted and press the Power button.

    When the wipe cache partition is complete, “Reboot system now” is highlighted.

    Press the Power key to restart the device.

    I do this whenever I have weird stuff happening on my Android devices and sometimes it clears up the issue. I've never lost any data doing this procedure. Just make sure you don't accidentally select factory reset, or you'll have to start from scratch setting up your phone again (although, it still might be required to fix your issue).
    Thank you for your suggestion. I didn't know about that procedure.

    If all else fails I'll do just that. But for now I'm going to wait a little longer to see if anyone else who may have had the same problem comes along to post.

    Thanks again.
    srvctec likes this.
    10-02-2017 06:30 PM
  13. Michelle Strickland's Avatar
    I had the same issue of the option greyed out. I FINALLY solved it by clicking the Bixby button to open Bixby, click on the 3 dots on upper right. Go to settings. Under voice uncheck Bixby voice. Now the ok google detection is no longer greyed out! I hope that helps others!
    everway9 likes this.
    10-20-2017 09:46 PM
  14. everway9's Avatar
    Hi Michelle.

    Unfortunately thats not the problem, not for me anyway. Onevof the first things I did when I got the phone was to disable all things Bixby.

    But thanks very much for posting your suggestion. It's appreciated.
    10-20-2017 09:56 PM
  15. Fr0gburp3r's Avatar
    Do you have Google set as the device assistance app?
    10-21-2017 06:16 AM
  16. everway9's Avatar
    Do you have Google set as the device assistance app?
    I do.

    BTW... I love your profile name Fr0gburp3r.
    10-21-2017 07:16 AM
  17. everway9's Avatar
    Update.

    It's very strange this... I've been trying out various different sat nav apps this week. Today I thought I'd have another play around with the settings for 'ok google'. To my amazement the 'ok google detection' was no longer greyed out. Now ok google works. It must have been when I was playing around with the voice settings in one of those sat nav apps that it triggered a setting which is used by google assistant. That's all I can think of anyway because I haven't changed any settings on the phone... just installed some sat nav apps.

    When i got my replacement phone I didn't go through the normal setup procedure. I just restored everything from samsung cloud. So maybe something going wrong with that process might have been the cause of voice not working.

    Just guessing... really I have no idea why it just started working. But it is now and thats the important thing.

    I wish i knew as it might have helped others with the same problem.

    Thanks again everyone for posting. It's really appreciated.
    10-24-2017 04:54 PM
  18. dakeith15's Avatar
    Just gonna give an update that I had the same issue one the Galaxy S9+. I disabled Bixby and Google Enhance Services was set as the default assistant automatically, but the "okay google" options were grayed out. I fixed it by going into Settings>Advanced Features>Device Assistant App and changing the device assistance app to "none" and then changing it back to "Google Enhanced Services". Then it came up with the voice training for the google assistant. I guess it doesn't set properly when you disable the Bixby assistant.

    I know this thread is for the Note 8, but it is one of the top results when I'm searching for this issue on the S9+. I hope this helps anyone else with this problem.
    everway9 and sknole like this.
    03-15-2018 09:46 AM
  19. everway9's Avatar
    Just gonna give an update that I had the same issue one the Galaxy S9+. I disabled Bixby and Google Enhance Services was set as the default assistant automatically, but the "okay google" options were grayed out. I fixed it by going into Settings>Advanced Features>Device Assistant App and changing the device assistance app to "none" and then changing it back to "Google Enhanced Services". Then it came up with the voice training for the google assistant. I guess it doesn't set properly when you disable the Bixby assistant.

    I know this thread is for the Note 8, but it is one of the top results when I'm searching for this issue on the S9+. I hope this helps anyone else with this problem.
    Thanks.
    03-15-2018 10:06 AM
  20. kirksucks's Avatar
    will not work in Battery saving/Power saving mode.
    This seems to end up being the answer to a lot of " X is not working" questions. I turn on Battery saver because I'm somewhere without a charger ... and then later I forget that it was turned on. Try to do stuff and it wont work... get frustrated.
    03-15-2018 12:45 PM
  21. sknole's Avatar
    Just gonna give an update that I had the same issue one the Galaxy S9+. I disabled Bixby and Google Enhance Services was set as the default assistant automatically, but the "okay google" options were grayed out. I fixed it by going into Settings>Advanced Features>Device Assistant App and changing the device assistance app to "none" and then changing it back to "Google Enhanced Services". Then it came up with the voice training for the google assistant. I guess it doesn't set properly when you disable the Bixby assistant.

    I know this thread is for the Note 8, but it is one of the top results when I'm searching for this issue on the S9+. I hope this helps anyone else with this problem.
    Thanks. This solution worked perfectly on my S9.

    SN: my phone is always in ‘mid’ power saving mode, so battery saving mode isn’t the issue.
    03-20-2018 01:53 PM
  22. BobbySingh1's Avatar
    I was having the same problem. It is very simple. Uninstall the Google app from the app store. Reinstall it and it will automatically start prompting you to register your voice after you click on settings, voice and choose to turn ok Google on. Then you are all set. Don't worry about Google enhanced voice service, it doesn't exist on the note 8 anywhere in any settings menu
    pixielee22 likes this.
    03-30-2018 02:56 PM
  23. androGx's Avatar
    Here is the solution:
    Go to settings > Advanced features > Device assistance app > Device assistance app "Change it from None to enhanced Google services"

    You will see that the option to turn OK Google on is available now, so basically you need to turn on the option that holding the home button opens google assistant for ok google voice to work.

    I had the same issue too although ok google voice recognition is horrible on my S8. Hope that helps
    everway9 likes this.
    05-05-2018 03:18 PM

Similar Threads

  1. Replies: 20
    Last Post: 10-05-2017, 10:56 AM
  2. Google app wont show "recents" button on the bottom of the screen?
    By Scott5798 in forum Samsung Galaxy J Series
    Replies: 1
    Last Post: 10-02-2017, 12:39 AM
  3. Can I manually input steps on S Health?
    By Kelly Gardner1 in forum General Help and How To
    Replies: 1
    Last Post: 10-01-2017, 07:30 PM
  4. Why can I not send mms & pictures with non stock messaging apps?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-01-2017, 05:38 PM
LINK TO POST COPIED TO CLIPBOARD