1. nizmoz's Avatar
    This just started happening this week where my Gmail isnt letting me know of new emails. When I open it, it then checks and I miss a whole day of emails. I have sync turned on. Any idea what to do to fix this?
    10-02-2017 08:59 PM
  2. srvctec's Avatar
    Maybe try a force stop of the Gmail app and/or clear the cache of the app.
    10-02-2017 09:01 PM
  3. kitmo's Avatar
    I think just leave things alone. I have found that I have had that happen and it seems to right it self in a day or so. Gremlins.
    10-02-2017 11:23 PM
  4. anon(5719825)'s Avatar
    You might also want to check if the battery saving settings are putting the app to sleep. I have found that contacts and calander items would not sync because the default setting was to sleep these.
    10-02-2017 11:29 PM
  5. srvctec's Avatar
    Also check that background data isn't turned off for Gmail, either by battery saver mode or otherwise. This is a separate setting from the sleep app setting. It's also in the data saver settings.
    10-03-2017 07:08 AM
  6. ketekojo's Avatar
    My first post. Try this:

    Settings, Battery, Usage, overflow (3 dots), optimize, and kill gmail optimization.
    10-03-2017 08:58 AM
  7. nizmoz's Avatar
    I think just leave things alone. I have found that I have had that happen and it seems to right it self in a day or so. Gremlins.
    Yep... A few days and it started to work again. Lol
    10-03-2017 09:54 PM
  8. nizmoz's Avatar
    My first post. Try this:

    Settings, Battery, Usage, overflow (3 dots), optimize, and kill gmail optimization.
    Not on.

    Thanks everyone. All those that gave advice I tried but none worked other than waiting. Maybe Google had issues. Don't know.
    srvctec likes this.
    10-03-2017 09:56 PM
  9. srvctec's Avatar
    Funny thing is, I posted to try and help and now I have the issue and never had it once on my Note 4 in two years. The problem is I usually don't notice until several or many hours have gone by. Happened a few days ago. Happened yesterday. Happened again this morning, even after a reboot. Not sure what's going on. If I pull down within the Gmail app, it will refresh and load all the emails that should have appeared as I received them. I get about 100 emails a day and it's getting annoying to try and remember to manually refresh.

    Edit: Just checked and Gmail was turned on to be optimized for battery optimization. I just turned it off and will update here if it fixes the issue.
    10-19-2017 12:04 PM
  10. PainFX's Avatar
    Does Google Sync means it is backing up the data, or is it restoring the data?
    10-19-2017 12:27 PM
  11. srvctec's Avatar
    Does Google Sync means it is backing up the data, or is it restoring the data?
    It's keeping the data on Google's servers synced up with your devices. For example, I have a tablet and my old phones with sync turned on. I can use any of those devices and check(send/receive my email on any of them and they will all have the same emails, providing I have them set up the same way.
    PainFX likes this.
    10-19-2017 01:13 PM
  12. PainFX's Avatar
    It's keeping the data on Google's servers synced up with your devices. For example, I have a tablet and my old phones with sync turned on. I can use any of those devices and check(send/receive my email on any of them and they will all have the same emails, providing I have them set up the same way.
    So if I currently have 100 contacts, I add another contact, total 101 contacts, I enable google sync, I will have a total of 101 contacts saved, not 100 contacts correct?
    10-19-2017 01:46 PM
  13. Ca_lvn's Avatar
    Yep ^^^
    PainFX likes this.
    10-19-2017 02:21 PM
  14. srvctec's Avatar
    So if I currently have 100 contacts, I add another contact, total 101 contacts, I enable google sync, I will have a total of 101 contacts saved, not 100 contacts correct?
    Correct, as long as you have the appropriate switches turned on for sync.

    Get to this screen: settings-accounts-Google-select your email account
    PainFX likes this.
    10-19-2017 03:05 PM
  15. srvctec's Avatar
    Just an update. Turning off the switch for Gmail being optimized within the battery optimization setting, made no difference. I still have to manually refresh my Gmail app to get new emails. Worked fine for three weeks straight and then the Gmail app got updated once or twice and busted it, I think, at least for me.
    10-19-2017 03:08 PM
  16. srvctec's Avatar
    And another update. The only way I can get automatic sync of Gmail to work again is to toggle off/on the switch for Gmail in the above screenshot. It's been working fine since I did that but that's also one of the things I tried the other day and it works for a while (few days, maybe) and then stops syncing for whatever reason.
    10-19-2017 05:23 PM
  17. o4liberty's Avatar
    The battery optimization can screw up a lot of apps and settings I learned it the hard way no more battery optimization for me anymore.
    10-19-2017 05:47 PM

Similar Threads

  1. Replies: 8
    Last Post: 07-12-2018, 10:57 AM
  2. How to stop annoying Pop Up ads Galaxy S8
    By CodyJames552 in forum Samsung Galaxy S8 & S8+
    Replies: 14
    Last Post: 01-31-2018, 12:49 AM
  3. Changiing font size and type in S Note
    By allen putzke in forum Samsung Galaxy Note 8
    Replies: 1
    Last Post: 10-03-2017, 11:10 AM
  4. how to disable recent apps hardware key in xolo era marhmallow
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-02-2017, 08:08 PM
  5. my htc phone camera stop working
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2017, 06:17 PM
LINK TO POST COPIED TO CLIPBOARD