1. sop23456's Avatar
    I received Samsung Note Pro 12.2 today.
    After a few steps in the Registration process, this message popup Every Second such that I cannot continue with the Registration process at all.

    "Unfortunately, Samsung link has stopped"

    Restart the new tablet and the popup appears immediately.
    I am still in the first few steps of registration.

    Thank you.
    04-17-2014 02:32 PM
  2. Miami1683's Avatar
    The tablet didn't come with link from the factory. Did you download it right away.

    Sent from my SM-N900V using Tapatalk
    04-17-2014 03:48 PM
  3. sop23456's Avatar
    Thank you for your reply.
    It did automatically download the update.
    The popup still appear every second after the update and restart.
    I finally managed to do a click faster than the popup appears every second and got to Settings Page and Reset the Tablet.

    When I register again, I skip the Gmail email address and everything works fine.
    04-19-2014 08:59 AM
  4. Miami1683's Avatar
    Mine is working flawlessly at this point. I would wipe and re setup like a new tablet then update every app in the system before adding anything else. You can then either just turn link off or make sure it works

    Sent from my SM-N900V using Tapatalk
    04-19-2014 10:36 AM
  5. Helenrmc1998's Avatar
    Purchased the Samsung Galaxy S5 after several hours of enjoying this new device this message popped up "Unfortunately, Samsung Link has Stopped". I called my carriers technical support and was told "I'm sorry, I have never heard of this before, since you are within your 14 days of purchase you should return it to the store". I return it got another and the same issue occured, I returned the second device for a third and it happen again. Out of complete frustration I returned the device for a refund.
    05-07-2014 04:58 PM
  6. theironblitz's Avatar
    This is for the Galaxy S5 with the most current updates only. It may work (and I hope it does!) with other updates or models but I cannot guarantee that.

    It repeatedly pops up "Unfortunately, Samsung Link has stopped working." When you click OK or Report, it pops up the same error again and again.... You get the point. And It appears that it's an app that's pre-installed are automatically updated/downloaded when you buy the phone new. I certainly never had it in "My Apps" on my S4 Active....

    **Here's the Fix**

    Between the error popping up literally every second, and you clicking OK, you can use the phone normally.

    1. Click your multi-window button, click the pie-chart and "End all" applications.
    2. Pull down your notifications tab. It's the only place safe from this bug.
    3. Click settings, in the top right corner.
    4. Scroll down to Application Manager and click it. It's located in the Applications subgroup at the bottom of the menu.
    5. Where it says DOWNLOADED and SD CARD at the top of the screen, scroll right until you get to "RUNNING". Ensure it says "Show cached processes" in the top right corner. If it doesn't just click it til it does.
    6. Somewhere in that menu.... I found it near the top of that menu on my phone.... there will be a process called "Samsung Link" that will repeatedly appear and disappear. It is fiendishly good at hiding but I PROMISE you, it is there. And sometimes it's rather slow at reappearing, so look carefully.
    7. Click it. Try to hit Stop on either processes contained within then hit OK. It keeps failing and disappearing, so you must be persistent. Repeat..... I promise you this works.
    8. Uninstall Samsung Link.
    9. Curse Samsung for their incompetence.

    Cheers, mates!
    kikiaggie, Carol 47 and jpwilber like this.
    05-08-2014 12:22 AM
  7. Vladan Ckrkic's Avatar
    This was most annoying experience with any of Samsung products so far. Download if you don't have Total Commander app. Open it, go to Installed apps, open it, choose Samsung link, tap on it. Touch delete. You will be asked to uninstall. Confirm uninstalling. Problem solved!
    05-08-2014 10:06 AM
  8. kikiaggie's Avatar
    Oh for the love of all that is holy, thank you thank you thank you for this fix!!!!! I will never use this app and accidentally pressed it while scrolling through apps, and that dang message popped up every half second. Did what you said, and it's all gone! YOU ROCK
    05-08-2014 10:38 AM
  9. Les Val's Avatar
    I got my Samsung Galaxy Pro 12.2 today and it is exactly the same story! The same message about Samsung link which stopped working appeared during system update. I finally managed to update all the software on the device, but id did not fix the problem. This message was still blinking in the center of the screen like crazy.

    Here is the way I took care of this: while pressing all the time on "OK" button on this blinking message I managed to get to
    "Settings" in pull down menu in the right upper corner of the screen. In Settings there is "General" tab where you can find "Application manager" and in the long list of applications go to "Samsung link", open it and uninstall.
    05-08-2014 05:47 PM
  10. jrosenbomb's Avatar
    How would I fix it if I haven't set the tablet up yet. I just got a used reset tablet. I can't get past the set up because that message keeps coming up.
    05-09-2014 07:12 PM
  11. Aaron Albrecht's Avatar
    YOU ARE MY FAVOURITE PERSON IN THE WORLD! This was awesome, fixed the problem instantly. You deserve heaps of sex w good looking individuals of your chosen gender, and a bucket full of Milo (it's an Australian chocolate drink, best thing ever)
    05-13-2014 01:03 AM
  12. Alexandru Muresan's Avatar
    i know it happened to me 2 is super annoying what you have to do is very simple

    1. try to open the Play Store
    2.go and type Samsung Link and search for it
    3.open the app and simple UNINSTALL
    and that is it worked for me and i hope is working for you 2

    05-16-2014 03:12 PM
  13. Inmyplums81's Avatar
    Cheers bro, just brought the new Samsung S5 with this error popping up and your info was spot on to rectify the problem. Cheers once again
    05-16-2014 08:13 PM
  14. Jessii Powers's Avatar
    Sweet mother of god THANK YOU! I tried the option above but it didn't work but THIS did the trick. It was fun trying to type Total Commander while that thing was popping up every .5 seconds.
    05-16-2014 09:05 PM
  15. marcus ware's Avatar
    thank you so much! worked perfectly
    05-18-2014 07:24 PM
  16. nezi's Avatar
    Thanks so much, this worked perfectly for me on my new phone.
    05-20-2014 01:36 PM
  17. Dua Arif's Avatar
    I received Samsung Galaxy Grand today.
    After a few steps in the Registration process, this message popup Every Second such that I cannot continue with the Registration process at all.

    "Unfortunately, Samsung link has stopped"

    Restart the handset and the popup appears immediately.
    I am still in the first few steps of registration.

    Thank you.
    11-10-2014 10:44 PM
  18. Maata Kuiperij's Avatar
    wow thanks so much, problem solved. do you know how to solve the "sd card is blank or has unsupported file"?
    12-08-2016 02:31 AM
  19. treetopsranch's Avatar
    Maata, please start a new thread as your subject is different from the original poster.
    12-08-2016 12:14 PM

Similar Threads

  1. samsung galaxy s5, contacts won't show for photos when linked
    By SaraPo629 in forum Samsung Galaxy S5
    Replies: 28
    Last Post: 11-17-2014, 10:07 AM
  2. S5 Samsung Account Log in 'In Progress'
    By aceridgey in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-18-2014, 10:25 AM
  3. 4.4 for Samsung Galaxy S3 GT-I9300
    By HarryDevice in forum Samsung Galaxy SIII I9300
    Replies: 1
    Last Post: 04-18-2014, 01:54 AM
  4. Samsung Galaxy S5 Google Play Edition stock Android
    By thehygene in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-17-2014, 01:14 PM