1. FaTROBoT97's Avatar
    Hey all.

    Hoping someone might have the magic answer to this before sending it in to Samsung for service. My son was playing his Minecraft on the tablet and the tablet turned off cause it was out of power. Went to plug it in ... And nothing. No battery indicator. No screen shimmer. Nothing. Tried holding power down for a bit. Let it charge for a couple hours hoping it would snap out of it. Tried holding Power / Down Volume like a Android phone and nothing seems to work.

    If anyone has a suggestion it would be appreciated.

    Thanks in advance.
    08-07-2014 07:30 PM
  2. acejavelin's Avatar
    Let it sit on the charger overnight... Sometimes when the battery dies it takes a bit to "recover". If that fails try pressing Home, VOL DN, and Power simultaneously for a few seconds, this forces download mode, then cancel it.

    The only other thing I can think of is press VOL DN and plug into a PC... This worked on old Galaxies, although I might be wrong on the key combination.

    Sent from my Nexus 4 powered by Beanstalk ROM and Hellscore kernel
    08-07-2014 09:34 PM

Similar Threads

  1. Replies: 28
    Last Post: 08-11-2014, 10:23 PM
  2. Bug or feature in Nova (Moto G)
    By Emerogork in forum Ask a Question
    Replies: 23
    Last Post: 08-09-2014, 06:11 PM
  3. Samsung S5 Charger plug
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 08-08-2014, 11:03 AM
  4. Humming/Buzzing Charger Plug
    By George H Martin in forum LG G Watch
    Replies: 1
    Last Post: 08-08-2014, 10:52 AM
  5. RCA 7" tablet prob.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-07-2014, 06:38 PM