1. drelky's Avatar
    I have 2-3 12.2 tab pros and 2 of them I am having an issue with the LCD display not turning on. I have narrowed it down to where the LCD cable plugs into the LCD not the motherboard. I think it has to do with the tape or port. I can occasionally get a display by holding pressure on the cable where it inserts to the LCD. Sometimes I can just get the lights on the bottom, sometimes it comes on but no display. I have tried a "new" cable but it did not help. I tried some conductive silver tape and it did not work at as well as samsungs original tape. Anybody have this problem? I don't get why there are 2 conduction spots on the LCD cable where the tape covers. Anybody have this problem? any thoughts on fixing it?
    10-20-2015 08:02 PM
  2. andysin's Avatar
    Drelky have you tried compressed air into the port to clear it. Also how do you know the new cable didnt work did you test it on another device? If you have a problem with two that sounds unusual for both to happen at once???
    10-26-2015 12:19 PM

Similar Threads

  1. Why will I not get push notifications on WiFi?!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-11-2015, 12:41 PM
  2. Replies: 2
    Last Post: 10-23-2015, 02:24 PM
  3. Replies: 1
    Last Post: 10-21-2015, 01:16 AM
  4. Why is my Galaxy Nexus 3 always turning off?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 10-21-2015, 01:14 AM
  5. How do I backup my data on my new Motorola Moto G?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2015, 07:46 PM
LINK TO POST COPIED TO CLIPBOARD