1. StatuSChecKa's Avatar
    Yea I wish...
    I plug in my phone every night. When I unplug it is it obviously at 100%, but by 11AM after using it on and off for a few hours my meter still indicates that I am at 100% battery life. Not until I reboot my phone does it give me an accurate reading. But after that one reboot it will continue to lower like normal.

    What is causing that hiccup before that initial reboot? Note, I am using ADW Launcher (and love it).
    11-15-2011 10:47 AM
  2. SteveISU's Avatar
    Are you using the supplied charger or just some spare one laying around the house? Mine did this at first. Battery pull solved the problem.
    11-15-2011 11:40 AM
  3. methree's Avatar
    Happened to me too. A reboot fix it at the time, but I'm not so sure that was the cure.
    11-15-2011 01:32 PM
  4. StatuSChecKa's Avatar
    Well I'll pull the battery for 15 minutes before I charge it tonight.

    I am using the Skyrocket Cable with an iPhone usb wall block. Pretty soon it I'll cycle the battery until it dies one of these nights too.
    11-15-2011 01:44 PM
  5. moto8dog's Avatar
    Mine is doing exactly the same thing. I believe micro usb is a standard that should just work. I'm travelling in California right now and left the stock charger block and cable at home. I'm using a micro usb cable from a blackberry set with a zag wall/battery pack. I noticed battery indicator doesn't change after reboot, only after removing and replacing the battery. It's done it 3 days in a row now. I even tried installing super status bar. But I don't like it because it puts the carrier and Wifi indicators right on top of each other, uninstalled. Weird problem. Anyone else please chime in!!
    11-17-2011 02:30 PM
  6. SteveISU's Avatar
    **edit** My skyrocket has battery meter issue... - Android Forums

    Like I said, try the supplied charger/block. It is probably an amperage issue.
    11-17-2011 02:41 PM
  7. jslanger's Avatar
    From reading on the phandroid/androidforums the consensus seems to be the wall charger itself. Some have noted this battery meter problem after using an Apple wall charger (which actually looks identical and has the same specs to the supplied Samsung charger). I have used a more powerful charger that came with my HP Touchpad (5V, 2.0A) without incident. Consensus also seems to be that its probably NOT the cable that matters.

    I've had this happen once to me, but I can't recall what I charged it with the night before. Hasn't recurred, but I have not used an Apple charger yet.
    11-17-2011 02:44 PM
  8. netarc's Avatar
    I've been having this same"battery always at 100%" issue as well, problem persists even after the recent 2.3.6 update. In my case, rebooting the phone causes the battery to display the correct battery status.

    I think the issue started upon use of a non stock charger, specifically the Belkin surge suppressor + dual USB port plug; I believe the USB ports on this charger deliver 1 amp.

    I'm going to revert to the stock charterer for a few days to confirm whether the problem is specifically due to a non stock charger.
    11-26-2011 11:54 AM
  9. CZ Eddie's Avatar
    Mine does this sometimes also. I use a 3rd party charger block in my car. And the OEM samsung charger at home. I'll monitor to see if it ever happens on the Samsung charger.
    Reboot fixes it. Doesn't always happen.
    11-26-2011 12:59 PM
  10. psiclne's Avatar
    Got the SR 2 weeks ago and been using the OEM charger and this happens to mine all the time. I'm completely stock 2.3.5 and was about to return it last night but the guy at the at&t store said to wait for the 2.3.6 update (which doesnt show up for me) - only problem is I only have 2 weeks left to return this thing. Is it a hardware issue or software?
    12-23-2011 04:19 PM
  11. st0nez0r's Avatar
    Mine did this but it was caused by "Juice Defender" app. I was able to consistently reproduce the issue.

    A lot of people seemed to like the app so I picked it up for 5.00, but If you ask me... waste of money for the sake of a couple extra hours... more of a hassle than anything,
    psiclne likes this.
    12-24-2011 10:46 AM
  12. capcanuck's Avatar
    If you are rooted and have clockwork mod, try clearing all cache (dalvik and partitions ) and clear battery stats...

    Sent from my SGH-T989 using Tapatalk
    12-26-2011 04:18 PM
  13. ve2aed's Avatar
    The problem is that most 3rd party chargers have usb pins 2+3 connected through a resistive voltage divider to accommodate Apple products , other products such as HTC to date ignore USB pins 2+3 , Samsug prooducts look for a short between pins 2 and 3 , if you take a after market charger and measure resistance you will see approximately 30K ohms between pins 2+3 , The Samsung phone will charge at haf rate 0.2% per minute and the charge indicator will not work properly , taking this aftermarket charger (lighter plugs included) breaking them open and soldering a short between 2+3 will solve this issue completely , the Samsung uses the new convention of USB . Please read the Wikipedia excerpt below ...all of my modified adaptors work great and charge in half the time prior to this mod...If you're lazy simply slit open a USB cable and short pin 2 and 3 usually green and white wires . Hope this helps everyone .... Regards Howard Rosen VE2AED

    Charging ports and accessory charging adapters

    The Battery Charging Specification of 2007 defines new types of USB ports, e.g., charging ports.[43] As compared to standard downstream ports, where a portable device can only draw more than 100 mA current after digital negotiation with the host or hub, charging ports can supply currents above 0.5 A without digital negotiation. A charging port supplies up to 500 mA at 5 V, up to the rated current at 3.6 V or more, and drop its output voltage if the portable device attempts to draw more than the rated current. The charger port may shut down if the load is too high.

    Charging ports exist in two flavors: charging downstream ports (CDP), supporting data transfers as well, and dedicated charging ports (DCP), without data support. A portable device can recognize the type of USB port from the way the D+ and D- pins are connected. For example, on a dedicated charging port, the D+ and D- pins are shorted. With charging downstream ports, current passing through the thin ground wire may interfere with high-speed data signals. Therefore, current draw may not exceed 900 mA during high-speed data transfer. A dedicated charge port may have a rated current between 0.5 and 1.5 A. There is no upper limit for the rated current of a charging downstream port, as long as the connector can handle the current (standard USB 2.0 A-connectors are rated at 1.5 A).

    Before the battery charging specification was defined, there was no standardized way for the portable device to inquire how much current was available. For example, Apple's iPod and iPhone chargers indicate the available current by voltages on the D- and D+ lines. When D+ = D- = 2V, the device may pull up to 500 mA. When D+ = 2.0 V and D- = 2.8 V, the device may pull up to 1000 mA of current.[44]

    Dedicated charging ports can be found on USB power adapters that convert utility power or another power source e.g., a car's electrical system to run attached devices and battery packs. On a host (such as a laptop computer) with both standard and charging USB ports, the charging ports should be labeled as such.[43]

    To support simultaneous charge and sync, even if the communication port doesn't support charging a demanding device, so called accessory charging adapters are introduced, where a charging port and a communication port can be combined into a single port.

    The Battery Charging Specification 1.2 of 2010 [9] makes clear, that there are safety limits to the rated current at 5 A coming from USB 2.0. On the other hand several changes are made and limits are increasing including allowing 1.5 A on charging ports for unconfigured devices, allowing high speed communication while having a current up to 1.5 A and allowing a maximum current of 5 A.
    02-06-2012 01:57 PM