1. gaygeek's Avatar
    I thought I'd post my experience with losing my data connection and the solution, since AT&T won't be of any help...

    Yesterday, mobile data stopped working on my new Skyrocket--I've had it since Tuesday and was working fine. WiFi still worked fine. However, any attempt to access the internet on mobile data would fail. I am not in an LTE market (Minneapolis), so I am using HSPA+ for mobile data. I tried many things:
    - Removing battery and sim card
    - Restarting (many times)
    - Trip to the AT&T store--they couldn't figure it out... the phone was provisioned properly, and they verified my SIM card worked fine in another phone. They concluded it must be the phone itself, and since I didn't get it from them, I would have to return it to Amazon Wireless where I bought it for $0.01. I called and Amazon Wireless said they don't even list the phone anymore, so they couldn't exchange it for the same phone (but I could a different one). They suggested I contact Samsung.
    - Hard reset

    Well... after all of that, I found this thread:
    [FIX] AT&T SGS2 Data Speed Issue's (Correct APN Settings) - xda-developers

    This describes how to change your APN settings for AT&T for HSPA+ markets (in the context of faster speeds than the default APN). Well, I found that the setting changes described there worked great--mobile data restored, and my speedtest results have been faster too (2-5Mbps, as opposed to 1-3 before). Anyway, figured I share this info since it was very frustrating and thought it might save some frustration for someone else.
    11-27-2011 08:46 PM
  2. Dmunjal's Avatar
    Do you still get Visual Voicemail with the new APN? You'll have to change it back when LTE is available?
    11-27-2011 10:37 PM
  3. gaygeek's Avatar
    I use Google Voice for voicemail, so I'm not sure if visual voicemail works or not. I am assuming that I will need to change it back when LTE is available or if I'm traveling somewhere LTE is available. Unlike the linked post described, I did not remove the original AT&T pta APN (I couldn't), so it would be a simple matter of selecting it instead of the newly-created one.
    11-27-2011 10:51 PM
  4. SubieSTi's Avatar
    I've been having issues with my data too. Went in to the AT&T store yesterday and they weren't able to solve it there, nor was the tech support able to solve it either when the store called them up. They advised me to do a Factory Reset which I did yesterday and worked for a while. Then this morning I lost the HSPA again. Since the Factory Reset wipes all the apps and everything I figured I'd try poking around myself and see if I could manage by doing something less drastic.

    Was going to try the method on the thread you linked to, but I figured that before I went through all that I would just reset the APN to default settings and that seems to have worked for the moment. I just hit the reset to default button on this screen instead of going through the trouble of adding the new APN's that the linked thread went through.

    CandiBp#AC likes this.
    12-12-2011 10:12 AM
LINK TO POST COPIED TO CLIPBOARD