1. SubieSTi's Avatar
    Hi guys. New to the forums and new to Android (~1 mo.) though I've been reading up the news end of the site for a while now when I was doing my phone shopping. I ended up with an AT&T GS2 Skyrocket to replace my vintage iPhone, and so far results have been mixed.

    My latest problem is the fact that I can't connect to a WiFi network that isn't broadcasting its SSID. Up until a week ago or so it worked just fine, but lately unless the SSID is visible it won't connect. I know the keys are entered correctly into the phone as I can change the WiFi router to broadcast the SSID and the phone will hook up just fine. Any body else run into this and have you found a fix other than leaving the WiFi broadcasting the SSID?

    Also had to do a master reset this Sunday as the phone lost the HSPA connection on Friday and doing the standard turn off & back on, pulling the battery, etc. didn't solve the problem. Went in to the store and they weren't able to solve it there, so they had me do the master reset. I thought that might solve the WiFi connection problem too, but the reset didn't have any effect on that.

    Thanks.
    12-12-2011 08:33 AM
  2. Cuboid's Avatar
    I have a very similar problem. The Skyrocket keeps searching but never detects the WiFi network. No amount of restarts has helped. The WiFi issue appeared suddenly after having worked without any glitches during the first week.
    This is quite annoying since I'm out of the country on vacation and my only connection is Skype at WiFi Hotspots...
    12-23-2011 05:16 PM
  3. jess.hickey's Avatar
    I noticed something today with wifi and android in general I think. I set up a network at my mom's and my phone couldn't even see it and my xoom would see it but wouldn't connect. Let's call the network "It's My Netwok". I changed it to ItsMyNetwork and both devices connected right up.

    It does appear as if there is something with the ssid requirements in android.
    12-23-2011 05:40 PM
  4. Chrstauffe's Avatar
    I had an issue at my parents over the holiday and it turned out to be the ATT WIFI tool called AT&T Smart Wi-Fi. interestingly enough it is not listed as not compatible with the skyrocket but it was when i first installed it a few weeks ago.

    The app was actually turning off my WIFI every time i put in the code for their WEP account.
    12-28-2011 07:04 PM
  5. PTSniglet's Avatar
    My Skyrocket definitely had working wifi as of about a week ago, and then today, I went to connect to the WiFi in my apartment, and out of the blue it won't turn on & only says "Error" under "WiFi" when I go into WiFi Settings. I took it to the ATT repair/warranty center and they said it is a problem they've had with several Samsung's & they've recently issued software updates to deal with it...they don't have one yet for the Skyrocket, but expect one very soon (or so they said).

    Does anybody know how to fix this.
    12-28-2011 11:18 PM
LINK TO POST COPIED TO CLIPBOARD